Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 - FF10RC1 [@ msvcrt.dll | jpins7.dll | jpioji.dll - nsJVMManager::StartupJVM] [@ MSVCRT.DLL - nsPluginHostImpl::GetPluginFactory]

VERIFIED FIXED

Status

()

--
critical
VERIFIED FIXED
14 years ago
7 years ago

People

(Reporter: c10, Assigned: bugs)

Tracking

({crash, fixed-aviary1.0, topcrash+})

1.7 Branch
x86
Windows XP
crash, fixed-aviary1.0, topcrash+
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20041026 Firefox/1.0RC1

After using Software Update to upgrade Firefox 0.10.1 to Firefox 1.0 RC1,
Firefox refuses to start and crashes instead.  See Talkback TB1561554Q for an
example of crash data.

Reproducible: Always
Steps to Reproduce:
1. Change app.update.url to
http://update.mozilla.org/update/firefox/en-US-1.0-rc.rdf
2. Run Software Update to upgrade to Firefox 1.0 RC1
3. Restart Firefox and see the crash

Actual Results:  
Crash in firefox.exe in msvcrt.dll.  Event viewer says: Faulting application
firefox.exe, version 1.0.0.0, faulting module msvcrt.dll, version 7.0.2600.2180,
fault address 0x00037c7e.

Expected Results:  
Started Firefox 1.0 RC1 without problems

Faulting application firefox.exe, version 1.0.0.0, faulting module msvcrt.dll,
version 7.0.2600.2180, fault address 0x00037c7e.
(Reporter)

Updated

14 years ago
Flags: blocking-aviary1.0?

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Keywords: crash
Version: unspecified → 1.0 Branch
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB1561554Q

msvcrt.dll + 0x37c7e (0x77c47c7e)
jpins7.dll + 0x188f (0x6d35188f)
nsJVMManager::StartupJVM 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/modules/oji/src/nsJVMManager.cpp,
line 655]
nsJVMManager::MaybeStartupLiveConnect 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/modules/oji/src/nsJVMManager.cpp,
line 876]
NS_CreateScriptContext 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/dom/src/base/nsJSEnvironment.cpp,
line 2013]
nsDOMScriptObjectFactory::NewScriptContext 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/dom/src/base/nsDOMScriptObjectFactory.cpp,
line 82]
nsWebShell::GetInterface 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/docshell/base/nsWebShell.cpp,
line 299]
nsGetInterface::operator() 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpcom/glue/nsIInterfaceRequestorUtils.cpp,
line 53]
nsCOMPtr_base::assign_from_helper 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 114]
nsAppShellService::GetHiddenWindowAndJSContext 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 932]
nsAppShellService::SetXPConnectSafeContext 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 202]
nsAppShellService::CreateHiddenWindow 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 485]
xre_main 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/toolkit/xre/nsAppRunner.cpp,
line 1826]
main 
[d:/builds/tinderbox/firefox-1.0/WINNT_5.0_Clobber/mozilla/browser/app/nsBrowserApp.cpp,
line 58]
kernel32.dll + 0x16d4f (0x7c816d4f)
out of curiosity I went through the steps to repro this on linux fc2 (from using
1.0PR), but the software update wizard wouldn't complete. after downloading the
Firefox browser, the wizard said:

Problems During Update: Firefox encountered problems when updating your
software, and as a result not all components could be updated. [Details]

clicking the Details button brought up a dialog with a xml parsing error (the
titlebar said "Gecko"):

XML Parsing Error: undefined entity
Location: chrome://mozapps/content/update/error.xul
Line Number 10, Column 16:

title="&errors.title;"
-------^

possible l10n issue, or something else?

in any case, the software update didn't succeed (but no crashing).
forgot to add: the version of 1.0PR I've got has app.version = 0.10.1.
*** Bug 266379 has been marked as a duplicate of this bug. ***
Currently there are other 179 incident reports with nearly the same stack trace:
http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=1&searchby=stacksig&match=contains&searchfor=msvcrt.dll+%2B+0x37c7e+%280x77c47c7e%29&vendor=All&product=All&platform=All&buildid=&sdate=&stime=&edate=&etime=&sortby=bbid
Keywords: topcrash
Summary: Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 → Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 [@ msvcrt.dll + 0x37c7e][@ nsJVMManager::StartupJVM]

Comment 6

14 years ago
Tried it on Mac without crash. I am using Steven Michaud's JEP 0.86 plugin. That
crashed on my banking site (doesn't do that in Mozilla).

But the update feature cycled through and presented a civilised dialog window
informing me there were no updates.

Comment 7

14 years ago
*** Bug 266401 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
*** Bug 266428 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
Created attachment 163672 [details]
Installation Log

The installation log shows an error during installation

Comment 11

14 years ago
Here are my talkback reports, but I suppose they are the same as everyone's

TB1570569H
TB1570583K
TB1570591W
TB1570602G
TB1570646Y
TB1570673H

Comment 12

14 years ago
This is the "important" part of the installation log I think
-------------------------------------------------------------------------------
http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/1.0rc1/windows-xpi/en-US.xpi
 --  2004-10-28 12:14:56
-------------------------------------------------------------------------------

     ** initInstall: platformNode=win
     en-US Langpack (version 1.0)
     --------------
     ** initInstall: 0
     ** fProgram: C:\Program Files\Mozilla Firefox\
     ** addDirectory() returned: 0
     ** fTarget: C:\Program Files\Mozilla Firefox\defaults\
     ** addDirectory() returned: 0
     ** fTarget: C:\Program Files\Mozilla Firefox\searchplugins\
     ** addDirectory() returned: 0
     [1/101]	Replacing: C:\Program Files\Mozilla Firefox\searchplugins\eBay.src
     [2/101]	Replacing: C:\Program Files\Mozilla Firefox\searchplugins\eBay.src
     [3/101]	Installing: C:\Program Files\Mozilla Firefox\browserconfig.properties
     [4/101]	Replacing: C:\Program Files\Mozilla Firefox\browserconfig.properties

....

     [97/101]	Register Locale: jar:resource:/chrome/en-US.jar!/locale/necko/
     [98/101]	Register Locale: jar:resource:/chrome/en-US.jar!/locale/autoconfig/
     ** InstallLocale() failed. - nsresult code: 0x80004005
     ** InstallPackage() failed. - nsresult code: 0x80004005
     ** Failed to register chrome. - nsresult code: 0x80004005
     ** performInstall() returned: -239

     Install **FAILED** with error -239  --  2004-10-28 12:15:04

Comment 13

14 years ago
Maybe I found why the installation raised the error:

in the en-US.xpi file, in the install.js there is the following command:

registerChrome(chromeType, cf, "locale/autoconfig/");

but there is no local/autoconfig/ folder in the en-US.jar

Comment 14

14 years ago
*** Bug 266524 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
This is a major topcrash for Firefox 1.0 RC1 and the latest Talkback data is
posted in bug 266524.
Keywords: topcrash → topcrash+
Summary: Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 [@ msvcrt.dll + 0x37c7e][@ nsJVMManager::StartupJVM] → Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 - FF10RC1 [@ msvcrt.dll | jpins7.dll | jpioji.dll - nsJVMManager::StartupJVM]

Comment 16

14 years ago
I was able to reproduce this crash on WinXP, but oddly Talkback isn't coming up.
Firefox simply won't launch...I keep getting the WinXP crash dialog instead of
Talkback. Here is what I did:

1. Installed FF 1.0 PR1 and ran it once with an existing profile
2. Changed the update url in about:config to:
http://update.mozilla.org/update/firefox/en-US-1.0-rc.rdf
3. Ran update from the options menu
4. Restarted Firefox... can't get it to startup at all.

Ben:  Is that .rdf file correct?  Any other update urls to try to see if this
crash goes away?

Comment 17

14 years ago
> I was able to reproduce this crash on WinXP, but oddly Talkback isn't coming up.
... 
> 1. Installed FF 1.0 PR1 and ran it once with an existing profile

If by any chance you didn't do a custom install, you won't always get Talkback.
 It's enabled/installed with a default installation only a certain percentage of
the time (either 10% or 25%, methinks).  Custom installs with Talkback selected
will always get Talkback.

Comment 18

14 years ago
After attempting to update Firefox 0.10.1 on Windows 98, I have not experienced
anything that seems like an actual crash (and as far as I recall, the update
process appeared to be successful).  However, Firefox now refuses to start at
all.  When I try to run it, I just get a small title-less window that reads:

   XML Parsing Error: undefined entity
   Location: chrome://browser/content/browser.xul
   Line Number 910, Column 33:

                         chromedir="&locale.dir;">
   ---------------------------------^

Closing that window closes the program.

I've looked at my install.log file, and the relevant portion is essentially
identical to what is shown in comment #12 (only the installation time differs as
far as I can tell).  I have no idea why I'm getting this XML error instead of a
full-fledged crash (Win 98 vs. Win XP?), but the browser doesn't work either
way.  Are there plans for Software Update to eventually recognize an "Install
**FAILED**" result like this and back out the changes?  (Yes, that probably
belongs in a separate bug.)

In case it's relevant, at the same time as the RC1 update I also asked to update
the Quality Feedback Agent and the Document Inspector, which were listed as
having available updates under "Optional Components".

Comment 19

14 years ago
I have the same experience with Steuard - the update seems to be failed, a bunch
of libraries are missing in the component directory, such as gklayout.dll.
Firefox can't start even without java plugin installed.

Comment 20

14 years ago
chromedir="&locale.dir;">

should have been

chromedir="&locale.dir;">

Comment 21

14 years ago
Robin, you are completely wrong, and this bug isn't about the entity error anyway.
Kyle, this is a static build, so there is no gklayout.dll... the firefox.exe
executable is about 6-7MB which contains almost everything. 

Comment 23

14 years ago
Oh sorry, I didn't notice that. I just tried it again - installed 1.0PR, no java
plugin, update to 1.0rc1, then I got the exactly same error message described in
comment 18. BTW, if the java plugin installed, I did get the same crash as
comment 0 said.
Created attachment 163926 [details] [diff] [review]
patch

Only attempt to register chrome for autoconfig when it's being built. The
standalone installer seems not to care about errors being returned, but the in
place installer sure does, and it bails.
Fixed. 
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 26

14 years ago
Comment on attachment 163926 [details] [diff] [review]
patch

a=asa for aviary checkin.
Attachment #163926 - Flags: approval-aviary+

Updated

14 years ago
Keywords: fixed-aviary1.0
I tried this on linux fc2, and after the components are downloaded the software
update wizard says that it's unable to complete the update. The Details button
reveals an error saying that the Firefox Browser (read only) could not be
downloaded.

is this expected? I did use the same app.update.url string specified in comment
0 --perhaps that's out of date?

Tracy, what do you see on WindowsXP today?
still crashes on restart following steps in comment 0.

http://talkback-public.mozilla.org/talkback/fastfind.jsp?search=2&type=iid&id=TB1706002G
Status: RESOLVED → REOPENED
Keywords: fixed-aviary1.0
Resolution: FIXED → ---
Tracy, your FF build ID shows 2004100109 which isn't a todays build. You have to
test it with a most recent build. Have you done that and only the ID is wrong?
Henrik, testing app update with the most recent build is pointless.

This bug is about updating Firefox the Application from the 1.0 PR build of
September to the current 1.0RC1 build.  But it seems that didn't work as
expected.  It only updated to the security 1.0.1 release of Oct 1st. then
crashed on restart. Is this URL,
http://update.mozilla.org/update/firefox/en-US-1.0-rc.rdf, from the steps to
reproduce still valid for this to be tested with? 
Ah, Ben just explained to me how to have the latest build fool the server by
changing app.version to 0.9.3.  The update mechanism works on the latest Windows
build.  (although it also *updated* to the 1.0.1 build)  No crash now.

Resolving again.

Offering a humble appology to Henrik.  


Marcia is seeing hang in update.  I believe that is different mac bug than this.

sorry about the noise.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED
following tracy's info (setting today's build app.version == 0.9.3), I can get
this work on linux fc2: it updates it to use 1.0PR (0.10.1). a bit of an odd
"downgrade" but it shows that the software app update mechanism does work on
windows and linux.
verified Windows FF build 2004-11-04-06-0.11
Status: RESOLVED → VERIFIED

Updated

14 years ago
Summary: Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 - FF10RC1 [@ msvcrt.dll | jpins7.dll | jpioji.dll - nsJVMManager::StartupJVM] → Crash on restart of Firefox 1.0 RC1 after updating from Firefox 0.10.1 - FF10RC1 [@ msvcrt.dll | jpins7.dll | jpioji.dll - nsJVMManager::StartupJVM] [@ MSVCRT.DLL - nsPluginHostImpl::GetPluginFactory]

Comment 34

14 years ago
*** Bug 266339 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
Crash Signature: [@ msvcrt.dll | jpins7.dll | jpioji.dll - nsJVMManager::StartupJVM] [@ MSVCRT.DLL - nsPluginHostImpl::GetPluginFactory]
You need to log in before you can comment on or make changes to this bug.