Google and Firefox Start not correct language (Catalan, Dutch, French, multi-lingual countries)

RESOLVED FIXED

Status

()

RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: toniher, Assigned: Pike)

Tracking

({l12y})

unspecified
Points:
---
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ca-AD; rv:1.7.5) Gecko/20041107 Firefox/1.0

Google and Firefox Start are not in Catalan by default in countries with a local
version of Google (.es, .fr, .it, etc.)

It works in other countries where there is not a Google local version, and you
get the Catalan version after Google gets the language from the browser language
header.
Most Catalan users would also prefer not using a local version of Google, just
google.com, that's the reason that
http://lxr.mozilla.org/l10n-aviarybranch/source/browser/locales/ca-AD/searchplugins/google.src
is google.com. 
In next versions, we may add 'hl=ca' tag to Google search and this would repair
that Google would be in Catalan but it would not be google.com and Start Firefox
Page would continue appearing in the default language of the local version of
Google. 

The problem in google searches is client=firefox-a tag. It triggers the search
into the local version of google with the default language in that domain. 

Here two example screenshots:

ftp://ftp.softcatala.org/pub/beta/firefox/bugs/google/bad.png
ftp://ftp.softcatala.org/pub/beta/firefox/bugs/google/good.png


Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
Firefox Start Page and Google searches under google.com in Catalan.
*** Bug 272586 has been marked as a duplicate of this bug. ***
*** Bug 269354 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Assignee: nobody → firefox-support

Comment 3

13 years ago
*** Bug 293904 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
*** Bug 286554 has been marked as a duplicate of this bug. ***

Comment 5

13 years ago
Morphing bug. See bug 286554 and bug 293904 for more explanation.

Most of our localisations have added their language in the start-URL (f.i.
<http://www.google.be/firefox?client=firefox-a&rls=org.mozilla:FR-fr:official>,
but Google insist on using the ip-address to decide what language to use. That
doesn't work in multi-lingual countries. Unlike the Google search-engine,
there's no way to switch to a different language either.

When searching, we're also passing the version, but Google also ignores it.

This is perceived as insulting by many minorities, and is also illegal in some
countries. In Belgium it definetely is, for sites that are trying to sell
something. Ofcourse, Google is an US company, and there's no commerical
contract, so it doesn't really apply, but still. How would you like it that you
fire up Firefox for the first time (with an English localised build), but you do
this in Russia, and you get redirected to a Russian language website, with no
means to switch back to English ? That's the effect !

I know this is a Google internal issue, but can't we put some pressure for the
start-page at least ? The minimum requirement would be a language selector on
the start-page. If Gogole would be able to recognize the language that we're
already passing in the url, then it woudl even be better.
Component: Other → General
Flags: blocking-aviary1.1?
Product: Mozilla Localizations → Firefox
Summary: Google and Firefox Start not in Catalan by default → Google and Firefox Start not correct language (Catalan, Dutch, French, multi-lingual countries)
(Reporter)

Comment 6

13 years ago
Hello,

I will try to explain the position of our community regarding this bug the best
I can for all non-Catalan people. I think I will be able to improve and
complement my first comment. 

I usually receive comments from many Catalan users lamenting that their start
page is not in Catalan (if they are in Spanish state, in Spanish for instance,
since this is the default language in google.es). But also, many users find
unnecessary or even offensive that they are forcefully moved to a local version
of google (either google.es or google.fr), even if they can change their
language preferences. Plainly, they do not want to be redirected to Google
*Spain* or Google *France*, for example. 
There were a lot of protests and a campaign among Catalan users when Google
started to force local redirection: 

* Google.es? No, gràcies:
http://www.campanyes.org/homepage.php?&op=inici&idcampanya=47

And some users asked for a Google Andorra (Andorra is an independent Catalan
country in contraposition with Balearic Islands, Catalonia or the Valencian Country)
http://www.campanyes.org/homepage.php?&op=inici&idcampanya=131

As a counter-response, several unofficial Google mirror sites started to appear:

http://google.carlesmillan.com/
http://latevaweb.com/google/
http://www.nitium.com/googlecat/
http://www.googlevalencia.com/
http://www.googlecat.com/

Firefox start page default language (Spanish, for instance) may be changed and
country reference (Spain, for example) may  be removed by playing with different
Google preferences. However, many people are not aware of this possibility and
get a bad first impression despite we try to spread a workaround solution of
this problem among users. By sure, many users did not even know the specific
Catalan tips we made for Firefox Start Page.

Since this bug is addressed to Mozilla community, I would ask that, no matter if
Google finally decide to change current redirection policy, Catalan Firefox
version should offer a default start page in *Catalan* with *no country* reference.

You can get Catalan language if we add hl=ca to default start page.
http://start.mozilla.org/firefox?hl=ca

but I have not found an easy way to prevent any explicit country specification
and redirection.

On the other hand, this Google page has a correct behavior, the same as I think
Firefox Catalan Start Page should have:
http://www.google.com/webhp?hl=ca
Searches are made from this page as it would be preferred for our user community
-> In Catalan language and without any country enforcement.

Of course, all this is connects to Google searchplugin searches and how searches
are made from Firefox Start Page. Since the first time Firefox start go to Start
page, it already stores a cookie with language and redirection preferences,
which affects searches and presentation in the future.

As a solution for this problem, we would include hl=ca parameter in Google
current searchplugin, Start page in translated string would be changed from:
http://start.mozilla.org/firefox to http://start.mozilla.org/firefox?hl=ca
but we would thank a redirection of start.mozilla.org to
http://www.google.com/webhp instead of current implementation.

Would that last option be possible?

Best regards,
(Reporter)

Comment 7

13 years ago
> but we would thank a redirection of start.mozilla.org to
> http://www.google.com/webhp instead of current implementation.
> 

I mean a http://www.google.com/firefox with same behavior as
http://www.google.com/webhp regarding to redirection (none) and language (as
specified by hl=ab).
Hardware: PC → All
Keywords: l12y

Updated

13 years ago
Assignee: firefox-support → rebron
(Reporter)

Comment 8

13 years ago
Hello,

I have been testing different default homepages with current Catalan tinderbox
builds, and I have noticed that it does not matter what I may try to solve by
myself with translated strings (totally or partially), since default homepage is
hardcoded by default (by pressing Home button or Web preferences) with this URL:

http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:ab-CD:official
where ab-CD is Firefox locale.
For current Catalan Deer Park:
http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:ca:official

Since Firefox 1.1.x release is approaching and this bug is rather old, I'm
afraid that there may not be any intention to solve this.

This should be changed, default homepage URL should at least contain hl=ab
parameter in order to prevent that this may be displayed in a different language.

And, as I have explained before and I say it again, many users also complain and
feel offended because of Google redirection policy which is currently now being
followed blindly by Mozilla products. Indeed, many Catalan users do not want to
be redirected to google.es or google.fr if they do not decide so. Firefox start
pages are doing this without their consent. Expert users may change this and we
try to explain them how, but many do not know and feel insulted.


As I said before, if google.com/firefox had the same behaviour of
google.com/webhp, which takes the default language preferences from language
browser preferences without any country enforcement... there would be no problem.
As I can see, there is no need of hl=ab then.

Please, I ask one of these two options in order to finally solve this problem
after several months this bug was first opened:

1 * Change the behavior of start.mozilla.org/firefox
2 * Allow default homepage be ACTUALLY coded in localizable strings, so a proper
solution may be discussion between translators and MoFo.

So, any of these options may warrant Firefox to be fully respectful with
languages such as Catalan and not to participate in any kind of political bias.

How would en-US or en-GB Firefox users would feel if they were redirected to
google.fr with default interface in French, or pl users to google.ru in Russian,
or the other way around? Catalan users, as many others which have complained in
this bug, deserve the same respect as the former ones.
I think the solutions I have proposed are currently the most sensible ones, and
I would sadly lament if they were ignored.

Best regards,
This is a google issue that we don't have direct control over, but hopefully
Rafael can communicate these issues to the appropriate individuals.
Flags: blocking-aviary1.1? → blocking-aviary1.1-
(Reporter)

Comment 10

13 years ago
I think it is partially true that there is 'no direct control over'.
AFAIK, default homepage must be coded within Mozilla CVS, must not it? So,
suitable parameters or changes might be performed in order to improve this if
Google were reluctant not to change current implementation.
However, I hope this will not be necessary if Rafael can finally make Google
change their minds.

Thanks in advance.

Comment 11

13 years ago
My Firefox Home Page suddenly became Dutch.  I downloaded a new version 1.06 and
though I specified English language, it still came down Dutch.
(Reporter)

Comment 12

13 years ago
Hello,

connecting from nearby Barcelona. Google (and Firefox Start Page) displays in
the preferred language specified from Web preferences. 
This is truly a very positive step, and I would like to thank this change. It is
also a good thing that users can decide from their preferences which language
may use in Google interface.
However, I must continue lamenting that redirection policy is still being
enforced, a practice that is offensive for many Catalan speaking users.

Best regards,

Comment 13

13 years ago
Just an info from a belgian punct of view:
www.google.be use a cookie named PREF
(for example for me:
ID=3bc5fd97419394d6:LD=fr:NR=10:TM=1093964276:LM=1120742185:S=bPzNQ2g6XN317SVe)
Google.fr and google.com has the same

--> info: LD=fr which is the language...

By default, www.google.be, without cookie set, display the page in dutch...
To set the cookie, you have to click to "Frans" (is is so stupid as french
speaking belgian seek for "Français", and not Frans ... :-)

So, the problem, when you install firefox for the first time in belgium is that
the start firefox/google page is in Dutch ... and there is no way to change the
language on this page ...

a french speaking belgian with basic knowledge of internet (call him Marcel
Dupont instead if John Doe :-) ) don't know it has to go to www.google.be to
change the language

Comment 14

13 years ago
It doesn't seem to be a problem anymore.
I just tested it and now Google determines the good language by looking at the
Accept-Language header sent by the browser.
So the FR-fr (or whatever) contained in the start address isn't even necessary.
WFM

Comment 15

13 years ago
(In reply to comment #14)
> It doesn't seem to be a problem anymore.
> I just tested it and now Google determines the good language by looking at the
> Accept-Language header sent by the browser.
> So the FR-fr (or whatever) contained in the start address isn't even necessary.
> WFM

No, it's not fixed.

- my HTTP_ACCEPT_LANGUAGE is "en-us,en;q=0.5"
- my HTTP_USER_AGENT is "Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US;
rv:1.8b4) Gecko/20050916 Firefox/1.4"
- I'm using the default start-page for this version, which is 
http://start.mozilla.org/firefox?client=firefox-a&rls=org.mozilla:en-US:official
- I cleaned all my cookies, so there would be no trace of any language setting
in a google.* domain

From all this information, Firefox (thru Google) should present me a homepage in
English. It's indicated in the user-agent, the accept-language header and the
homepage URL.

However, when Google recieves the URL (after the redirect from
start.mozilla.org), it notices that I'm using a Belgian ip-address, and so it
redirects me to
http://www.google.be/firefox?client=firefox-a&rls=org.mozilla:en-US:official .
That's the same process that happens when I surf to www.google.com, I get
redirected to www.google.be. 

That page is presented in *Dutch*, despite that the language is encoded in the
URL. In my case that actually right (I use English on the web, my Dutch is my
mother tongue), but 44% of Belgium does not speak Dutch, but French or German.
French-Canadians and Catalans are even a smaller minority in their country than
French-speaking Belgians, so Google would make even less errors. But look at it
another weay : if you're a US citizen, and you try to surf here from your hotel
room, you will see a Dutch language homepage, that might be completely
unreadable for you. If you go to Russia, you will see a Russian language
homepage, etc ...

http://www.google.be/ is also presented in Dutch, but gives you the opportunity
to switch to French, German or English. If you know one of those, you can switch
back to a more familar language. It's still a problem for Chinese or Russian
people though, even if they don't know enough English to continue.

The problem is that the Firefox startpage does NOT give the opportunity to
switch to another language ! Just look at
http://www.google.be/firefox?client=firefox-a&rls=org.mozilla:en-US:official and
 try to guess where you would have to click to change the language.

The problem is two-fold :

- Google should use the hint in the URL to select the correct language. This
will help foreigners to auto-select the language they use even when visiting
another country. It will also help people from minority groups that has chosen
another language for political reasons (someone browsing in Catalan would
*really* be offended when be given a Spanish language page) or because they
can't understand the default language at all (many Wallons do not speak Dutch at
all for instance). It's the user who chooses the language, not Google.

- the startpage should give you the opportunity to switch to another language.
This would require no changes in Google at all, except for a few additional
links on the page.


It seems to me that most english-speaking users do not realize how important
this is. Let's look at it another way : since the majority of users on the web
are Chinese, possibly without the slightest knowledge of English, Google should
present its default interface in Chinese, without the possibility to switch to
English. They're the majority after all. How would you feel then ? 

Comment 16

13 years ago
Note: google does not use their own cookie to use the desired language of the
user (which would be another solution), but the point is that the user
explicitely requested the desired language in the URL. And note that a
first-time user will not have the cookie anyway.

As a demonstration, suppose you travel to Moscou (Russia), with your english
version of Firefox. Your default homepage would be
<http://www.google.ru/firefox?client=firefox-a&rls=org.mozilla:en-US:official>.
Try to change your language here - you can't find it without being able to read
Russian. In Poland it would be
<http://www.google.pl/firefox?client=firefox-a&rls=org.mozilla:en-US:official>.
In Finland
<http://www.google.fi/firefox?client=firefox-a&rls=org.mozilla:en-US:official>

Comment 17

13 years ago
Let me just mention that the "the desired language is encoded in the URL" is
to some extent a misconception.
The tag we deliver includes the locale of the build you use for the default
startpage pref, but it does not for the one in the bookmarks, for example, and
it shouldn't be required. The query string is merely an indication that you're
coming from the default pref startpage, nothing else.

The real problem is that google doesn't honor the accept-lang header, and that's
the way to solve it, at least from my firefox-the-browser perspective.

One EVIL, and I mean really evil, hack around this would be to ship firefox with 
a default cookie to set the google language.

Comment 18

13 years ago
(In reply to comment #15)
I just tested it with
Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8b4) Gecko/20050823 Firefox/1.0+
and it works perfectly.
If my accept-lang header is set to fr, I'll always get Google start page in
french , with any link you provided. Now if I set it to en-us, they'll be in US
english, even without wiping the cookies. I even tried it with nl.
I already tested it under Firefox 1.0.6, so Google seems to look at the
accept-lang header.
I repeat that it works for me.
Would it be only fixed for the fr HTTP_USER_AGENT ?
Could someone else test the links provided above, with/without wiping the Google
cookies and with different accept-lang header (Customize Languages in the Options) ?

Comment 19

13 years ago
(In reply to comment #18)

This is not true if you have installed firefox for the really first time:
typically a french speaking newbie which would test firefox ...
As the google cookies is not yet set, he will receive a start page in dutch ...

Comment 20

13 years ago
(In reply to comment #18)

- first I wipe out all my google-cookies (in google.be and google.com),
otherwise Google would have used those
- With the default accept-language header (en-us,en;q=0.5), I receive a Dutch
language startpage (with a Belgian ipaddress).
- When I add French, and put it on the top, I receive the page in French
- when I move French to the bottom, so that English is on the top again, I
receive it in English
- when I remove French again, returning to the original setting, I receive the
page in Dutch again.

Conclusion : it doesn't work for the default setting in en English-language
Firefox (en-us,en;q=0.5). It works it you chnage the preferences.

The point is not that you can change the default language in FF (which is under
the advanced setting), or in the Google PREF cookie. The point is that a
first-time user does *not* have as cookie, or even knows how to set the desired
language in the preferences. It's even physically impossible, because you see
the startpage first.

From all the data I described in comment 15 (no cookie, default language set to
English, user-agent indicates English, ...), why does Google present me a Dutch
language startpage. Only because I'm using a Belgian ipaddress ? That guess is
56% correct, but a large part of Belgian users can't even read in that language.
 Note that there's no link on that page to load the startpage in a different
language (which btw, is required by law). And our Catalan users might all be
able to read Spanish, but that still leaves a very bad feeling for them.

People who can change the language-setting in the preferences (which most users
can't even find) won't have a problem with this, but all first-time users do.
(Reporter)

Comment 21

13 years ago
Well, I have been playing with this again. And I would bet the blame is,
somehow, on google.be in Belgium territory. I do not experience these problems
with google.be URLs and I get the interface in my preferred accept-language.

I also have noticed a very peculiar behavior, at least, where I'm checking this,
in Southern Catalonia (Spanish state), and I think this also happens in other
places.
If you have as a primary accept-language Basque, Catalan, English, Galician or
Spanish, you are redirected to Google Spain. However, if you have French,
Occitan* or any other language, you are not. (This may happen in other places,
as well)
Searches results if you use Occitan (google.com then) and Catalan (google.es
then) are slightly different.

I suppose this redirection policy may be related with customization and business
issues within Google. I must admit it is really a good sign that local google in
Spanish State consider different languages, as it happens in Switzerland or
Belgium (I hope problems may be solved there), specially if we compare it with
French State, where its government still ignore languages other than French (and
in the end, Google seems only to consider official languages).
I imagine that current solution is optimal in places such as Switzerland where
there are several official languages (Deutsch Français, Italiano, Rumantsch) and
a clear Swiss national feeling.
It is not the same, for instance, in Catalan Countries or Euskal Herria, either
in French or Spanish states. Users that prefer interfaces and software in Basque
or Catalan are also more likely to refuse Spanish or French nationality. So,
redirection and, for instance, adding as a search option 'Display pages in
Spain' is not really welcomed from these users.

Another point, you can only search pages in one definite language (a very
interesting and useful option for users) if you are in some certain local
googles. For instance, I enable French as my default language (notice I'm in
Southern Catalonia), and in google.fr and google.com I can search for pages
written in French, but not in Google.es.

Finally, as I have already said, Catalan-speaking community thanks Google
compromise for Catalan language, and I think this gratitude could be extended to
other less protected or minoritary languages. No doubt, Google is currently the
international company which has shown a greater respect for these issues.

I hope all the information I have written down may be used in the future for
improving localization policy in Google (and Mozilla, as well).

Best regards,

*Occitan is a language which is mostly spoken in French State, and currently
official in one only place in the world, in Val d'Aran (in Southern Catalonia). 

(In reply to comment #20)
> (In reply to comment #18)
> 
> - first I wipe out all my google-cookies (in google.be and google.com),
> otherwise Google would have used those
> - With the default accept-language header (en-us,en;q=0.5), I receive a Dutch
> language startpage (with a Belgian ipaddress).
> - When I add French, and put it on the top, I receive the page in French
> - when I move French to the bottom, so that English is on the top again, I
> receive it in English
> - when I remove French again, returning to the original setting, I receive the
> page in Dutch again.
> 
> Conclusion : it doesn't work for the default setting in en English-language
> Firefox (en-us,en;q=0.5). It works it you chnage the preferences.
> 
> The point is not that you can change the default language in FF (which is under
> the advanced setting), or in the Google PREF cookie. The point is that a
> first-time user does *not* have as cookie, or even knows how to set the desired
> language in the preferences. It's even physically impossible, because you see
> the startpage first.
> 
> From all the data I described in comment 15 (no cookie, default language set to
> English, user-agent indicates English, ...), why does Google present me a Dutch
> language startpage. Only because I'm using a Belgian ipaddress ? That guess is
> 56% correct, but a large part of Belgian users can't even read in that language.
>  Note that there's no link on that page to load the startpage in a different
> language (which btw, is required by law). And our Catalan users might all be
> able to read Spanish, but that still leaves a very bad feeling for them.
> 
> People who can change the language-setting in the preferences (which most users
> can't even find) won't have a problem with this, but all first-time users do.

Comment 22

13 years ago
(In reply to comment #11)
> My Firefox Home Page suddenly became Dutch.  I downloaded a new version 1.06 and
> though I specified English language, it still came down Dutch.

I have to mention that many people using Firefox 1.0.6 in UK have complained to
Mozilla Europe members about this Google showing up in Dutch just after
upgrading to 1.0.6. Don't ask me why. It may or may not be linked to the overall
issue described here.

Comment 23

13 years ago
(In reply to comment #22)
> I have to mention that many people using Firefox 1.0.6 in UK have complained to
> Mozilla Europe members about this Google showing up in Dutch just after
> upgrading to 1.0.6. Don't ask me why. It may or may not be linked to the overall
> issue described here.

That can happen when Google only uses the ipaddress to guess the language. In
this case probably an ipaddress in the KPN network, which spreads over both the
UK and the Netherlands. Note that this confirms comment 20 -
HTTP_ACCEPT_LANGUAGE is not used here.

This is one of the reasons that Google should provide at least a link on the
startpage, to help 'lost' users.
(Reporter)

Comment 24

13 years ago
Tristan, would it be possible to ask those affected people which google URL
shows them up when using Firefox start page: google.co.uk, google.com or
google.nl/google.be? Since they are supposed to use en-GB or en-US Firefox I
presume their primary accept-language is en, en-GB or en-US.

(In reply to comment #22)
> (In reply to comment #11)
> > My Firefox Home Page suddenly became Dutch.  I downloaded a new version 1.06 and
> > though I specified English language, it still came down Dutch.
> 
> I have to mention that many people using Firefox 1.0.6 in UK have complained to
> Mozilla Europe members about this Google showing up in Dutch just after
> upgrading to 1.0.6. Don't ask me why. It may or may not be linked to the overall
> issue described here.
(Reporter)

Comment 25

13 years ago
I lament repeating again but there is still a part of the issue open that could
be easily solved for the next major release. At least, I would suggest that
Google offered a workaround solution to localization groups, such as Catalan
one, which would provide a google-ca.src, and would satisfy most of its users,
who expect a solution for this problem.

Redirection from google.com to a local Google, such as google.es, is forced in
Firefox browser, but not necessarily in a common Google search. 
In Barcelona, where I am, using a google searchplugin, such as this:
http://www.softcatala.org/projectes/mozilla/mycroft/google-ca.src
(the same is currently in 1.8 branch)
when I search Andorra with the searchplugin, this is converted to this string:
http://www.google.com/search?q=Andorra&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:ca:official
which is then converted to:
http://www.google.es/search?q=Andorra&start=0&start=0&ie=utf-8&oe=utf-8&client=firefox-a&rls=org.mozilla:ca:official

if "&client=firefox-a" is removed, the string is not redirected.

Look images of first comment
ftp://ftp.softcatala.org/pub/beta/firefox/bugs/google/bad.png
ftp://ftp.softcatala.org/pub/beta/firefox/bugs/google/good.png

So, this makes Google *Catalan Firefox* users searches to be especifically
redirected. That's a bad image for Google and/or Firefox in the Catalan
community. I would suggest this behaviour to be suppressed, or at least, provide
a workaround for avoiding this behaviour in google-ca.src searchplugin.

Best regards,
Flags: blocking-firefox2?
(Assignee)

Comment 26

12 years ago
We'll fix the locale stuff in bug 337719.

Regarding the redirection stuff, that's a different bug, if at all. Ending
up in .es is fine as long as there's no catalan TLD. If that hurts somebody's
political feelings, Mozilla is not the place to solve that. Sounds rude, but
there is a distinct line between politics and software, and this on is on the
other side.
Depends on: 337719
(Reporter)

Comment 27

12 years ago
Fine. Thanks for pointing at there is another bug about, Axel. Language detection is happily working some months ago, as I reported here as well.

About the second point, you must take into account that Google is the one which has actually started assuming a political position using software, especifically for Firefox. Compare SeaMonkey and Firefox Google search behaviour. 
However, I can understand that, since it's Google's fault, it's beyond what Mozilla people can code. For this reason, I was simply asking if anyone may intercede in it.

Best regards,
(In reply to comment #26)

> Regarding the redirection stuff, that's a different bug, if at all. Ending
> up in .es is fine as long as there's no catalan TLD.
> 

FYI, there is a catalan TLD (.cat) but of course no google.cat site
(Reporter)

Comment 29

12 years ago
(In reply to comment #28)
> (In reply to comment #26)
> 
> > Regarding the redirection stuff, that's a different bug, if at all. Ending
> > up in .es is fine as long as there's no catalan TLD.
> > 
> 
> FYI, there is a catalan TLD (.cat) but of course no google.cat site
> 

Despite it's still not used, google.cat is already registered by Google. (see whois.cat)

Anyway, even if Google changes the behaviour for Catalan users (for instance, by adopting .cat), this might not change for other ones, let's say Basque. 
What I complain, and I know it is a Google issue, is that Firefox users should not be redirected by default, as that do not happen with SeaMonkey or other browsers. 
That would be the more politically neutral attitude. If users wanted .cat, .es, .fr, or whatever other regional google portal, they can choose to download the searchplugin apart.
Axel, should we be blocking on this?
Assignee: rebron → l10n
(Assignee)

Comment 31

12 years ago
No, I think we should mark this bug fixed. We do have some detail problems, but
those are not the original bug request, and morphing bugs five times doesn't help.

For reference, search suggest giving 'good' results for l10n is open. Filed
bug 340693.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Detail problems?  "The browser is in the wrong language" is a common complaint of users because we don't do *anything* to make the start page language match the language of the build.  In what sense is this fixed?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 33

12 years ago
dbaron, comment 27 says that language detection works fine now.

We could file a separate bug on http://ab-cd.start.mozilla.com/firefox not
working as other URLs, but this is only the link we commonly use in the bookmarks,
and from SearchForm, the latter may be modified by bug 335460.

But those are all separate bugs, IMHO.
Ah, OK, it's fixed on the Google end on the basis of Accept-Language, not on the basis of the URL.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 35

12 years ago
Regarding the language detection, I presume, as Axel has pointed as well, this may be already solved...
I'm unsure if there could be different behaviours depending on the languages and regions (that is, google local portal). Please, other people who have commented before, give feedback. 

For avoiding confusion, I would fill a more specific bug about the redirection issue with the suggestions I have given above.
(That said, I got the start page in Dutch last time I was in the Netherlands, although that was a few days before comment 27.)

Comment 37

12 years ago
(In reply to comment #34)
> Ah, OK, it's fixed on the Google end on the basis of Accept-Language, not on
> the basis of the URL.
> 

I can confirm that it works now (FF 1.5.0.4). I'm physically in Belgium, but my internet gateway is in France, so Google will redirect www.google.com to www.google.fr. But Google will also select my preferred language automatically, so it really doesn't matter. I've tried English, Dutch, French, German, Spanish and Catalan and Basque. Cookies don't influence it, unless I force a particular language with the links below. If you have trouble, you might have to clear all *.google.* cookies.

I must applaud Google for finalling implementing it correctly. Respecting Accept-Language is a lot better than trying to parse the URL, maybe we can now switch to a standard startpage for all (or most) localisations. 

Anybody else has problems ? I know that accurate detection of your region might still be difficult. Catalan users using an English build should select Catalan as their preferred langauge, which won't work for the very first homepage ofcourse. Luckily, you can force it with the links below. But using a Catalan build where the language was preset, should work out of the box.

Updated

12 years ago
Flags: blocking-firefox2?
*** Bug 312720 has been marked as a duplicate of this bug. ***
*** Bug 306553 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.