If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SELECT drag-select stops working after first drag above/below

RESOLVED WORKSFORME

Status

()

Core
Layout: Form Controls
RESOLVED WORKSFORME
18 years ago
12 years ago

People

(Reporter: Eli Goldberg, Assigned: rods (gone))

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Checked using 2000021008 builds on Win32/Mac OS.

Steps to reproduce:
1. View a web page such as http://bugzilla.mozilla.org/enter_bug.cgi?product=
Browser, with scrolled select lists.

2. Attempt to drag select such a list (e.g. Component)

Actual results:
---> Drag selection doesn't do anything.

Expected results:
---> Behavior similar to Win32 & Mac OS widget sets --- drag selection should be 
supported.

Comment 1

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods
(Assignee)

Comment 2

18 years ago
Setting to M16
Status: NEW → ASSIGNED
Target Milestone: M16
(Assignee)

Comment 3

18 years ago
*** Bug 29990 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
"Fix" for this (Actually, 29990 which is marked as duplicate of this...) in 
layout\html\forms\src\nsListControlFrame.cpp:MouseMove() prevents compiling on 
VC5 due to all control paths not returning a value. This is also a potential bug 
because method may get called by something that expets a return value.
(Assignee)

Comment 5

18 years ago
This now works except for auto scrolling when below or above the list.
(Assignee)

Comment 6

18 years ago
*** Bug 31781 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
mass-move to M16

Comment 8

18 years ago
Related: bug 34020 for scrolling the content area while selecting.
(Assignee)

Comment 9

18 years ago
moving bugs to M17
Target Milestone: M16 → M17
Revising summary per rods's comments.  Pushing out to M19 as: (1) there's a 
workaround: scroll using arrows and shift-select to select the whole group, (2) 
this only affects drag scrolling ith auto scroll when above/below list, (3) we 
have higher priorities, and (4) we could live with this for FCS if necessary.
Summary: Scrolled select lists don't support drag-scrolling → Scrolled select lists don't support drag-scrolling with auto scroll when above/below list
Target Milestone: M17 → M19
(Assignee)

Comment 11

18 years ago
This bug has been marked "future" because at this time it has been determined 
that it is not absolutely critical for RTM (Release To Manufacturing). If the 
reporter and anyone else believe it is necessary to fix this before shipping 
Seamonkey 1.0, please describe your issue in the bug. 
Target Milestone: M19 → Future
(Assignee)

Comment 12

18 years ago
*** Bug 44454 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
erg...future...:(

rods, can you give me a general idea of what implementing this would entail 
(and where changes would have to be made)?

Comment 14

18 years ago
disregard my last comment, as this isn't the same as 44454 (I thought it was 
initially), which I had more interest in fixing

Comment 15

17 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma
(Assignee)

Updated

17 years ago
Summary: Scrolled select lists don't support drag-scrolling with auto scroll when above/below list → [CBX]Scrolled select lists don't support drag-scrolling with auto scroll when above/below list
(Assignee)

Comment 16

17 years ago
leaving P3/Future for now.
(Assignee)

Comment 17

17 years ago
*** Bug 46497 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 18

17 years ago
*** Bug 63072 has been marked as a duplicate of this bug. ***

Comment 19

17 years ago
Can someone clarify what this bug is still open for?  Upon further reading, it 
seems to be the same as bug 44454.  What Rod mentioned on 3/16 seems to be 
fixed also.
(Assignee)

Comment 20

17 years ago
I think this is left open because drab scroll doesn't work and you drag off the 
end of the list. In otherwords, it should continue to scrol the list.
(Assignee)

Comment 21

17 years ago
*** Bug 59459 has been marked as a duplicate of this bug. ***

Comment 22

17 years ago
QA Contact Update
QA Contact: bsharma → vladimire
It appears that scrolling off the bottom of the list is working; but off the
top, no cigar.  Try http://bugzilla.mozilla.org/query.cgi for some examples.

Comment 24

16 years ago
I'm seeing something different: if I try to drag-scroll up and then drag-scroll 
down, it only works going up, unless I go down really far below the bottom of 
the select.  But if I do the opposite, it only works going down!  It's as if 
the scroll-off, selected items block Mozilla from realizing that I'm below the 
bottom (or above the top) of the listbox.

Comment 25

16 years ago
is this still futured given comment 23 and comment 24 ? I also see this on
linux with a currentish build :(
(Assignee)

Updated

16 years ago
Priority: P3 → --
*** Bug 117600 has been marked as a duplicate of this bug. ***
*** Bug 143028 has been marked as a duplicate of this bug. ***

Comment 28

16 years ago
Reproduced in build 2002071403, Mac OS 9.2.2.

Resummarizing to minimize confusion with bug 63295. Bug 46497, bug 63072, and
bug 59459 were duplicates of bug 44454, not this bug. Some of the other
duplicates of this bug should probably be duplicates of bug 63295, not this bug.
Summary: [CBX]Scrolled select lists don't support drag-scrolling with auto scroll when above/below list → SELECT MULTIPLE drag-select stops working after first drag above/below

Comment 29

15 years ago
Created attachment 99643 [details]
Drop down select and multiple select testcase

I've attached a testcase for this bug that illustrates both cases when Mozilla
shows odd behaviours, and there are more variations then those aleady described
in this bug so far.

1) in drop down select, when using the mouse to make a selection, the options
are more then the displayed ones and a scroll bar exists, dragging the mouse
down to a value not yet visible may not always work. 
I got different results at various times:
- I was able to go down to the last value (correct)
- I was not able to go down past the last displayed value when the pull down is
extended the first time
- I was able to get some steps down, but not all
- moving the mouse fast and exiting the area of the unrolled pull down list
will stop the selection scrolling towards the last value.

Similar results are encountered with the multiple select, with an added twist:
- if multiple select is partially visible in the currently displayed area of
the window, scrolling down with the mouse left click and held will select all
visible values, but will not scroll the entire window so that the bottom of the
select input field is visible.
- writing text in a textarea that is partially visible does trigger a scroll so
that the bottom of the textarea becomes visible as the cursor  goes down.
(same is valid for going up and sideways but only for input type text and
textarea)

If user wants to do a multiple selection starting from the bottom, there is no
way to select with a single mouse left click and drag upwards more then the
visible values in that select. No scroll will take place upwards.

Same is valid for drop down list.
As in the testcase: pull down the list, go down so the the last value (31) is
visible. Left click and hold mouse and move mouse upwards. It will not scroll
at all, 16 being the top most visible value it stops there.

In the multiple select, go down to 31, left click and hold, move upwards. As
about 2 pixels are visible from value 26, depending on how fast you move the
mouse, the top most selected value can be 27 or 26, but there is no wy to
select more then this.

(my screen resolution is 800x600)

Comment 30

15 years ago
*** Bug 141657 has been marked as a duplicate of this bug. ***

Comment 31

15 years ago
The bug I just duped, is talking also about single-select scrolling
in HTML listboxes, which this bug seems to be about. Shouldn't
the "MULTIPLE" be removed from the subject ?

Hmm, actually. bug 44454 is marked as fixed but there are two
cases where things s till fail :

1) open a combo box and keep the mouse button held down. scrolling
does not work

2) open a combo box, release mouse button, select an item, and try
to scroll upwards by hold position above the t op of the listbox.
nothing happens.

Bleh. Confusion.
The original problem was fixed by bug 291443.
The additional problem mentioned in comment 29 regarding scrolling the
surrounding views to make the selection become visible is covered
by bug 56602.

-> WORKSFORME
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Summary: SELECT MULTIPLE drag-select stops working after first drag above/below → SELECT drag-select stops working after first drag above/below
You need to log in before you can comment on or make changes to this bug.