Provide Thunderbird MSI package

RESOLVED FIXED in Thunderbird 66.0

Status

--
enhancement
RESOLVED FIXED
15 years ago
3 months ago

People

(Reporter: gkn, Assigned: Paenglab)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

unspecified
Thunderbird 66.0
All
Windows
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

15 years ago
Bug 231062 for Thunderbird

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Flags: blocking-aviary1.1?

Comment 1

14 years ago
Now that Firefox's installer is working, this one should be a shoe-in.

Comment 2

14 years ago
Marking fixed per bug 229706 comment 40 (copied below)

> Thunderbird now installs completely when using the MSI package and silent
> installer mode.  Marking this bug resolved.  Please file any automated installer
> issues you find in a new bug.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Flags: blocking-aviary1.1?
reopening. no way is this resolved.  Depends on bug 231062 which is still going strong
Assignee: mscott → nobody
Status: RESOLVED → REOPENED
Depends on: 231062
QA Contact: installer
Resolution: FIXED → ---

Updated

10 years ago
Duplicate of this bug: 474088
Duplicate of this bug: 548841

Comment 6

9 years ago
You know, that is really irritating. I entered "MSI Thunderbird" in the search box before opening that bug, and this bug did NOT come up... I just checked, and entering only "msi" it does... and this is not the first time...

It would be nice if someone would 'fix' the search function for the bug tracker, it is really hit and miss...

Comment 7

9 years ago
Anyway... I can't believe this request was actually *resolved* at one time?? There was a short window when an MSI installer was available?
there has been progress in the Firefox bugs. This is where the action is and where you can contribute your skills and time.  FWIW, available in chrome browser - http://www.google.com/apps/intl/en/business/chromebrowser.html 

Charles in comment #7
> Anyway... I can't believe this request was actually *resolved* at one time??
> There was a short window when an MSI installer was available?

not from mozilla afaik.  some external outfit in the 1.0/1.5 time frame.

Updated

8 years ago
Blocks: 564148

Updated

5 years ago
OS: Windows 2000 → Windows 7

Comment 9

2 years ago
Now bug 231062 has been closed as RESOLVED/WONTFIX.
So MSI is not provided for Firefox.
Comment hidden (spam)
Firefox landed bug 1475510, so we should do this too.
Status: REOPENED → NEW
OS: Windows 7 → Windows
Hardware: x86 → All
(Assignee)

Comment 12

4 months ago
Posted patch 274624-Thunderbird-msi.patch (obsolete) — Splinter Review
Rob, what do you think about this? Could this work? I checked it on try and it doesn't break, but I can't say if it would work.

This is a port of:

Bug 1475510: Create MSI installer as an exe wrapper
Bug 1475512: Integrate MSI installer inside CI system
Bug 1485228: add wix binaries to existing fetch support for toolchains
Assignee: nobody → richard.marti
Attachment #9029597 - Flags: feedback?(rob)

Comment 13

3 months ago
Comment on attachment 9029597 [details] [diff] [review]
274624-Thunderbird-msi.patch

Review of attachment 9029597 [details] [diff] [review]:
-----------------------------------------------------------------

Looks pretty reasonable. I suspect that since this is touching release-bouncer things that something will need to happen with the release-bouncer itself so that it recognizes the new aliases. If you want to open a separate bug for me I'll look into it.

There needs to be a line added to beetmover-repackage/kind.yml kind-dependencies pointing to repackage-signing-msi. See https://hg.mozilla.org/mozilla-central/file/tip/taskcluster/ci/beetmover-repackage/kind.yml#l26. Looks like it was part of Bug 1475512.

::: taskcluster/ci/release-bouncer-sub/kind.yml
@@ +41,1 @@
>                  comm-esr60: ['complete-mar', 'complete-mar-bz2', 'installer', 'installer-ssl', 'partial-mar']

Not sure why the msi is not on comm-esr60 here when it's there in other kind files. But, this is how Firefox has it.
Attachment #9029597 - Flags: feedback?(rob) → feedback+
(Assignee)

Comment 14

3 months ago
Thanks. Added the line in beetmover-repackage/kind.yml.
Attachment #9029597 - Attachment is obsolete: true
Attachment #9033367 - Flags: review?(rob)
(Assignee)

Updated

3 months ago
Blocks: 1516475

Comment 15

3 months ago
Comment on attachment 9033367 [details] [diff] [review]
274624-Thunderbird-msi.patch

Ran a first pass try job last night at https://hg.mozilla.org/try-comm-central/rev/5e0a467a5fc347d1208611c3ddf57e3008a4f9c5

Richard's assessment of results:

The MSIs are created but I see some issues:
- The MSI have a SHA1 certificate which shows on Win 10 like unsigned.
- The MSI shows "Mozilla Firefox 66.0a1" instead Thunderbird.
- I found no en-US MSI package.

I am 99.9% sure that there are no en_US MSI's because I set up the try job wrong. The Symbol uploads also failed, again probably something with the try job configuration.

Marking this review+ so it can land in C-C and we can start generating nightlies. Can always be backed out if there's problems.
Attachment #9033367 - Flags: review?(rob) → review+
(Assignee)

Comment 16

3 months ago
Okay, set c-n to test it on Daily.
Keywords: checkin-needed

Updated

3 months ago
Depends on: 1516542

Updated

3 months ago
No longer blocks: 1516475
Depends on: 1516475

Comment 17

3 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/78daaa93369e
Provide Thunderbird MSI package. r=rjl
Status: NEW → RESOLVED
Last Resolved: 14 years ago3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

3 months ago
Target Milestone: --- → Thunderbird 66.0

Comment 18

3 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/110a814e63fa
Follow-up: Correct indentation in kind.yml files. rs=bustage-fix DONTBUILD

Comment 19

3 months ago
Hmm, there are a few text failures now: BM-R and BMR-L10n. Are they related to bug 1516542? So where do you get the MSI?
Flags: needinfo?(rob)
(Assignee)

Comment 20

3 months ago
(In reply to Jorg K (GMT+1) (urgent reviews and bustage fix only, Dec 22nd to Jan 1st) from comment #19)
> Hmm, there are a few text failures now: BM-R and BMR-L10n. Are they related
> to bug 1516542? So where do you get the MSI?

BM-R says: KeyError: 'target.installer.msi'

So I think it's related to bug 1516542.

I think the MSI can be found here: https://tools.taskcluster.net/groups/fmn3n2FDTWqWK3UAoz626Q/tasks/HsATYFlhSl-5MzOwyyA_XA/runs/0/artifacts

In taskcluster's MSIs
(Assignee)

Comment 21

3 months ago
Tried this package in my Win7 VM and it installs. First it says Mozilla Firefox, but in the end it's Daily which is installed.

Comment 22

3 months ago
Attachment #9033562 - Flags: review?(rob)

Comment 23

3 months ago
Comment on attachment 9033562 [details] [diff] [review]
274624-follow-up.patch

Review of attachment 9033562 [details] [diff] [review]:
-----------------------------------------------------------------

Ran a try job: https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=a58ee51b9cbd6a15d7b105a059a57ab48505a009, based in the scheduling it has the desired effect.
Attachment #9033562 - Flags: review?(rob) → review+

Updated

3 months ago
Flags: needinfo?(rob)

Comment 24

3 months ago
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ec788f59f769
Follow-up: Temporarily remove repackage-signing-msi dependency. r=rjl

Updated

3 months ago
See Also: → bug 1516741
You need to log in before you can comment on or make changes to this bug.