Last Comment Bug 277079 - "Close other tabs" should always warn about closing multiple tabs
: "Close other tabs" should always warn about closing multiple tabs
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: Firefox 16
Assigned To: Dão Gottwald [:dao]
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 801533 772319
Blocks:
  Show dependency treegraph
 
Reported: 2005-01-04 18:24 PST by Chris Cunningham
Modified: 2013-09-18 15:05 PDT (History)
29 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.43 KB, patch)
2012-07-03 06:07 PDT, Dão Gottwald [:dao]
ttaubert: review+
Details | Diff | Splinter Review
patch v2 (3.10 KB, patch)
2012-07-03 11:09 PDT, Dão Gottwald [:dao]
ttaubert: review+
Details | Diff | Splinter Review

Description Chris Cunningham 2005-01-04 18:24:39 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5) Gecko/20041110 Firefox/1.0 (ax)

Close Other Tabs is unintuitive and dangerous. It doesn't belong in the context
menu for a tab, or anywhere else for that matter. The time saved by the menu
option is in my experience not worth the frustration caused by hitting it
accidentally all the time.

Reproducible: Always

Steps to Reproduce:
1. Decide that a particular unfocussed tab in unimportant.
2. Rather than clicking it and then hitting the X button on the tab bar, use the
handy "close tab" context menu item.
3. Miss by three pixels and hit "close other tabs" by mistake.
Actual Results:  
All of my other tabs (i.e. the ones I was actually interested in) close.

Expected Results:  
Expected Results:  
Not closed all the wrong tabs. (in an ideal world I might have accidentally hit
bug 254021 but that's currently still broken.)

Accidentally transposed the terms "close other tabs" and "undo close tab" in
previous report, to the detriment of bug usefulness. Apologies.
Comment 1 Kevin Brosnan 2005-01-04 18:35:13 PST
Can we dupe this to bug 103354 in the core?
Comment 2 Mike Connor [:mconnor] 2005-01-05 01:34:28 PST
There's a warning/confirmation dialog, but its useful enough to enough people to
keep, and leaving the warning dialog enabled is enough of a solution to not take
a drastic step such as this.  This is probably a dupe, but I don't feel like
looking for it.

You can always kill it via userChrome if you're really not a fan, but the
feature stays.
Comment 3 Dietrich Ayala (:dietrich) 2012-01-19 15:28:38 PST
Twice now, I've somehow triggered this without seeing the warning dialog. Possibly I hit enter or the mousepad with my hand?

Either way, the only recovery option is to go through your history manually, trying to remember what tabs were open.

IMO the dataloss risk with this menu item is too high to offer it without an "undo" option.

We should re-evaluate the usage via TestPilot data (which we already have for tab context menu items iirc), and decide from that whether to remove the option or not.
Comment 4 Dão Gottwald [:dao] 2012-01-20 03:59:51 PST
(In reply to Dietrich Ayala (:dietrich) from comment #3)
> Twice now, I've somehow triggered this without seeing the warning dialog.
> Possibly I hit enter or the mousepad with my hand?

Or maybe you disabled the "warn when closing multiple tabs" option?

> We should re-evaluate the usage via TestPilot data (which we already have
> for tab context menu items iirc), and decide from that whether to remove the
> option or not.

This will probably tell us that it's not used very much, but what does that mean? It's probably still a significant time saver when it's used. TestPilot cannot tell us the intentional/accidental rate, can it?
Comment 5 Dietrich Ayala (:dietrich) 2012-01-20 07:49:10 PST
(In reply to Dão Gottwald [:dao] from comment #4)
> (In reply to Dietrich Ayala (:dietrich) from comment #3)
> > Twice now, I've somehow triggered this without seeing the warning dialog.
> > Possibly I hit enter or the mousepad with my hand?
> 
> Or maybe you disabled the "warn when closing multiple tabs" option?

Yes, that option was disabled. I don't remember doing it, but probably was testing something in the years I've had this profile :P

> > We should re-evaluate the usage via TestPilot data (which we already have
> > for tab context menu items iirc), and decide from that whether to remove the
> > option or not.
> 
> This will probably tell us that it's not used very much, but what does that
> mean? It's probably still a significant time saver when it's used. TestPilot
> cannot tell us the intentional/accidental rate, can it?

Obviously it cannot tell us accidental use. The point of looking at usage data is that it'd help us weigh the cost of keeping an option that allows significant dataloss vs the number of users we'd hurt be removing it.

Regardless of usage, I think that this menu item should not exist without a way to undo the action, due to it's high level of destructiveness. Even with the warning, you should still be able to reverse the action.
Comment 6 Dão Gottwald [:dao] 2012-01-20 09:04:59 PST
Sounds like we should always prompt here, regardless of prefs. With that I don't really see a dataloss risk.
Comment 7 Alex Limi (:limi) — Firefox UX Team 2012-02-03 16:46:23 PST
Always prompting sounds good to me. Agree that this is suboptimal (but also that the default we do now, which is ask, is good enough)
Comment 8 Willy_ Foo_Foo 2012-05-20 21:13:59 PDT
(In reply to Chris Cunningham from comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5)
> Gecko/20041110 Firefox/1.0 (ax)
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.5)
> Gecko/20041110 Firefox/1.0 (ax)
> 
> Close Other Tabs is unintuitive and dangerous. It doesn't belong in the
> context
> menu for a tab, or anywhere else for that matter. The time saved by the menu
> option is in my experience not worth the frustration caused by hitting it
> accidentally all the time.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 1. Decide that a particular unfocussed tab in unimportant.
> 2. Rather than clicking it and then hitting the X button on the tab bar, use
> the
> handy "close tab" context menu item.
> 3. Miss by three pixels and hit "close other tabs" by mistake.
> Actual Results:  
> All of my other tabs (i.e. the ones I was actually interested in) close.

This should be up to the user (pref)
Many users use this feature
Comment 9 Willy_ Foo_Foo 2012-05-20 21:15:06 PDT
(In reply to Alex Limi (:limi) — Firefox UX Team from comment #7)
> Always prompting sounds good to me. Agree that this is suboptimal (but also
> that the default we do now, which is ask, is good enough)

+1
Comment 10 Dão Gottwald [:dao] 2012-07-03 06:07:22 PDT
Created attachment 638678 [details] [diff] [review]
patch
Comment 11 Tim Taubert [:ttaubert] 2012-07-03 06:23:59 PDT
Comment on attachment 638678 [details] [diff] [review]
patch

Review of attachment 638678 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me!
Comment 13 Dão Gottwald [:dao] 2012-07-03 09:19:21 PDT
Backed out, since browser_bug577121.js didn't like this change. It started triggering the prompt, preventing the test suite from continuing. I'll need to think about this more, but I might just remove this test.

I'll also need to change the patch to continue checking (tabsToClose <= 1) unconditionally, since 1) the prompt string doesn't take "1" as a possible number into account and 2) tabsToClose could be 0 if the caller isn't careful (such as browser_privatebrowsing_zoomrestore.js calling removeAllTabsBut for no good reason).
Comment 14 Dão Gottwald [:dao] 2012-07-03 09:25:51 PDT
(In reply to Dão Gottwald [:dao] from comment #13)
> Backed out, since browser_bug577121.js didn't like this change. It started
> triggering the prompt, preventing the test suite from continuing. I'll need
> to think about this more, but I might just remove this test.

Just reverting the (tabsToClose <= 1) should actually take care of this, as browser_bug577121.js only removes a single tab using removeAllTabsBut.
Comment 15 Dão Gottwald [:dao] 2012-07-03 11:09:58 PDT
Created attachment 638806 [details] [diff] [review]
patch v2
Comment 17 Ryan VanderMeulen [:RyanVM] 2012-07-04 06:39:03 PDT
https://hg.mozilla.org/mozilla-central/rev/2dfd0ad87b15
Comment 18 Frank Lion 2012-07-06 16:09:47 PDT
This fix breaks any 'Close Tabs To The Right' extensions by offering an unwanted prompt. Bearing in mind that this is already a default menu option on the Chrome browser and that Firefox is surely going to 'innovate' the same behaviour at some point, it might be an idea to fix this now.
Comment 19 xunxun 2012-07-21 19:53:33 PDT
(In reply to Frank Lion from comment #18)
> This fix breaks any 'Close Tabs To The Right' extensions by offering an
> unwanted prompt. Bearing in mind that this is already a default menu option
> on the Chrome browser and that Firefox is surely going to 'innovate' the
> same behaviour at some point, it might be an idea to fix this now.

Can you file a new bug?
Comment 20 Frank Lion 2012-07-22 05:23:04 PDT
(In reply to xunxun from comment #19)
> (In reply to Frank Lion from comment #18)
> > This fix breaks any 'Close Tabs To The Right' extensions by offering an
> > unwanted prompt. Bearing in mind that this is already a default menu option
> > on the Chrome browser and that Firefox is surely going to 'innovate' the
> > same behaviour at some point, it might be an idea to fix this now.
> 
> Can you file a new bug?
I think my suggestion would be covered by this bug - https://bugzilla.mozilla.org/show_bug.cgi?id=772319 So, to avoid duplication best not do another one.
Comment 21 Loic 2012-10-10 10:07:20 PDT
Is there a pref in about:config to disable the annoying dialog box when the user selects "Close other tabs"?
Comment 22 Loic 2012-10-10 10:11:42 PDT
Ok, I read there is browser.tabs.warnOnCloseOtherTabs but it's only available in FF19. I asked that because some users are not really happy this new feature in FF16.
http://forums.mozillazine.org/viewtopic.php?f=23&t=2531393
Comment 23 GS 2012-10-11 05:45:30 PDT
This is stupid, there should be an option to disable this behaviour. 
I am a frequent user of the "Close Other Tabs" and it is annoying to have this dialog box pop up to confirm closing the tabs.
To add insult to the injury, they forgot to eliminate the option in Preferences->Tabs->"Warn me on closing multiple tabs". The option is there but does just nothing.
Comment 24 Greeny 2012-10-13 05:07:29 PDT
Just to let you know that I'm downgrading to Firefox 15.0.1 until you revert this change, or at least provide me with an option to disable the behaviour (i.e. some option which makes "Preferences->Tabs->"Warn me on closing multiple tabs" actually do what it says it does).

Looks like I'll be waiting until Firefox 18 is released...
Comment 25 o1660360@rtrtr.com 2012-10-13 09:06:28 PDT
I've also downgraded because of this 'forced' change.
Comment 26 J.Vandervort 2012-10-14 21:30:37 PDT
Can't say this new feature is a feature.  If I didn't want to close other tabs I wouldn't have clicked on the popup menu.  We need a way to turn off the confirmation prompt, you know, like before when it worked correctly.
Comment 27 Dash 2012-10-15 05:25:15 PDT
How on earth did this get implemented?  Sure, remove the default check-box, but leave the existing check-box in the options enabled - or at least the config setting.

Just because the original poster has butter fingers and can't click straight doesn't mean the rest of the world needs to be inconvenienced.  Is his history broken?

Or - add a new feature "Undo Close All Tabs" or something.

How do we go about getting this change backed out?
Comment 28 porl 2012-10-15 14:11:11 PDT
(In reply to Dash from comment #27)
> Or - add a new feature "Undo Close All Tabs" or something.

I agree with that. The Undo command is where a user corrects something they have done in error. Why not save the session when they select 'Close All Tabs' and restore it if they do one of CTRL+Z, Undo or Restore Previous Session?
Comment 29 changa 2012-10-16 14:53:48 PDT
I hit Close Other Tabs constantly - why would I open 20 tabs within one window, unless they were all part of a single project?  Upon finishing and opening a tab for a new project, I find that I have to confirm constantly.  
I looked in preferences, sure enough the confirmation option is unchecked, but my preference is being overridden.  I looked in about:config for an override-override, but nothing yet.  Are there plans to fix the constant unwanted confirmation boxes, or will that wait for a new bug report?
Comment 30 Dave Casey 2012-10-20 15:55:29 PDT
I agree with most of those that are requesting that the option to turn off the warning be put back in.  When I call up the menu and select Close Other Tabs that is what I mean.  I don't need to be warned that I'm doing something that I specifically requested to do.
Comment 31 tggm 2012-10-28 10:30:11 PDT
(In reply to Dash from comment #27)
> How on earth did this get implemented?  Sure, remove the default check-box,
> but leave the existing check-box in the options enabled - or at least the
> config setting.

Agreed, my brain just frozed when I discovered this was a new feature. So, the Reporter disabled the "Closed all tabs" warning and now is complaining about his poor mouse control? Amazing how he got to annoy me and a lot of the world; every day, many times a day...


(In reply to Chris Cunningham from comment #0)
> Close Other Tabs is unintuitive and dangerous. It doesn't belong in the
> context

It is extremely intuitive. That action does an extremely simple task which any user that understands the concept of "tabs" grasps immediately. It's only dangerous if, say, you chose to:

1 - Disable the warning in the settings menu.
2 - Prefer the "unintuitive" path of right-clicking the tab and then aim for "Close Tab" instead of clicking the damn cross that's just in front of you.
3 - Hit "close all tabs" by mistake.

> The time saved by the menu
> option is in my experience not worth the frustration caused by hitting it
> accidentally all the time.

Your experience, your accidents and frustrations, one patch, our annoyances.

Cheers.
Comment 32 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-10-28 11:23:45 PDT
Bug 772319 adds an about:config pref to revert to the old behavior.
Comment 33 supersapper89 2012-10-31 22:33:53 PDT
There is an option in the settings to turn that feature ON IF YOU WANT IT! I turned it off and it STILL prompts me when closing multiple tabs. I HATE IT!!! If people want it, let them turn it on. If you're not going to make it OPTIONAL, TAKE OUT THE BOX that "lets me choose" what it does. Ridiculous!
Comment 34 Dave Casey 2012-11-01 01:01:53 PDT
Well, it seems to be fixed.  At least for me it is.  I found a reason to do a complete reset of Firefox, which obviously wipes out quite a lot of things, like extensions, cache, history and more.  Once I got things back to where I like them with new add-ons and preferences, I noticed that the warning to Close Other Tabs was now turned off and I didn't get that warning anymore.  Let's hope it stays that way.  Just because one person has butter-fingers and can't control their mouse doesn't mean all of us are the same.  And I learned a long time ago how to use the History menu to reopen tabs that I had closed that I shouldn't have.
Comment 35 joe.fishing 2012-11-03 05:49:50 PDT
please undo this "patch" - thx
Comment 36 Loic 2012-11-03 05:57:12 PDT
(In reply to joe.fishing from comment #35)
> please undo this "patch" - thx

Please read the bug, the option to disable the dialog box is already back in FF17.
Comment 37 Hoku 2012-11-14 21:28:07 PST
Close Other Tabs is unintuitive and dangerous? You have got to be kidding. Is this some kind of joke?
Comment 38 tggm 2012-11-21 06:37:24 PST
I'm sorry but this is becoming ridiculous.

The net effect of this issue and Bug 772319, is that a user preference was moved from the options window to some God forsaken place in about:config. Considering that IE and Chrome all have the "no-warn-on-close-all-tabs" feature easily configurable, why not Firefox?

Actually, why was this request implemented so quickly and in such a sloppy manner that the original check-box in the options menu still remains (now useless; now a bug) ?

Why has someone as Chris Cunningham (the original reporter) so much power? 

If people decide to disable warnings (and this one is enabled by default) why should the rest of the world lose a feature just because ONE person is unable to use the mouse properly? 

In my entire life as a developer I've never seen functionality being dropped or hidden because a particular user is too stupid, has fatty fingers or is unable to understand and use "semi-advanced" options (such as those that usually live in context menus).

Why not move all the warning disable check-boxes to about:config? Better still, perhaps add a warning when disabling another warning? Of course we'll all be here again when Chris Cunningham disables that warning too.

My brain dies a bit every time I read this sentence on the original report:
"2. Rather than clicking it and then hitting the X button on the tab bar, use the handy "close tab" context menu item"

Cheers.
Comment 39 Hoku 2012-11-21 08:47:01 PST
I wholeheartedly agree with 'tggm'. Unfortunately, I was unsuccessful in my attempt to stop the warning from popping up by resetting the option in about:config.

What could possibly be unintuitive about "Close Other Tabs"? It is perfectly clear what that means. Couldn't be any clearer IMO.
Comment 40 Marco Bonardo [::mak] 2012-11-21 08:59:01 PST
If you don't stop with attacking other users we'll likely have to take care. This is a developers bug tracker with an etiquette, not a public forum.

If you want to discuss the change, please post a constructive thread to mozilla.dev.apps.firefox explaining your troubles and how you suggest to resolve both your problem and the original report.

Thank you for your understanding.

About the provided option:
about:config / browser.tabs.warnOnCloseOtherTabs / set to 'false'
Comment 41 Grant Wier 2012-11-21 09:17:36 PST
I was pretty certain i was clicking something else when "close other tabs" is what activated and destroyed my session with no recourse for recovery except 100+ individual "undo close tab" operations, and is apparently placed by default right next to other non-dangerous functions in the context menu.
a single "warn me when closing multiple tabs" preference is inappropriate for the 2 very different functions of closing a window (less likely to happen on accident, plus the session gets saved) and "close other tabs" (where it's easy to do accidently, isn't easy to anticipate being there for those who never use that function, and destroys the session unrecoverably).
i would say there's more than enough room for the appropriate pair of checkboxes in the preferences.
Comment 42 Nathan Williams 2012-12-11 09:01:34 PST
I really wish I had seen this bug before people stepped in and disabled a desired feature.  

You had a checkbox to turn this feature on or off.  I turned it off and didn't cry if I accidentally closed all tabs.  A mistake I think I've made once in a year.   The prompt is incredibly annoying but I can understand some that might want it.  

Also removing the function has been incredibly sloppy programing as you didn't remove the menu item that implies it is supposed to toggle it.   And now per bug 772319 an about:config work around is in place to replace the toggle on the menu.

Why is this marked resolved fixed when a menu item is left hanging?  This is not resolved.  This is not desired but it is sloppy programing.
Comment 43 Manachi 2012-12-19 17:07:02 PST
I am extremely confused and highly dissapointed that this bug/change was actioned. It defies logic. How is "Close Other Tabs" unintuitive? It's clear, consise and does EXACTLY what it claims to do.  I very commonly use this feature and I do not want a prompt asking me "Am I sure?" (If I wanted that I'd be using another browser which shall not be named).  So my natural course of ation was to untick "Warn me when closing multiple tabs" - that is all logical makes sense, but now this preference is IGNORED? WHAT? 

Comment 6 says it should always prompt regardless of the prefs? Are you actually serious?  What's more baffling is that someone listened to this suggestion?

Something is extremely broken here. There should be the option to close multiple tabs , without having a prompt forced on you.  If I UNTICK the option "Warn me when closing multiple tabs", I expect, based on the english understanding of that statement, that it should no longer warn me when closing multiple tabs.  I fail to see the issue here.  If you're worried about people selecting the wrong option due to inexperience, incompetence or just a genuine mistake, then fair enough, have the OPTION for a "Are you sure" prompt. But do not FORCE it on everyone due to the mistakes of a few!  Come on guys, please use some common sense here!  A lot of FireFox users are power users or developers and don't want to be spoon fed like babies. My #1 priority is fast, efficient shortcuts, and this is debilitating.
Comment 44 ChrisX 2012-12-31 14:49:10 PST
They now distinguish between 1) "close multiple tabs" (i.e. when you close a window with more than one tab) and 2) "close other tabs" (i.e. the rightclick menu option). 1) has a tick in the preferences, and 2) has an about:config switch (browser.tabs.warnOnCloseOtherTabs). Not an ideal solution (it used to be good and easy untill they started fixing things that didn't need to be fixed) – just trying to shed some light on the confusion.
Comment 45 Nathan Williams 2013-01-08 08:12:01 PST
(In reply to Manachi from comment #43)
> I am extremely confused and highly dissapointed that this bug/change was
> actioned. It defies logic. How is "Close Other Tabs" unintuitive? It's
> clear, consise and does EXACTLY what it claims to do.  I very commonly use
> this feature and I do not want a prompt asking me "Am I sure?" (If I wanted
> that I'd be using another browser which shall not be named).  So my natural
> course of ation was to untick "Warn me when closing multiple tabs" - that is
> all logical makes sense, but now this preference is IGNORED? WHAT? 
> 
> Comment 6 says it should always prompt regardless of the prefs? Are you
> actually serious?  What's more baffling is that someone listened to this
> suggestion?
> 
> Something is extremely broken here. There should be the option to close
> multiple tabs , without having a prompt forced on you.  If I UNTICK the
> option "Warn me when closing multiple tabs", I expect, based on the english
> understanding of that statement, that it should no longer warn me when
> closing multiple tabs.  I fail to see the issue here.  If you're worried
> about people selecting the wrong option due to inexperience, incompetence or
> just a genuine mistake, then fair enough, have the OPTION for a "Are you
> sure" prompt. But do not FORCE it on everyone due to the mistakes of a few! 
> Come on guys, please use some common sense here!  A lot of FireFox users are
> power users or developers and don't want to be spoon fed like babies. My #1
> priority is fast, efficient shortcuts, and this is debilitating.

Amen.

I really want this BUG undone.  I again request that this be reversed as it was a MINORITY that requested this be done.  The item is clear and easy to understand and now you have a dead link in the menu.  About:config work around are NOT good ways to handle GUI issues.

Comment 2 was correct and how it should have been left.
Comment 46 iain 2013-01-09 09:53:03 PST
(In reply to Nathan Williams from comment #45)
> I really want this BUG undone.  I again request that this be reversed as it
> was a MINORITY that requested this be done.  The item is clear and easy to
> understand and now you have a dead link in the menu.  About:config work
> around are NOT good ways to handle GUI issues.
> 
+1. I find the behavior absolutely exasperating. I had hoped from the discussion above that it was going to be corrected in FF18, but it's still the case.

Is there any chance that the behavior will be changed to work logically in a future release - or is this now a completely closed issue?
Comment 47 Loic 2013-01-09 10:03:18 PST
This bug is closed now, the new bug to discuss about that is bug 801072.
Comment 48 Greeny 2013-02-27 02:33:39 PST
This was a feature change request not a bug.
Massive numbers of people are annoyed by this feature change (see many many comments on bug 772319 (and it's 18 duplicates!), bug 801072 , bug 801533 etc).
This bug report should be reopened, the "fix" should be reverted, and the bug report should then be closed as WONTFIX.
Comment 49 Richard Elkins 2013-05-13 13:04:52 PDT
The title is incorrect as stated: "Close other tabs" should always warn about closing multiple tabs.  That is true if the checkbox is checked in preferences > tabs > Warn me when closing multiple tabs.

Checkboxes are there for differing preferences.  This bug report should remain closed.

Actually, currently, leaving the box unchecked does not work as advertised (The warning is ALWAYS popped up - ugh).  THAT, in my opinion, is a bug.
Comment 50 tggm 2013-05-13 13:15:21 PDT
Could we please get some comment on when this issue will be solved? This as the potential to manifest itself on a daily basis.
Comment 51 Grant Wier 2013-05-13 14:08:13 PDT
This shouldn't be all that complicated, there seem to be two unnecessarily competing interests here: prevention of data loss vs disabling of unwanted/annoying warnings.
This is because:

1. There are lossless multiple-tab closures (like exiting the browser, session is saved), which the original warning applied to (at least for the example case).
2. There are lossy multiple-tab closures (like "close other tabs", session is UPDATED to the new state, therefore tab data is lost), which it did not apply to (again, for the example case anyway).

Nobody wants annoying warnings in any cases where they don't care, but any extant lossy cases should either have:
A. an easy undo and/or session backup that makes them lossless (and one at a time undoing an instant closure of 100 tabs doesn't count, if it even works at all for it)
OR
B. a separate warning that requires acknowledgement of the lossyness of the operation before disabling.

Personally i don't care what the solution is, and don't even know what the current status is, i just don't want big lossy operations in easy access of a slipped finger without any recovery or warning, nor pointless annoying warnings for lossless operations.

I only post in hopes of clarifying a situation that strikes me as having way too muddled of conversation around it. If you feel i've missed something about it, then please take 5 real minutes of thought to 1. identify if so for sure and 2. exactly what  before posting about it, in the interest of not regressing back into confusion. ;)
Comment 52 Dave Casey 2013-05-13 14:45:18 PDT
Actually, you have missed something Grant.  The next option down from the "Close Other Tabs" in the pop-up menu is "Undo Close Tab."  I've already tested this by closing half a dozen tabs with the first option and getting them back with the second option.  If I have closed something by mistake, it is quite easy to get it back.
Comment 53 Nathan Williams 2013-05-13 15:09:54 PDT
Unsubscribed.  I gave up on Firefox and moved to chrome mostly because of the bad handling of this very issue.
Comment 54 Grant Wier 2013-05-13 16:28:14 PDT
Dave, quite easy for a few tabs yes. But, as i pointed out, inadequate when there's many.
Especially trying to click it 100 times, right next to the option you've already hit by accident once. Perfect recipe for endless frustration; how many times will you again accidently hit it in the course of undoing the 100 tabs it already closed the first time? Sounds downright Sisyphean! Not even to mention firefox possibly crashing or freezing in the meantime...
Personally, i've used an extension to completely remove the "close other tabs" option from my menu, but that's a kludgey workaround that increases the potential for other issues.
Comment 55 Dave Casey 2013-05-14 05:06:20 PDT
Well Grant, if I were do close many tabs and realize that I didn't want to I would to History, Recently Closed Tabs and Restore All Tabs.  Works like a charm.
Comment 56 tggm 2013-05-14 05:27:50 PDT
I fail to understand why people continue to insist on the stupidity of solving a problem that simply does NOT exist.

Let me simplify matters:

Regular User:  "Warn me on closing multiple tabs" => Checked => Works as expected. Life is beautiful.

Power User: "Warn me on closing multiple tabs" => Unchecked => Works as expected and if I make a mistake it's just a matter of CTRL+H and middle-click all my tabs back to existence. Life is beautiful

Original Reporter of this issue: I want to close all tabs except when I don't want to close all tabs but I still do because I explicitly disabled a warning and now I will vent my frustration over the internet by typing a stupid bug request so that I may irritate millions of people and send them on a discussion that lasts since 2005.

Please people. STOP NOW and revert this to the original behaviour. Warnings exist for a reason and are skippable for advanced users. Stop this mental masturbation once and for all.

Thank you.
Comment 57 iain 2013-05-14 06:06:53 PDT
Like Nathan Williams, I'm using Chrome increasingly over Firefox because of this issue. It's a shame.

I recognize that some users might struggle with closing multiple tabs when they intend to close only one tab. That's a usability issue, which could have several possible solutions. 

However, the solution is definitely not to break the checkbox that says "Warn me on closing multiple tabs". Indeed, that checkbox is surely one answer to the original problem: for users who may accidentally close multiple tabs, they can check "warn me on closing multiple tabs" to be warned on closing multiple tabs. 

The current behavior is as unhelpful as if the "remember passwords for sites" checkbox were to remember passwords even when unchecked, just in case some users might forget their passwords.

I don't understand why this issue is contentious. The checkbox is broken and needs to be fixed.
Comment 58 PouderedWater 2013-07-16 21:14:07 PDT
I need a way to get ride of the warn before. It breaks all my iMacros scripts that use multiple tabs. I'm stuck using windows 15 until the feature is put back in. I see no reason for there being no way to disable the window. It's like you are intentionally importing the worst features of MS Windows. FF is the browser for customization. I don't want to switch to Chrome either but if this keeps up I will have too.
Comment 59 Loic 2013-07-17 02:47:13 PDT
(In reply to PouderedWater from comment #58)
> I need a way to get ride of the warn before. It breaks all my iMacros
> scripts that use multiple tabs. I'm stuck using windows 15 until the feature
> is put back in. I see no reason for there being no way to disable the
> window. It's like you are intentionally importing the worst features of MS
> Windows. FF is the browser for customization. I don't want to switch to
> Chrome either but if this keeps up I will have too.

Seriously?
about:config > browser.tabs.warnOnCloseOtherTabs=false
Comment 60 iain 2013-07-17 03:47:59 PDT
(In reply to Loic from comment #59)
> (In reply to PouderedWater from comment #58)
> > I need a way to get ride of the warn before. It breaks all my iMacros
> > scripts that use multiple tabs. I'm stuck using windows 15 until the feature
> > is put back in. I see no reason for there being no way to disable the
> > window. It's like you are intentionally importing the worst features of MS
> > Windows. FF is the browser for customization. I don't want to switch to
> > Chrome either but if this keeps up I will have too.
> 
> Seriously?
> about:config > browser.tabs.warnOnCloseOtherTabs=false

Or, you know, how about if the checkbox for "Warn me when closing multiple tabs" actually did what it's supposed to do?

Users should not have to fiddle around with "about:config" to make a checkbox do what its description says.
Comment 61 Loic 2013-07-17 03:53:24 PDT
There is a bug about this talk (bug bug 801072).
Comment 62 jakobunt 2013-09-18 15:05:54 PDT
Nobody seems to have noticed here is that the order of the menu entries has changed since this was reported. I presume that "Close Other Tabs" used to be right above "Close Tab" at that time. This is no longer the case (FF23)! The entry "Undo Close Tab" AND a horizontal line now separate them. There is no way to mis-click anymore.

This means the patch can be safely reverted, restoring the old functionality and fixing bug 801072.

Note You need to log in before you can comment on or make changes to this bug.