Open Bug 801072 Opened 7 years ago Updated 4 years ago

Add a visible preference to disable "Close other tabs" prompt

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

People

(Reporter: bugzilla, Unassigned)

References

Details

By user request in Bug 772319, I ask a new visible option to disable the "Close other tabs" prompt, because it results fixed in Firefox 18, but there is no visible preference to uncheck in Options -> Tabs panel.

For coherence, it should act in the same way as the option "Warn me when closing multiple tabs".
See Also: → 772319
Personally I'd suggest a new preference like ""Warn me when closing all tabs except the current".
I would like the original functionality restored.

Right now in FF 17 there is a checkbox under Mainmenu/Options/Options/Tabs that has no function now.   
It used to provide a warning when checked and didn't when not checked.  Easy to understand.   Per Bug 772319 this has now been disabled by design in FF16 and higher, but the checkbox was not removed.   The checkbox is now a dead function that does nothing.  There is a about:config work around that now provides the same function but the end user has to know about it to use it and it is totally disconnected to the checkbox in Options/Tabs.  Again see bug 772319.

This is very sloppy programing that takes away function control from the average end user and back step in user friendliness.   SOME ONE FIX THIS STUPIDITY NOW.
This is marked as 64bit Windows 7.  This effects all platforms not just Win7.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Nathan Williams from comment #2)
> I would like the original functionality restored.
> 
> Right now in FF 17 there is a checkbox under Mainmenu/Options/Options/Tabs
> that has no function now.   
> It used to provide a warning when checked and didn't when not checked.  Easy
> to understand.   Per Bug 772319 this has now been disabled by design in FF16
> and higher, but the checkbox was not removed.   The checkbox is now a dead
> function that does nothing.  There is a about:config work around that now
> provides the same function but the end user has to know about it to use it
> and it is totally disconnected to the checkbox in Options/Tabs.  Again see
> bug 772319.
> 
> This is very sloppy programing that takes away function control from the
> average end user and back step in user friendliness.   SOME ONE FIX THIS
> STUPIDITY NOW.
+1. I find the behavior absolutely exasperating. I had hoped from the discussion of bug 277079 that it was going to be corrected in FF18, but it's still the case.
It'd be great if the original functionality would be restored. When I uncheck the "Warn me when closing multiple tabs" option, I expect the "Close Other Tabs" command to be silent. The current behavior (when confirmation is always displayed) is irritating.

I am aware about the "about:config" switch, but it is for experienced users only. We do not go to Windows Registry to modify preferences for MS Word. I believe that this is an important setting, and it requires a more visible switch.

Thanks a lot.
I agree - very frustrating and a major step backwards for FF IMO. Restore the functionality to the visible check box that is already there. Provide a help link or something if you feel it needs further explanation for the novice user, or present 1 warning box when someone unchecks it to make sure they know what they are doing. Just stop punishing the rest of us who know what we are doing!!!
Still the case in FF19. It's so incredibly patronizing. 

If Chrome weren't spyware for Google, I'd switch immediately.
See Also: 772319
... No. Why do we need an option on the warning tab itself? The preference is very clearly worded. In fact, before FF 18, it worked just fine.
I again am going to request that the actions taken in Bug#277079 and Bug#772319 be undone.  Bug 277079 was very ill conceived and should NOT have been acted on.  The fact that it generated a work around(Bug#772319) that tries to restore that function is strong evidence of that.

Please undo this and restore the functionality of Close all tabs back to it's obvious intended design.
Yes, please restore it or at least explain where you think the objections are wrong. Thanks in advance!
The argument still rages over at <a class="bz_bug_link" href="show_bug.cgi?id=772319" title="VERIFIED FIXED - No option to disable the &quot;Close other tabs&quot; prompt">Bug 772319</a>; see <a href="show_bug.cgi?id=772319#c118">Comment 118</a> through <a href="show_bug.cgi?id=772319#c120">Comment 120</a>. And I have bailed on Firefox.
Sorry about the mess - in a rush - but you get the picture.
This option is critical to my usage of Firefox. Ability to close multiple tabs rapidly is a critical feature of the usability of FF, and it should not be a "hidden" about:config option -- it should be exposed in the user interface in the same way that it used to be.

Removing options that advanced users use only damages the product without making it significantly safer for novice users.
Again, I say that this "fix" needs to be reversed and put back the way it was.  I have used the about:config option, but that is a ridiculous thing to have to do with what is supposed to be one of the market leading browsers.  Just because one fat fingered numbskull clicked on it by accident is no reason remove this option from our use.  And make no mistake, he clicked on it by mistake and has then tried to say that something was wrong with the program as written.  Nothing was wrong with the program and the only error was an "operator" error.
I voted with my feet.  I use chrome now.  Unsubscribing from this bug because I don't care anymore.
Could somebody PLEASE take care of this?
@tggm That would be great, since it's incredible that despite the fact how old this bug entry is, this still happens on Firefox 24 (!) here on Lubuntu 13.10 (b2).

Great, we have a preference to set in Settings now. But it is not recognized. It can be set to either enabled or disabled - the warning will still appear. This is annoying.
Don't bother posting here or on Bug#277079 or Bug#772319. It's an infinite loop, not a dialog, and the FF developers Do. Not. Care.
To be honest, at this point I believe that this is being left un-fixed on purpose. 

For months I've put up with this abomination daily. It's been all a massive exercise in stupidity: The first few posts on Bug#277079, the reasoning to force the prompt, the impact on millions of users, the ignorance that people will now "Close All tabs" by right clicking the tab -> Left-Click -> HIT SPACE REALLY FAST.

Maybe some day I'll start a petition. Until then:

***** you, FF developers. *
Agreed. This whole discussion was snarkily described as "bugspam" by user >>Q<< over on the related bug 772319.

I've given up and use Chrome these days.
I wonder what the target audience of Firefox currently is. Grandma? Junk "safety features" like this are just slowing down everybody who knows what he is doing.

Bye bye Firefox, hello Chrome.
Duplicate of this bug: 956542
Comment #2 - Please do not be distracted by the colorful phrasing.  This comment is pointing out a design flaw in FF 35.0.1.  There are two issues:

1. Don't have an option which is dead.  Specifically, the "warn me when closing multiple tabs" checkbox of Preferences > Tabs doesn't work as indicated; it actually has no effect at all.

2. The purpose of the "warn me when closing multiple tabs" checkbox is to give all users a choice as to be warned or *not* be warned when closing multiple tabs through a "close other tabs" or "close tabs to the right" operation (from the right-tab drop-down menu on a tab).

Like the writer comment #2, I object to resorting to about:config in order to get my choice set.
Duplicate of this bug: 1194839
Can we get an estimation of when this will be fixed? 

Or as an alternative, can we get an explanation of why is this issue NOT being solved? 4 years with a control not working on the FRONT PAGE of the settings window!

Yes, Edit -> Preferences -> General has a control that doesn't work. 

This is, like, being left deliberately unfixed, right?
Still a bug in version 43.0 on Mac, Linux, and Unix.
You can get the expected behavior by changing the warnOnCloseOther preference in about:config

If you search in about:config for "warnOnClose", you can see that there are two options:

* warnOnClose, which is controlled by the "Warn me when closing multiple tabs" checkbox
* warnOnCloseOther, which is not.

If you set warnOnCloseOther to false, you can get the expected behavior. I guess the difference is that first option (the user-visible option) only applies if the current tab is closed as well.

Personally, I'd like to see this as an user-visible preference, right alongside the existing one. Or, at least on the confirm dialog. I have missed this feature greatly, for several browser versions!

I'm doing this on Windows, with FF 43.0.4
You need to log in before you can comment on or make changes to this bug.