After sending the e-mail, the systems 'hangs' on 'copy to send folder...'

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
minor
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Carsten Dohrmann, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
Hi all,

after I press the send button, the next info windows pops up with the message
that the SMTP server gets connected, the e-mail gets send. than it hangs on the
last message 'Copying message to Sent folder...', I have to press cancel and
have to dicard or save the message. 

after this event, I can not see anything in the sent folder and the curser stays
in the 'hour-clock' form till I click to another folder. After closing and
opening Thunderbird again, the system performs a re-indexing of the folder.

However, the e-mail gets send out and copied into the sent folder correctly

This happens not always, but oftener and oftener. I observed that it happens
after I some other mails or there is no conection to the SMTP server. 

my build; version 1.0 (20041206)

regards

Carsten Dohrmann


it happens oftener and oftener that the
(Reporter)

Comment 1

13 years ago
Created attachment 170514 [details]
Print screen of message where it hangs after sending out the e-mail
(Reporter)

Comment 2

13 years ago
Created attachment 170528 [details]
Word file with a sreen copy
(Reporter)

Updated

13 years ago
Attachment #170514 - Attachment is obsolete: true

Comment 3

13 years ago
it's like bug 271259, isn't it?
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> it's like bug 271259, isn't it?

Not really, as the message get sent and copied into the sent folder correctly,
but than the  message window that says 'copying to sent folder....' do not
disapear/terminates and the main 'message write' window do not terminate. I have
to click the cancl button at the first message window and than close the 'write
window' with option clicking 'don't save' to go back to normal main window where
I can see all the folders and messages.

Comment 5

13 years ago
(In reply to comment #0)
Hi,
I've got exactly the same problem (Windows XPSP2 Thunderbird fr version 1.0
(20041206)) for 1 month now.
First, it occurred from time to time, but now each copy to "Sent folder" fail.

Additional info :
My provider has a special imap setting, and  I had to change manually the
"server Imap folder" to "INBOX.".
Outlook express seems to work flawlessly and set up automatically the "INBOX."
thing.

Comment 6

13 years ago
My experience of this is:
1. The problem is intermitent.
2. It never appears if I compose in offline mode and "send later" and then
"connect" and send.
3. Once it started happening, it alsways happen - and restarting thunderbird
does not help.
4. I use different accounts from different providers, and I have not been able
to see and difference between the account - when it happends it concerns all
accounts.

My tests are made on WINXP SP2 with thunderbird version 1.0 (20041206)

Comment 7

13 years ago
My experience:
1. After starting TB, I will be able to send maybe 1-5 emails without a problem
before the problem occurs.
2. Once the problem occurs (as described by others here), it happens every time
until I restart TB. Restarting TB fixes the problem, but...
3. After the problem occurs, One message will be missing from my Inbox, and
replaced by an unread blank message dated 1/1/1970. Quitting TB, deleting the
Inbox index file, and restarting TB restores the Inbox.

Running on Win XP SP2, Thunderbird 1.0 (20041206) with a POP3 account.

Comment 8

13 years ago
Further to my tale of woe in comment #7:
4. THis still happens if I compose in Offline mode. In this case, when I click
"Send Later" it hangs on "Copying message to Unsent Items folder". However, the
message does in fact get copied. The Inbox corruption still occurs.
5. This still occurs with TB 1.0.2. Damn.

Comment 9

13 years ago
nothing has changed in 1.02. If you want to try a new build, try a trunk build.

Comment 10

13 years ago
I have a hunch this is connected to a filter bug. I started getting this problem
when i had a filter copying every mail into a folder called "inbox archive" (to
prevent need for constant profile backups). The problem disappeared once i
turned off this filter (which caused other problems too like sometimes putting
only a copy in the archive and leaving none in the normal inbox, causing less
junk recognition, and/or keeping recogised junk in the inbox).

Comment 11

13 years ago
Isn't this related or identical to bug 271259 ?
https://bugzilla.mozilla.org/show_bug.cgi?id=271259

Comment 12

13 years ago
Is it like the bug 231493?

Comment 13

13 years ago
It is not like bug <a
href="https://bugzilla.mozilla.org/show_bug.cgi?id=231493">231493</a>. Read the
bug descriptions; they're quite clear, and quite different.

There are similarities with <a
href="https://bugzilla.mozilla.org/show_bug.cgi?id=271259">271259</a>. The
corrupted inbox, for example. Either that or the bugs are different and I am
getting bitten by both of them. Lucky me.

I am using filters, including one that copies all incoming messages to a folder.
Perhaps I will try turning it off to see what effect that has.

Comment 14

13 years ago
I seem to have fixed the problem by disabling my message filter. It was a filter
that copied all incoming messages to an archive folder.

Strange that it's an incoming message filter, yet seems to trigger this bug in
outgoing messages. Also annoying.

Comment 15

12 years ago
This is specifically to Carsten Dohrmann, who opened this bug.  It might also be 
of help to some of the other reporters here.  (Ekhart, and Boying Lu, were 
talking about bugs that I think are completely unrelated.):

Is this for IMAP mail?  There have been some recent fixes around several 
different apparent hangs when copying messages to the Sent folder; see in 
particular bug 287658, bug 123063, bug 163951.  

The fixes for those are in 1.5b1 and branch builds as well as trunk builds.
(Reporter)

Comment 16

12 years ago
To whoever is working on the fix.

It happend with any POP server. However, since a couple of month I have not seen
it happen again. Looks like it is solved (with 1.0.6), or a change of my system
environment had a positive side effect on it.

No idea if it is still valid for other users.

cheers

Carsten

Comment 17

12 years ago
=> WFM per reporter's comment 16.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.