Closed Bug 280298 Opened 16 years ago Closed 16 years ago

Plain text structured formatting not working well

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 106028

People

(Reporter: legege, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20041107 Firefox/1.0

In the message view window, some formatting can be done with specials characters
like * / _. But :
First, we cannot use them all together.
Second, when characters like (:) are inside, it doesn't work (ex. *List :*)
Third, it doesn't work with accent characters like é, à, ...

Reproducible: Always

Steps to Reproduce:
Try :
- *List :*
- */_Hello_/*
- *Québec*

Actual Results:  
They are not bold, italic or underlined.

Expected Results:  
They should be bold, italic or underlined.
(In reply to comment #0)
> In the message view window, some formatting can be done with specials
> characters like * / _. 

FYI, this feature is called "structured text".

> First, we cannot use them all together.
bug 158706

> Second, when characters like (:) are inside, it doesn't work (ex. *List :*)
> Third, it doesn't work with accent characters ....

see the dupe (and bug 206298, which was duped to that one).

This *does* work for the Québec case -- accented characters (and punctuation, 
spaces, and numbers) are only a problem in the position immediately following or 
preceding the markup character.  The leading/trailing character is limited to 
plain ASCII letters: A-Za-z

*** This bug has been marked as a duplicate of 106028 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Summary: Plain text formatting not working well → Plain text structured formatting not working well
Assignee: mscott → nobody
You need to log in before you can comment on or make changes to this bug.