{table-reflow} Clicking on URL dynamically resizes table cells

VERIFIED WORKSFORME

Status

()

Core
Layout: Tables
P3
normal
VERIFIED WORKSFORME
19 years ago
18 years ago

People

(Reporter: Joseph Elwell, Assigned: karnaze (gone))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
This basically bug 7522. That bug was marked WORKSFORME and was asked to have a 
new bug opened.

Here is a good way to reproduce:
1)Load http://www.mozilla.org/
2)Click on "Windows" to begin downloading the windows nightly build. 
3)Watch the tables resize.

Another way to reproduce it: 
1)Load http://www.slashdot.org/
2)While the page is loading click on a link.(Most noticeably to an URL outside 
of the slashdot.org domain)
3)Notice the tables resize.

I'm using build 2000021608 winNT.

Comment 1

19 years ago
I experience this problem on a linux cvs build from today 2000-02-17.
Perhaps the platform and OS should be changed to ALL, since it doesn't
look like a Windows only problem.
(Reporter)

Updated

19 years ago
OS: Windows NT → All

Comment 2

19 years ago
*** Bug 28377 has been marked as a duplicate of this bug. ***

Comment 3

19 years ago
hint on reproducing from #28377:
> Right-clicking on links on the mozilla page causes shrinking of the table
> columns in which the link is contained. It happens only on the second and
> the third column of the main table.

Comment 4

19 years ago
Not only clicking on a link will reflow the table. If you resize the browser
window a little on /. you will see the same reflow happen.
Text moves around and eventually the clicked link will move so far away, that
you will have to click a second time to get it. That's a nasty thing.

Could this also be related to bug 25053 a:hover causes font size change and
subsequent reflow?

Comment 5

19 years ago
This can also been seen on:

http://www.cybernettix.vuurwerk.nl/animated.html

For example, click on the "mail mozilla" link on the first column on the left 
(titled 1-10).  The page will reorganize, and the link must often be clicked 
again to actually activate.

After some experimentation, it seems that only clicking links below the 
longest-named link will cause this behavior.  Thus, on the page listed above, 
anything below "Swimming on a ruler" will cause reorganization.  Clicking on the 
longest item itself causes no reorganization.  The same holds for the other 
columns;  repeated reorganizations can be caused by clickin on items from 
different columns, as long as they are below the longest entry for that column.

Comment 6

19 years ago
A particularly bad example can be seen at http://www.nasdaq.com
Clicking in one of the text-entry fields will shift the entire page about two
inches to the right, moving the graphs off of the screen.

This happens in Mozilla 2000030312 for Linux.

Comment 7

19 years ago
Additional testcase:

1. Go to http://www.dn.com
2. Click on the "Linux servers" link on the left
3. Click on the "NT servers" link on the left

The page should shift, showing duplicate sets of the graphics; sometimes this
can be experienced on the first page (www.dn.com), sometimes it you have to go
into the site to get it to work.

Comment 8

19 years ago
Could one of you take a look at 30628 and see if it is a duplicate.

Comment 9

19 years ago
I'm uploading a testcase that shows Mozilla resising cells (not the entire
table) when a link is clicked.

When creating the testcase, I noticed that the problem occurred only when :
The link color was specified in the BODY tag.
The font size was specified as larger than normal ("3" in this case).
The user selected a link after the first two in the cell.

I'm posting this as a testcase for bug 30628 as well.

Comment 10

19 years ago
Created attachment 6180 [details]
Simple testcase for table cell resize on clicking link
(Assignee)

Comment 11

19 years ago
I'm not seeing the problem in the tescase but I do see upon right clicking in 
www.mozilla.org links and www.nasdaq.com.
Status: NEW → ASSIGNED
Target Milestone: M16

Updated

19 years ago
Blocks: 28522

Comment 12

19 years ago
This bug is probably a dup of bug 7617. CCd attinasi who is working on it.
I also marked this bug as dependent of bug 28522. See comments there.

Comment 13

19 years ago
This bug is a dup of 7617. Also, the test case does show the problm but only on 
items 4 and 5 which toggle the column width back and forth. 

Chris, do you want to mark this as a dup of bug 7617 or keep it for yourself?

Comment 14

19 years ago
*** Bug 7617 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
Someone please change the platform to "all"?  This is a cross-platform bug.
(Reporter)

Comment 16

18 years ago
deven@ties.org : I don't see any reports for any Platforms other than PC. Note,
that the OS is set to ALL. Add a comment with your Platform, OS and build ID if
it isn't covered.

Comment 17

18 years ago
This is a bug in the incremental reflow code for HTML tables.  This is XP code
and part of the layout engine; how could the platform possibly affect it?
(Assignee)

Comment 18

18 years ago
I'm not seeing the problem on any of the urls mentioned.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 19

18 years ago
marking verified. using winNT build 2000051012.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.