sync xpfe toolbarbutton.xml with toolkit toolbarbutton.xml

RESOLVED FIXED in mozilla1.8.1alpha2

Status

()

RESOLVED FIXED
14 years ago
12 years ago

People

(Reporter: mconnor, Assigned: sgautherie)

Tracking

(Blocks: 1 bug, {fixed-seamonkey1.1a, fixed1.8.1})

Trunk
mozilla1.8.1alpha2
fixed-seamonkey1.1a, fixed1.8.1
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [verified-seamonkey1.1a])

Attachments

(4 obsolete attachments)

(Reporter)

Description

14 years ago
 
(Reporter)

Updated

14 years ago
Blocks: 282177
(Reporter)

Updated

14 years ago
URL:
Summary: sync xpfe toolbarbutton.xmll with toolkit toolbarbutton.xml → sync xpfe toolbarbutton.xml with toolkit toolbarbutton.xml
(Assignee)

Comment 1

14 years ago
Created attachment 176675 [details] [diff] [review]
(Av1) <toolbarbutton.xml>
[Checked in: Comment 2]

Untested, but so obvious...
(What would be the expected non-regression test for this change ?)

This came from Toolkit version:
{{
1.3	blakeross%telocity.com	2004-02-20 23:14		Fix bad
capitalization.
}}
Assignee: nobody → gautheri
Status: NEW → ASSIGNED
Attachment #176675 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #176675 - Flags: review?(neil.parkwaycc.co.uk)

Updated

14 years ago
Attachment #176675 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #176675 - Flags: superreview+
Attachment #176675 - Flags: review?(neil.parkwaycc.co.uk)
Attachment #176675 - Flags: review+
(Assignee)

Comment 2

14 years ago
Comment on attachment 176675 [details] [diff] [review]
(Av1) <toolbarbutton.xml>
[Checked in: Comment 2]


Check in: { 2005-03-08 07:44	neil%parkwaycc.co.uk	mozilla/ xpfe/ global/
resources/ content/ bindings/ toolbarbutton.xml  1.8 }
Attachment #176675 - Attachment description: (Av1) <toolbarbutton.xml> → (Av1) <toolbarbutton.xml> [Checked in: Comment 2]
Attachment #176675 - Attachment is obsolete: true
(Assignee)

Comment 3

14 years ago
Created attachment 176786 [details] [diff] [review]
(Bv1) 2005.03.08 X2T diff report

Diff from Xpfe to Toolkit version.

These came from Toolkit versions:
{{
1.5	ben%bengoodger.com	2004-11-30 20:48		Aviary branch
landing
1.4	ben%bengoodger.com	2004-03-06 20:42		214893 - Mail
Integration UI - add "Mail" button to toolbar palette, with a submenu providing
convenient access to mail, newsgroups. also adds Ctrl+M to compose new message.

}}
(Assignee)

Comment 4

14 years ago
(In reply to comment #3)
> Created an attachment (id=176786) [edit]
> 2005.03.08 X2T diff report

How to proceed with this part ?
Can it be added as is, or is anything else needed ?
Status: ASSIGNED → NEW
Keywords: helpwanted

Comment 5

14 years ago
yes, this and don't forget to add this to xul.css:
 toolbarbutton[orient] {
   -moz-binding:
url("chrome://global/content/bindings/toolbarbutton.xml#menu-orient");
 }

This is used for Read Mail toolbar button.

Comment 6

14 years ago
Comment on attachment 176786 [details] [diff] [review]
(Bv1) 2005.03.08 X2T diff report

I'd like to use this for the Classic theme's "File" button in messenger - but
I'd need to change the xul:box to a xul:vbox if that's ok with you?
Attachment #176786 - Flags: review?(mconnor)

Comment 7

14 years ago
In regards to comment #5, this introduced a bug into firefox. That bug is number
252393. I attached a patch to that bug.
(Assignee)

Updated

14 years ago
Depends on: 214893, 252393
(Reporter)

Updated

13 years ago
Attachment #176786 - Flags: review?(mconnor) → review+
(Assignee)

Updated

13 years ago
Attachment #176786 - Attachment description: 2005.03.08 X2T diff report → (Bv1) 2005.03.08 X2T diff report
(Assignee)

Comment 8

13 years ago
Created attachment 219242 [details] [diff] [review]
(Bv2-XPFE) <toolbarbutton.xml> ++
[Checkin: Comment 16 & 23]

Bv1, updated to current Trunk:
in fact, it's now a port, of the (TB+TK) attachment 214196 [details] [diff] [review] in bug 252393,
which addresses comment 5 and comment 6.

Untested.
Attachment #176786 - Attachment is obsolete: true
Attachment #219242 - Flags: superreview?(neil)
Attachment #219242 - Flags: review?(neil)
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Keywords: helpwanted
Target Milestone: --- → mozilla1.9alpha

Comment 9

13 years ago
Comment on attachment 219242 [details] [diff] [review]
(Bv2-XPFE) <toolbarbutton.xml> ++
[Checkin: Comment 16 & 23]

This is fine except for the Modern theme which has its own way of handling this.
Attachment #219242 - Flags: superreview?(neil)
Attachment #219242 - Flags: superreview+
Attachment #219242 - Flags: review?(neil)
Attachment #219242 - Flags: review+
Does this patch here need to be checked in?
(Assignee)

Comment 11

13 years ago
(In reply to comment #10)
> Does this patch here need to be checked in?

No, Neil already done it;
but I have kept the bug untouched, waiting for some email answers...

Comment 12

13 years ago
Please ask bug questions in the bug, mail tends to get dropped, esp. if it hardly readable in style like your mails (like whiteboard entries) tend to be.

So, what's the remeaining issue here?
(Assignee)

Comment 13

13 years ago
(In reply to comment #9)
> (From update of attachment 219242 [details] [diff] [review] [edit])
> This is fine except for the Modern theme which has its own way of handling
> this.

1) Then the modern button.css file stays as it is !? (as in your checkin.)

2) I believe the widgets/bindings patchs can/should go in the v1.8.1 branch, can't they ? (contrary to XUL Runner work which is Trunk specific.)

3) After synchronizing TK and XPFE, the idea seems to be to build directly SeaMonkey from the Toolkit file (before they diverge again).
Could you (or who else ?) post a patch for this bug, which I could use as a template for the other bugs then ?

Comment 14

13 years ago
A template for your issue #3 is in bug 282190

Comment 15

13 years ago
(In reply to comment #13)
>1) Then the modern button.css file stays as it is !? (as in your checkin.)
Right.

>2) I believe the widgets/bindings patchs can/should go in the v1.8.1 branch,
>can't they ? (contrary to XUL Runner work which is Trunk specific.)
They could do, if anyone wanted.
(Assignee)

Comment 16

13 years ago
Comment on attachment 219242 [details] [diff] [review]
(Bv2-XPFE) <toolbarbutton.xml> ++
[Checkin: Comment 16 & 23]


Checkin: { 2006-04-21 02:43	neil%parkwaycc.co.uk }

'approval-branch-1.8.1=?': (SeaMonkey only)
Simple U.I. code synchronisation (was Toolkit->XPFE, now Trunk->branch), no risk.
Attachment #219242 - Attachment description: (Bv2-XPFE) <toolbarbutton.xml> ++ → (Bv2-XPFE) <toolbarbutton.xml> ++ [Checkin: Comment 16]
Attachment #219242 - Flags: approval-branch-1.8.1?(mscott)
(Assignee)

Comment 17

13 years ago
Created attachment 220532 [details] [diff] [review]
(Cv1) <jar.mn>

Now, switch to use the toolkit file directly, per comment 14.
(untested)

This switch would not be welcomed on the 1.8 branch, would it ?
Attachment #220532 - Flags: superreview?(neil)
Attachment #220532 - Flags: review?(mnyromyr)

Updated

13 years ago
Attachment #219242 - Flags: approval-branch-1.8.1?(mscott) → approval-branch-1.8.1+

Comment 18

13 years ago
Comment on attachment 220532 [details] [diff] [review]
(Cv1) <jar.mn>

We don't need this because the xulrunner version of SeaMonkey will already use toolkit toolbarbutton.xml
Attachment #220532 - Flags: superreview?(neil)
Attachment #220532 - Flags: superreview-
Attachment #220532 - Flags: review?(mnyromyr)
(Assignee)

Updated

13 years ago
Attachment #220532 - Attachment is obsolete: true
(Assignee)

Comment 19

13 years ago
(In reply to comment #18)
> (From update of attachment 220532 [details] [diff] [review] [edit])
> We don't need this because the xulrunner version of SeaMonkey will already use
> toolkit toolbarbutton.xml

Is this situation specific to toolbarbutton.xml, or are such patches useless for all the (other) widgets too ?

Then, I guess it answers my other question too:
direct usage of toolkit files is not wanted for non-SuiteRunner (both Trunk and branch), right ?
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 20

13 years ago
(In reply to comment #19)
>Is this situation specific to toolbarbutton.xml, or are such patches useless
>for all the (other) widgets too ?
We'd still like to have them in sync so that there are fewer surprises.

>Then, I guess it answers my other question too:
>direct usage of toolkit files is not wanted for non-SuiteRunner (both Trunk and
>branch), right ?
Right.
(Assignee)

Comment 21

13 years ago
(In reply to comment #20)
> (In reply to comment #19)
> >Is this situation specific to toolbarbutton.xml, or are such patches useless
> >for all the (other) widgets too ?
> We'd still like to have them in sync so that there are fewer surprises.

Agreed: sync'ing the widgets files is still to be done.

I meant to ask whether the jar.mn patch would be needed for all/some other widgets, or for none (now) ?

Comment 22

13 years ago
(In reply to comment #21)
>I meant to ask whether the jar.mn patch would be needed for all/some other
>widgets, or for none (now) ?
There are a couple of widgets that are completely different and for those we will have to move the xpfe version to suite/common but apart from those there will be no jar.mn changes.
(Assignee)

Comment 23

13 years ago
Comment on attachment 219242 [details] [diff] [review]
(Bv2-XPFE) <toolbarbutton.xml> ++
[Checkin: Comment 16 & 23]


Checkin: { 2006-05-05 06:57	bugzilla%standard8.demon.co.uk  	MOZILLA_1_8_BRANCH }
Attachment #219242 - Attachment description: (Bv2-XPFE) <toolbarbutton.xml> ++ [Checkin: Comment 16] → (Bv2-XPFE) <toolbarbutton.xml> ++ [Checkin: Comment 16 & 23]
Attachment #219242 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Keywords: fixed-seamonkey1.1a, fixed1.8.1
Target Milestone: mozilla1.9alpha → mozilla1.8.1alpha1
(Assignee)

Comment 24

13 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20060505 SeaMonkey/1.1a] (tinderbox-builds, 2006050514) (W98SE)

V.Fixed (per comment 6 case) for SeaMonkey on 1.8.1 branch.
Whiteboard: [verified-seamonkey1.1a]
Target Milestone: mozilla1.8.1alpha1 → mozilla1.8.1alpha2
(Assignee)

Updated

13 years ago
Blocks: 336873
You need to log in before you can comment on or make changes to this bug.