Rename "Sanitize" feature to "Clear Private Data"

RESOLVED FIXED in Firefox1.5

Status

()

--
enhancement
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: ryanrafferty, Assigned: beltzner)

Tracking

(Blocks: 1 bug)

Trunk
Firefox1.5
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [1.8 Branch ETA 8/10])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.5.6 (KHTML, like Gecko) Safari/125.12
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050305 Firefox/1.0+

The function could be called 'Shredder' -- It is a term analogous to the removal and destruction of 
sensitive information. It provides a real-world metaphor that people can instantly relate with. It can also 
be easily represented in the form of an icon, similar to the trash-can/recycle-bin found in Thunderbird.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

14 years ago
Summary: Suggestion for the replacement of the word Sanitize → Rename "Sanitize" feature to "Shredder"

Comment 1

14 years ago
I like this idea. I think the work 'sanitize' could be confusing to the user as
it does not really give a clear indication of what it will do. Perhaps you could
be even more verbose like "Clear all browsing information" or "Delete browsing data"
Some guys in MZ forum are quite interested in this bug.
http://forums.mozillazine.org/viewtopic.php?t=226601
Version: unspecified → Trunk
*** Bug 295651 has been marked as a duplicate of this bug. ***
Assignee: firefox → nobody
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
(In reply to comment #3)
> *** Bug 295651 has been marked as a duplicate of this bug. ***

Sorry for the dupe submission -_-'  I thought this bug was only for renaming as
"Shredder."  Since it's serving as a general "rename 'Sanitize'" bug though,
I'll nominate "Clear Tracks" as an alternative.

People in the MZ thread seem okay with it, and it fits nicely with the animal
imagery (picture a set of fading pawprints as an accompanying graphic :).

Comment 5

14 years ago
So i guess this bug is about renaming "Sanitize" to something better? And not
specifically "Shredder" (see dupe)?

In that case, my suggestion is "Reset". Camino and Safari uses that name. Nice
and short.
>The words Clear and Clean seem to appear most commonly

Summary: "Shreader" -> "Clear Tracks"

Summary: Rename "Sanitize" feature to "Shredder" → Rename "Sanitize" feature to "Clear Tracks"

Updated

14 years ago
Flags: blocking-aviary1.1?

Comment 7

14 years ago
(In reply to comment #5)
> So i guess this bug is about renaming "Sanitize" to something better?

Yes. Ben posted on his blog when landing the new pref window that they were in
search of a better name:
http://weblogs.mozillazine.org/ben/archives/2005_02.html

Comment 8

14 years ago
"Cover Your Tracks" is clever. If clever is what we seek, that's what I'd vote for.
But I tend to lean toward something that desribes directly what will happen. 
Like  "Clear Stored Data"

Let's get some noise here and decide before it's too late for 1.1.

Updated

14 years ago
Flags: blocking-aviary1.1? → blocking1.8b4?
I agree with Tracy, we should make sure that we select something that describes
what will happen. "Cover your tracks" is okay, but I would be in favor of
something like "Erase my tracks" since that makes it pretty clear that if you do
it the stuff is gone for good.

(In reply to comment #8)
> "Cover Your Tracks" is clever. If clever is what we seek, that's what I'd vote
for.
> But I tend to lean toward something that desribes directly what will happen. 
> Like  "Clear Stored Data"
> 
> Let's get some noise here and decide before it's too late for 1.1.

Comment 10

14 years ago
Don't forget the "Sanitize Options" button. That would mean a long "Cover your
track Options" button. Or "Tracks Options".

As mentioned before, Camino uses "Reset Camino...".

Comment 11

14 years ago
Reset implies loss of settings, it's an incredibly bad term. 

I'd suggest "Clear Tracks" for the menu item, but not for the prefs. "Auto
Clear" or similar would work fairly well, and would attract the eye of anyone
looking to tweak such settings.

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4+

Comment 12

13 years ago
You could also consider "Erase Private Information".

Updated

13 years ago
Assignee: nobody → cbeard
Whiteboard: [needs research] [eta 7/30]

Updated

13 years ago
Summary: Rename "Sanitize" feature to "Clear Tracks" → Rename "Sanitize" feature to "Clear Tracks..." or "Clear Saved Information..."
Someone who's trying to get rid of this information is looking to clear the
browser's memory of the various places visited and tokens accumulated while
browsing. Sadly, "Clear Memory" kinda sucks as a name for this function,
although really it's probably the most correct :)

Why we don't just call this "Clear History ..." By default, it brings up the
dialog (the user has to check a preference to make it do it without asking)
which asks what aspects of the history should be cleared. In the "Privacy"
options tab, the option could be called "Clear History Settings ..." I think
that both of these names will be easier to understand by novices who know that
browsers keep a history of where they've been, but might not realize all the
types of information a modern browser keeps track of.

A valid concern with this suggestion is that privacy-savvy users might think
that this function would *only* clear the browsing history, despite there being
an elipses (which indicates there's more options to choose from in the
function.) Although I don't think that will really be hard for people to discover.

Comment 14

13 years ago
(In reply to comment #13)
I think it has to be something that encompases the action, so "Clear History..."
is pretty confusing since you get a similar option in the Options ("Clear
Browsing History Now").

By sanitizing, what the user essentially doing is clearing out his private
information (cookies, cache, history, ssl sessions, etc..).

I don't like using "Clear Tracks..." because it implies some kind of criminal
activity.

"Clear Saved Information..." is also not good, since from a first look, you
don't know what "Saved Information" is.. Some might think that this completely
resets the browser (clears bookmarks, profile, etc..).

I'm leaning towards a term that has the words "Private Information" in it.

I'm going to throw in some random words for you to play with:
 - Eliminate
 - Erase
 - Clear
 - Clean
 - Destroy
 - Delete
 - Private
 - Privacy
 - Information
 - Settings
 - Trace
 - Tracks
 - Browsing/Internet Activity

Updated

13 years ago
Blocks: 302607

Comment 15

13 years ago
(In reply to comment #14)
> I don't like using "Clear Tracks..." because it implies some kind of criminal
> activity.

I agree with this. 

For the record, here are the naming of other browsers for the same functionality:
Safari, Camino = "Reset Camino/Safari"
Opera = "Delete private data"
IE7b1 = "Delete browsing history"

Comment 16

13 years ago
I think "reset" shouldn't be used at all since it implies that everything is
resetted - which means options, extensions and other things.

I agree that it should be clear what this entry will do - it shouldn't be a name
where you first need to read an explaination (i.e. like "cookie"), it should be
something where you actualy know what will be done or what it is good for (like
"begin finding when you begin typing").

While "Clear Tracks" maybe clear to me, I'm not sure whether the average user
will know. As far as I can tell with my knowledge of the English language,
"clear tracks" somehow sounds if it would be illegal to do so.

I'm fine with "clear private/personal information" (erase somehow sounds that
"hard" to me - and so does shredder) or something similar since this is exactly
how magazines explain "sanitize" when they report about it. 

E.g. heise.de described it this way: "während des Websurfens zu Stande gekommene
persönliche Daten"
which could be translated with "personal data created while surfing". 
(In reply to comment #16)
> E.g. heise.de described it this way: "während des Websurfens zu Stande gekommene
> persönliche Daten"
> which could be translated with "personal data created while surfing". 

Ah, to be young and have that many characters to play with :)

The content that is being cleared by this function is truly hard to describe.
It's "delete all of the stuff that the browser is remembering about this user
*except* for bookmarks, themes, extensions, window positions, file handlers and
download locations" (note that the exception is why "reset" is a problematic
choice.) 

Caleb: I know that there's overlap between "History ..." and "Browser History",
but I was hoping (perhaps naively) that we'd see one of two scenarios:

1) Expert user looking to clear all private information: Sees "Clear History
..." under tools and notes the elipses so hoeps for an advanced option. This
leads him to the list of possible types of history (including browsing history)
to be cleared.

2) User looking to clear just the browser history: a direct hit, and then also
gets to see a bunch of other types of things that can be cleared. We might want
to make sure our default options are sensible to cover this case.

The reason I like "Clear History" (or Erase/Scrub/Delete) is that the type of
content that we're offering to clear is all historical browsing data as opposed
to explicit browser settings. I'd be thrilled if someone could come up with a
better term that classifies the type of information; the only other one I've
heard, and a good 2nd choice IMO would be "Clear Personal Information" (or
Erase/Scrub/Delete).

Comment 18

13 years ago
(In reply to comment #17)
> 1) Expert user looking to clear all private information: Sees "Clear History
> ..." under tools and notes the elipses so hoeps for an advanced option.

You pretty much lost me after "notes the elipsis and hopes for an advanced option".

I'd go for "Clear Personal Information" though.
As far as I can tell, as it stands, everything in the "Privacy" part of
Preferences is also included in the "Sanitize" options (and vice versa).  It's
also (confusingly) possible to set your Sanitize options such that they override
the Privacy settings, without there being any indication that this is the case.

For example, in Privacy, I can set my browser to "Remember visited pages
for...[X] days".  At the same time, however, I can have my Sanitize options set
to automatically clear my Browsing History on exit.  The Sanitize option will
override the Privacy option, and yet there is nothing telling me so.

Given that the types of information covered by Privacy and Sanitize are the
same, is there no way that we could merge these two seemingly independent
features into one?  

As I see it, there are two settings for each type of information covered here:

1) A user-defineable default behaviour.  For example "Remember visited pages for
9 days", or "Automatically clear list of visited pages on exit."
2) The ability to have the information optionally cleared on demand (either via
the Tools menu, the Preferences dialog, or via a shortcut key).

Would it make sense to put all of the following types of information in the same
section of the Preferences dialog?  Maybe we could also change "Privacy" to
"History" since, as Beltzner points out, it is really a collection of historical
information and artifacts that are being stored, managed, and cleared.

* Visited Pages
* Saved Forms
* Passwords
* Downloads
* Cookies
* Cache
* Authenticated Sessions
"clean slate" ?
Possible suggestions

"clear web data" as the data is related to webpages whereas the options settings
are associated with your computer

related is "flush web data" (I'm not so sure about that one)

or "clear web information" (possibly less technical), I think web information is
more accurate than saved information.

"destroy web data" - indicates that the data is deleted not moved, simularly
"erase web data" (probably too technical)

Comment 22

13 years ago
For the record, "Sanitize" WFM

I like it. It's a clean sounding name for lack of a better word. [This is not an
attempt at a pun; its simply the best description I can come up with]

And, importantly, it sets Fx apart from the rest. Please don't
scrub/rinse/clean/clear/wash my tracks/history. Give me something new.

And IMO, it is not anymore difficult to understand to the nontechnical user than
any of the other terms. The technical user could of course understand it if you
called it <insert four lines of geek code>.
Sanitize is meaningful if you know what sorts of things within the modern web
browser need to be wiped/cleaned/etc, and also if you feel that that sort of
information is "dirty" or problematic to keep around. We don't want to pick a
term that sets us apart from other people; we want to pick functionality that
sets us apart, and present in a way that makes it as easy to understand as
possible (thus setting us apart).

Despite my own feelings on this issue, and Dria's quite astute observation that
there are pretty inconsistent ways for managing one's historical/cached browsing
data, I think that in order to make the 1.5 deadline, we should probably try to
keep things focused on what the button currently does offer, and how best to
express that. It's a button that gives a user quick access to deleting
historical/cached browsing data which is lumped together under the heading of
"Privacy" in the options/prefs.

As such, I'd say that the leading contenders for making this happen in time for
1.8b4 are:

"Clear Personal Data"
"Clear Private Data"

(the button in the preference page would be the same label)
Whiteboard: [needs research] [eta 7/30] → [needs research] [eta 8/5]

Comment 24

13 years ago
Mike, sounds good. How about picking one for us ;-) Either one is considerably
better than what we have and we need to get this patched ASAP so that our doc
people and our l10n people can include this change. 
Summary: Rename "Sanitize" feature to "Clear Tracks..." or "Clear Saved Information..." → Rename "Sanitize" feature to "Clear Private Data" or "Clear Personal Data"
Whiteboard: [needs research] [eta 8/5] → pending decision on "private" or "personal"

Comment 25

13 years ago
I really don't want to be involved in picking bike shed colours here, but "clear
personal data" could quite well mean bookmarks, and "data" is a geek word
anyway. If the best argument against "clear tracks" is potentially offending
people I'd go for it. No privacy erasers that are commercially available shy
away from this kind of language.

 - Chris
"Clear Private Data" is the winner, since it ties in closest with "Privacy"
which is the name given to the closely-related options panel.
Whiteboard: pending decision on "private" or "personal" → 1.8 Branch ETA [8/9]
(In reply to comment #26)
> "Clear Private Data" is the winner, since it ties in closest with "Privacy"
> which is the name given to the closely-related options panel.

"Clear Privacy Data" seems more consistent...?

(In reply to comment #23)
> (the button in the preference page would be the same label)

You mean "Sanitize Seetings..." -> "Clear Private Data Settings..." ?
It sounds we are going to clear "Private Data Settings".
We should adjust somehow, e.g. "Settings of...", "Configure...", etc.

Maybe, we need a draft patch for further discussion.

Comment 28

13 years ago
Sorry for chiming in so late.  I like the current thinking better than what's
currently implemented.  But I think Remove/Removal is better than Clear.  The
tools menu could be Remove Private Data... and the options dialog button could
be Data Removal Settings or Configure Data Removal.  The privacy/private part of
the data is implied by the tab of the options dialog and can also be made clear
with the label that is to the right of the button.  Otherwise the button would
be something like Data Clearing Settings or Configure Data Clearing.

Updated

13 years ago
Assignee: cbeard → mconnor
Blocks: 300860
Whiteboard: 1.8 Branch ETA [8/9] → 1.8 Branch ETA [8/10]
(In reply to comment #27)
> "Clear Privacy Data" seems more consistent...?

Privacy settings are the settings that govern one's private data. I think we
want to (for 1.5) use the words in those particular contexts.

> You mean "Sanitize Seetings..." -> "Clear Private Data Settings..." ?

I'd actually meant "Sanitize Settings..." -> "Clear Private Data ...", but I
think we actually need the button to really call out that it's the place where
users can change the settings that govern how the browser automatically (or
semi-automatically) clears all that data. (This button is really doing too much,
actually, as it's acting as both a settings )

How about: "Default Clear Data Settings..."

> Maybe, we need a draft patch for further discussion.

Agreed. This can change after beta if it's awful, too.
> (This button is really doing too much, actually, as it's acting as both a
>settings )

For those who were waiting for the thrilling conclusion, that was meant to say ..:

This button is really doing too much, actually, as it's acting as both a
settings window for what types of information are cleared by the "Clear Private
Data" tool, as well as the settings window for what is cleared on shutdown,
which somewhat overrides/changes settings that are set outside of the settings
window.

Upon reflection, I'm not sure that makes the point any clearer.
This renaming affects all localizations except those who already translated the
untranslatable Sanitize as a "Clear Private/Personal Data". 

Adding the firefoxl10n watcher to CC.
(In reply to comment #30)
> This button is really doing too much...

How about moving the label from <button/> to <groupbox/>?

/---------------------------------------\
|  _____________________  Sanitize is a |
| | Sanitize Settings...| blah foo bar  |
|  ---------------------                |
\---------------------------------------/

->

/--- Clear Private Data ---------------\
| Clear Private Data is  ____________  |
| a blah foo bar        | Settings...| |
|                        ------------  |
\--------------------------------------/

And we can add another button such as "Clear Now", in the future.
I don't think that full group box treatment is needed; it would make the page
look a little too boxy. But I do like the idea of moving the button to the right
hand side

So:

The Clear Private Data tool can be used to erase your private
information from the Tools menu or when %S closes.             [Settings ...]

Updated

13 years ago
Whiteboard: 1.8 Branch ETA [8/10] → [1.8 Branch ETA 8/10]
Created attachment 192467 [details] [diff] [review]
patch to change "Sanitize..." to "Clear Private Data..." everywhere in UI

I'm pretty sure that I got all the places. There are a few associated label
changes in here as well to make the grammar work:

in the dialog that comes up from the tools > menu item
  checkbox: "Ask me before clearing private data"
  button: "Clear Private Data Now"

in the prefs > privacy > settings ... dialog:
  section header: "Private Data"
  label: "Select the items to be cleared:"
  section header: "Settings"
  checkbox: "Clear private data when closing %S"
  checkbox: "Ask me before clearing private data"
Attachment #192467 - Flags: review?(mconnor)
(In reply to comment #34)
> Created an attachment (id=192467) [edit]

Good job. I found a minor glitch.

>  # Sanitize
> -sanitizeWithPromptLabel=Sanitize %S...
> -sanitizeButton=Sanitize Now
> +sanitizeWithPromptLabel=Clear Private Data...
> +sanitizeButton=Clear Private Data Now

You smashed "%S" in sanitizeWithPromptLabel,
then getFormattedString() would be replaced with getString()

http://lxr.mozilla.org/mozilla/source/browser/base/content/browser.js#1181

- var brandShortName = bundleBrand.getString("brandShortName");
- sanitizeItem.label = bundleBrowser
-                       .getFormattedString("sanitizeWithPromptLabel",
-                                           [brandShortName]);

->

+ sanitizeItem.label = bundleBrowser.getString("sanitizeWithPromptLabel");
Created attachment 192479 [details] [diff] [review]
change "Sanitize" to "Clear Private Data" in UI (updated)

Changed the JS as required.
Attachment #192467 - Attachment is obsolete: true
Attachment #192479 - Flags: review?(mconnor)
Attachment #192467 - Flags: review?(mconnor) → review-
Comment on attachment 192479 [details] [diff] [review]
change "Sanitize" to "Clear Private Data" in UI (updated)

fix the no newline bit and get this in!
Attachment #192479 - Flags: review?(mconnor)
Attachment #192479 - Flags: review+
Attachment #192479 - Flags: approval1.8b4+

Updated

13 years ago
Assignee: mconnor → mike

Updated

13 years ago
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Summary: Rename "Sanitize" feature to "Clear Private Data" or "Clear Personal Data" → Rename "Sanitize" feature to "Clear Private Data"

Comment 38

13 years ago
You missed: sanitizeSettings.accesskey

Comment 39

13 years ago
(In reply to comment #38)
> You missed: sanitizeSettings.accesskey

Can we not use "Se_t_tings" instead (_t_ is available) of "Settings (Z)..." for
the accesskey?  It looks bad using "(Z)"...

~B

Comment 40

13 years ago
Beltzner: this is *exactly* why I mentioned the l10n key-change policy to you
yesterday about changing string keys when you change the string meanings: most
localizations are still going to have "sanitizeWithPromptLabel=Sanitize %S..."
in their locale, and it's likely that some locales aren't going to notice the
change because their tinderbox didn't go orange.
(In reply to comment #40)
> Beltzner: this is *exactly* why I mentioned the l10n key-change policy to you

Oops. Sorry about that. I plead newness, and promise not to make the same
mistake twice. In the meantime, what's the best way to fix this up?
Target Milestone: --- → Firefox1.1

Comment 42

13 years ago
(In reply to comment #41)
> (In reply to comment #40)
> > Beltzner: this is *exactly* why I mentioned the l10n key-change policy to you
> 
> Oops. Sorry about that. I plead newness, and promise not to make the same
> mistake twice. In the meantime, what's the best way to fix this up?

As agreed with mconnor in IRC, attachment #192559 [details] [diff] [review] for bug #284086 fixes the
sanitizeSettings.accesskey mismatch *and* the abusive trailing "..." in
sanitizeCmd.label. I'm still using the sanitizeWithPromptLabel bundle key in
browser.js, though, so I guess it's a good idea CCing bs on that bug too to know
if it needs to be changed.
You need to log in before you can comment on or make changes to this bug.