Caret (cursor) disappears, lags, does not always respond to space bar press at end of word

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
--
major
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: Joe, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2011-06-01 WFM])

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

In Email compose when typing - cursor periodically disappears, lags or when
pressing the space bar at the end of a word the cursor doesn't always move even
though the space key press registered.  Pressing the space bar again results in
2 spaces!  This only happens in Thunderbird - keyboard responses and cursor
movement are normal in all other PC applications.

Reproducible: Always

Steps to Reproduce:
1. Type a new Email.
2. Reply to an Email - seems more severe when replying
3. Forward an EMail

Actual Results:  
Cursor periodically disappeared, lags or when pressing the space bar at the end
of a word the cursor doesn't always move even though the space key press registered.

Expected Results:  
Responded promptly to every keystroke, cursor shouldn't randomly disappear.

Default Theme installed - 2.0
Only 1 Extension installed - Delete Junk Context Menu 0.3.2

XP Pro - SP2
Browser - Firefox 1.0.3
Mail Client - Thunderbird  1.0.2
Dell 8100 Desktop P4 1.5 GHz
256 Mb Ram
Keyboard - Microsoft Natural Multimedia
Mouse - Microsoft IntelliMouse Explorer 4.0
ZoneAlarm - Free edition v. 5.5.094.000
AVG Free edition v. 7.1.307
(Reporter)

Comment 1

13 years ago
I love Firefox and Thunderbird but this problem is so severe with Thunderbird
that I'm at the point where I may go back (reluctantly) to Outlook Express.  I
spend more time looking for the disappearing cursor or correcting the unintended
double spacing after the cursor disappears or freezes at the end of a word that
it is now affecting my productivity when composing an Email.  This problem
occurs on either a new Email, a Reply or a Forward.

Please help.  I can't believe no one else has reported this problem.  Thank you   

Comment 2

13 years ago
have you tried a trunk thunderbird build? I think I remember seeing reports of
issues like this, but I don't know if they've been fixed in trunk builds or not.
I don't see this problem myself.

Comment 3

13 years ago
Behavior confirmed for version 1.0+ (20050517).



(Reporter)

Comment 4

13 years ago
I still haven't gone back to OE because Thunderbird is so feature rich and great
to use.

I did download Thunderbird again (1.0.2) and reinstalled it over itself and the
problem temporarily disappeared for a few days!  But it's back but not happening
as frequently but it still happens in every Email I compose.

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

13 years ago
I reluctantly backed out of Thunderbird because of additional problems that
cropped up (or bacame hard to live with), namely;

1. The cursor frequently froze (won't move beyond a certain point) when pressing
either the right or left arrow keys.
  
2. Pressing the up or down arrow keys to move to the line above or below often
repositioned the cursor at the top or bottom of the message, instead of the
adjacent line.
 
3. I have yet to understand the extra CTRL-L keystrokes to create a link that
was placed in a message from the "Send Link" in Firebird.
 
4. The spell checker is completely inadequate.
 
5. Forwarding anything with attachments that has already been forwarded several
times is way to complicated if one wants to remove some of the attachments
and/or some of the mail headers.  Too much work!

6. For reasons unknown, Thunderbird unexpectedly renamed several mail folder
names with 8 character number/letter patterns.  Bug report submitted - no response.
 
7. For reasons unknown, numerous mail messages were duplicated but the text was
blank.
 
8. Message font sizes displayed are inconsistent from one Email preview to the
next - not consistent throughout like OE
 
The above was really minor stuff compared to the nightmare of backing out of
Thunderbird. Mozilla provides no methed to easily export Thunderbird's mail
folders into Outlook or Outlook Express.  This was a major disappointment.

To go back to Outlook and OE requires finding and copying the correct mail files
(often several folders deep), renaming them all, installing Eudora Lite, copying
the renamed files into Eudora, starting Eudora, opening the copied mail folders,
closing Eudora, starting OE and importing from Eudora Lite.  Not fun. The
process is slightly different for Outlook.  Nevertheless, expect to spend an
evening or more completing this process, and expect to get only about 80% of
your mail back, some which will be unreadable.

Comment 6

12 years ago
I'm using Thunderbird Trunk and I noticed severe cursor problems starting in the last 2 days.

The cursor is frequently misaligned and can appear in multiple locations.

Comment 7

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060513 Thunderbird/2.0a1 ID:2006051323

I can confirm that the cursor disappears in approximately 2/5 emails I write and cannot be recovered. I have, however, not been able to discern any pattern to the problem. I update my 2.0a1 Branch (zip) on Saturdays, and began to notice this 2-3 weeks ago. 

Sorry I can't be any more helpful, but as I've said, I can't see anything or any pattern that seems to trigger the disappearance. It is, though, extremely annoying.
(Reporter)

Comment 8

12 years ago
As far as I know, this bug and the related bugs I reported about a year ago have never been fixed.  It's a shame because Thunderbird has a lot of great features and the price (free) is right.

Backing out of Thunderbird (back to OE) is also nightmare one does not want to do twice.  You would hope Mozilla would have provided a program to do this.

So after not hearing anything, and needing a more powerful Email client, I moved to Outlook 2003.  It is packed with more features than I will ever use (I'm a home user, retired, but do some consulting from time to time).  No, it is not free, comes with Office 2003, but if you are into serious Email, want something that works all the time and every time, provides powerful backup and archiving capabilities, has the best spell checker of any Email client, is customizable at every level, handles Spam and junk Email with ease, does everything Thunderbird does and more, then you need to consider Outlook or other non-free robust Email clients.

Comment 9

12 years ago
Also seen in Thunderbird 1.5.0.4 on Mac OS X 10.4.6. An additional symptom is that spell checker underlines will also be off by one character.

Comment 10

11 years ago
Just to check: was this bug originally reported for HTML composition, or for plain text?
Summary: Cursor disappears, lags, does not always respond to space bar press at end of word → Caret (cursor) disappears, lags, does not always respond to space bar press at end of word

Comment 11

11 years ago
I do not know what was the original cause, but this certainly still happens with plain text in TB 1.5 and its subsequent releases.

I will monitor this for TB 3 Alpha 1

Comment 12

11 years ago
I don't know about the original complaint, but in my case it has to do with html mails. 

I can add - after several months of still having the problem- that it only happens in mails that I'm writing after having used the "Reply" function AND when I try to modify text that appears when using the "quote original message" function.

I have TBird set so that it doesn't automatically quote the message when I hit "Reply". 

By the way, this is a REALLY disturbing bug and I never had it in the 8 years or so I used Netscape mail. It doesn't happen on any other program, and as I've said, it only happens when I'm "replying". 

If somebody could fix this, I'd be a very happy TBirder.

Comment 13

11 years ago
I want to remove the last part of the sentence. It should only say: "I can add - after several months of still having the problem- that it only happens in mails that I'm writing after having used the 'Reply' function". 

Comment 14

11 years ago
One more thing: I'm using a Logitech trackball with the "Windows inverted" (extra large) cursor. I wonder if using a non-standard cursor has something to do with it.

It might be good if people who are experiencing the problem identify their pointing devices and the cursor being used.

The problem is also alluded to in this posting:
http://forums.mozillazine.org/viewtopic.php?p=2595798#2595798

A few weeks ago, the cursor returned - as some other people have mentioned - when the user switched to another window. Now nothing I do gets the cursor back. In fact even opening a new "Write" window doesn't do anything. 
(Reporter)

Comment 15

11 years ago
Interesting - I started this thread (reported this problem) a year and a half ago.  In my initial report I specified the hardware (mouse & keyboard) being used.  Anyway, 18 months later and it still isn't fixed.  Tbird is a good product but unfortunately it is still in the minor leagues.  I hate to give Gates more $$ but if you are serious about Email and want industrial strength that works all the time then consider Outlook 2003.  Yes, it is bloat-ware but it works every time.  I never looked back and seeing how long this Tbird cursor problem has been around, I'm glad I didn't wait for a fix.  It is hard to believe they haven't figured this one out yet.

Comment 16

11 years ago
(In reply to comment #15)
> Interesting - I started this thread (reported this problem) a year and a half
> ago.  In my initial report I specified the hardware (mouse & keyboard) being used.  Anyway, 18 months later and it still isn't fixed. 

I guess the problem is that too few people are experiencing the problem (or reporting it) and that too few people are working on TBird in general.

Comment 17

11 years ago
I get the immovable cursor in plain text and it is always reproducible with either new or reply.  It happens at the end of a line when I add enough spaces to bump up against the line wrap character count.  When there are already mailnews.wraplength characters in the line and the next keystroke is a space, it doesn't show.  If there are mailnews.wraplength-1 characters and the next 2 chars are space, the first is displayed and the 2nd is displayed as a backspace.  Your mileage may vary.  Version: Thuderbird 1.5.0.7  OS: Linux

Comment 18

11 years ago
(In reply to comment #17)
> I get the immovable cursor in plain text and it is always reproducible with
> either new or reply.  It happens at the end of a line when I add enough
> spaces to bump up against the line wrap character count.  When there are
> already mailnews.wraplength characters in the line and the next keystroke is
> a space, it doesn't show.  If there are mailnews.wraplength-1 characters and
> the next 2 chars are space, the first is displayed and the 2nd is displayed
> as a backspace.  Your mileage may vary.

That's bug 87314.

Comment 19

11 years ago
I've solved my problem with this one: I disabled the Bi-Di Mail UI extension (version 0.7.2). 

Comment 20

11 years ago
can anyone reproduce this if the spellchecker is off?
c.f. bug 216830 where I asked the same question.
QA Contact: message-compose

Comment 21

10 years ago
I hadn't had any problems with this bug for awhile, but - all of a sudden - I got two emails from someone named Wayne Mery (vseerror@Lehigh.EDU) asking about. 

Sure enough, the bug was back! I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.7pre) Gecko/20070911 Thunderbird/2.0.0.7pre ID:2007091103.

I mentioned awhile ago (post of 2006-12-08) that (I though) I had fo0und the source of the problem and got rid of it by disabling Bi-Di Mail UI. It's still disabled, but the bug is back. 

If anyone would like to see the exact sequence of how it happens, I've made a little film:
http://www2.tu-berlin.de/zems/greenman/no_cursor.flv

I hope this helps.

Comment 22

10 years ago
Ummm, I meant "... asking about it." in my first sentence of the last post.

Also, maybe I should list my extensions (or are they add-ons?). By the way, none of these has been added recently so that it might have re-caused the problem. 

abcTajpu 1.5
addressContext 0.8.1
BiDi Mail UI 0.7.4 [DISABLED]
Clippings 2.6
ConfigDate 0.3.9
Contacts Add BCC button 0.0.3
Deutsches Wörterbuch 1.0.1
Empty Trash 1.3.11
FlatStyle for Thunderbird 0.9.2.3
HiddenPrefs 0.2.2
MoreColsForAddressBook 0.2.6
MR Tech Local Install 5.3.2.5
Nightly Tester Tools 1.3b3
No New Window on Double Click 0.2.3
Quick Locale Switcher 1.6.3.4
QuickZoom 1.0.5
SmoothWheel 0.44.9.20061102
United States English Dictionary 2.0.0.6

Comment 23

10 years ago
Bug still present in TB version 2.0.0.6 (20070728) (French version)

Only one Add-on : Talkback 2.0.0.6
Default TB Theme

Comment 24

10 years ago
Hmmm, could this somehow be a problem restricted to people using non-English keyboards? 

I'm using German, I guess Raanan is using French ... and there have been some other TBird problems caused by non-English keyboards.

Comments please? 

Comment 25

10 years ago
(In reply to comment #24)
> Hmmm, could this somehow be a problem restricted to people using non-English
> keyboards? 
> 
> I'm using German, I guess Raanan is using French ... and there have been some
> other TBird problems caused by non-English keyboards.
> 
> Comments please? 
> 

I confirm using a French keyboard.

Comment 26

10 years ago
I put this message in but 359913 because it is the same bug. Very severe:
I just installed version 2.0.0.6 and the spacebar bug is still very real - and fully unworkable. Because I watch the type window while I'm typing (not my fingers), I have a tendency to backspace to try and take away the extra space I put in there when the spacebar does not appear to work. That's when things really get screwy. When back spacing over misspellings, or apparent extra spaces, it appears as though the text is writing over other text (so two letters will appear to be on top of each other). Trying to highlight and delete the apparent error only makes it worse. Eventually I have to delete the email and start over. This is my first day using Thunderbird and I'm going to to abandon it now. Too bad because the other functionality of this app. is just lovely.

Comment 27

10 years ago
Since no one seems to be following up on this, I've removed the little film I made (mentioned in comment #21) from my server.

Comment 28

10 years ago
I had hopes this bug would be fixed with 2.0.0.12 but it did not for me. I wanted to add my name to the list having this problem!

Comment 29

10 years ago
Reproducing the problem:
I believe the problem is to do with dual monitors  (not in mirror mode). Can the users that have reported the bug please confirm? On my machines (I've tried many MacOSX computers with different versions of mozilla and OSX) the problem arises only when I start mozilla or thunderbird  with two monitors and the desktop spanning both screens. Actually it even occurs in text input boxes in firefox (so a gecko thing I guess). The workaround is to switch to mirror mode of the screens when you start thunderbird/mozilla/firefox.

The bug has cropped up a number of times in bugzilla. I imagine the reason that the bug keeps failing to make 'confirmed' status is that the developers aren't using a dual (extended) display, and users don't think of this as part of the necessary behaviour to "reproduce" the bug.

other bugs with similar reported errors:
295852 
292580?
318150 
249849
262078

Comment 30

10 years ago
Jon Pierce's observation appears to be right on the money, at least in my case. 

I have three monitors connected to two graphics cards. My main display is an NEC 2180UX connected to a Matrox Parhelia 128. The other two are Samsung 172Ws, and they're connected to a Matrox G200MMS. 

I used to have two monitors connected to the Parhelia (I had different Matrox G200 as my second card then), and at that time, I seem to remember that the problem occurred even more frequently. It's relatively rare now, but it still happens. 

Now I'll keep an eye out to see if it only happens when one (or both) or the secondary monitors is / are on.

I was a bit confused by John's "mirror mode" comment, but a bit of research revealed it's only related to Macs.

I think there's a steadily growing number of people opting for dual-monitor solutions, so it's something the devs might want to investigate further. 

Thanks to everyone who's still working on this very annoying little problem.

Joe

Comment 31

10 years ago
I have single-monitor Win XP system and the problem is present there too.

Comment 32

10 years ago
@ Raanan - Are you still using your French keyboard / system? 

I observed earlier that a non-English system component might have something to do with it. 

@John Pierce  - I see you're in the UK as assume you're using a UK English system. Even though it's not very different from US English, maybe the UK settings (time / currency / whatever) are enough to set it off. 

And the fact that you're using a Mac adds yet another "magical mystery" component ;-)

Interestingly enough, I just went to reply to an email (with only my main monitor on), and there was no cursor. I re-started TBird and it came back and worked fine. Weird. 

Comment 33

10 years ago
@ Joe - Yes, I am still using a French keyboard & system.

It is very difficult to have any certainty here: at this point I am not sure the error crops up under Vista, but I will try to be attentive to the possibility. I am sure it came up under XP SP2.

Updated

9 years ago
Assignee: mscott → nobody

Comment 34

9 years ago
do you see this if you use beta 1? 
  http://www.mozillamessaging.com/en-US/thunderbird/early_releases/


is bug 450567 a dupe?


(In reply to comment #29)
> Reproducing the problem:
> I believe the problem is to do with dual monitors  (not in mirror mode). Can
> the users that have reported the bug please confirm? On my machines (I've tried
> many MacOSX computers with different versions of mozilla and OSX) the problem
> arises only when I start mozilla or thunderbird  with two monitors and the
> desktop spanning both screens. Actually it even occurs in text input boxes in
> firefox (so a gecko thing I guess). The workaround is to switch to mirror mode
> of the screens when you start thunderbird/mozilla/firefox.
> ...
> other bugs with similar reported errors:
> bug 295852 
> bug 292580?
> bug 318150 
> bug 249849
> bug 262078
Blocks: 359913

Comment 35

9 years ago
In regard to my Comment #21, nobody ever commented on the film I made, so I've taken it down.

I can confirm bug 450567, but it bears no similarity to the bug in question here.

Comment 36

9 years ago
@ Wayne Mery

It's interesting that you're still (back) onto this after such a long time. I can't quite understand, though, your relating bug 450567 to the one I've been trying to bring to the fore for so long now. (Pls. see my Comment #21.)

I don't know why I've never filed a separate bug. The point would be to focus attention on the fact that the undesired behavior I'm concerned with is ALWAYS and ONLY related to emails being composed after having used the "Reply" button and then modifying the text of the original mail that's been inserted in my reply using the "Quote" function. 

All I can say is that I'm quite sure this problem has never been solved, but I can also say that it doesn't happen regularly. Though I've been observing it literally for years, I can't begin to see any pattern to it other than what I've described here. 

I've basically written it off as an anomaly.

Comment 37

9 years ago
My last comment for tonight: The fact that this topic was initiated 2005-05-01 and still bears the Status "New" is a sad comment on the state of things. 

I don't know what it takes to catch the devs' attention, but I think I can say without fear of contradiction that this particular bug ain't managed to do it. :-(

Comment 38

9 years ago
well, according to a coder's comment in bug 450567, it seems quite possible this is fixed in the beta. Hence my comment 34 requesting someone try the beta. The feedback will be helpful.

Updated

8 years ago
Duplicate of this bug: 413688

Comment 40

7 years ago
has this issue stopped for you?
Keywords: perf
Whiteboard: [closeme 2011-06-01 WFM]

Comment 41

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.25pre) Gecko/20100629 Thunderbird/2.0.0.25pre ID:2010062904

I'm still

Comment 42

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.25pre) Gecko/20100629 Thunderbird/2.0.0.25pre ID:2010062904

I'm still v2 - and no, it hasn't, but I've found a pretty fast workaround.

Comment 43

7 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.25pre) Gecko/20100629 Thunderbird/2.0.0.25pre ID:2010062904

I'm still v2 - and no, it hasn't, but I've found a pretty fast workaround.
(In reply to comment #43)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.25pre)
> Gecko/20100629 Thunderbird/2.0.0.25pre ID:2010062904
> 
> I'm still v2 - and no, it hasn't, but I've found a pretty fast workaround.

That version of Thunderbird is no longer supported. It was obsoleted about a year ago when those updates stopped, and you are no longer getting security and stability updates.

Therefore I'm resolving this as works for me as we've had no confirmations of this on the latest Thunderbird versions, just on 2.x or earlier, and hence I think it is most likely fixed there.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 45

7 years ago
Fine.

Comment 46

6 years ago
Hi - it seems that this bug has appeared again, using the latest 7.0 beta, WinXP.  I've never had it before in TB (but I did have it very occasionally in FF HTML text areas eg. FCKeditor at one stage).  Started happening as soon as I updated to 7.0 beta.  Can anyone else confirm?

Current active add-ons (everything else is disabled for compatibility):
British English Dictionary 1.19.1
keyconfig 20110522
Mail Merge 2.4.1

Comment 47

6 years ago
TB 6.0 and XP.   At random the typed text doesn't appear (the screen hangs).  Saving the edit so far corrects it to continue as normal
You need to log in before you can comment on or make changes to this bug.