Closed Bug 293740 Opened 17 years ago Closed 17 years ago

XHTML/CSS pop-up becomes transparent when user choose "Always use my colors"

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 255411

People

(Reporter: ginnchen+exoracle, Unassigned)

References

()

Details

(Keywords: access)

Attachments

(1 file)

3.24 KB, application/xhtml+xml
Details
Choose "Always use my colors" in Firefox options.
Try http://www.canyonjam.net/samples.html, scroll to "Pure XHTML/CSS pop-up
(drop-down?) menus".
You'll find the pop-up is transparent, and overlaps text behind.
It works fine with IE.
LXR blame page is another testcase.
If I change some code in PrefShell::SetPropColorRules, this bug can disappear.
For example, add "*|div {background:#RRGGBB !important;}" before "*
{background:transparent !important;}"
But it may cause regressions, when web author intents to use transparent
background color.

David, what's your opinion?
Keywords: access
Note that the preference is browser.display.use_document_colors. 'True' equates
to "Allow pages to choose their own colours, instead of my selections above."

The problem here is that when browser.display.use_document_colors == false, the
background-color of a lot of elements becomes transparent, and not the color
specified in Edit -> Preferences -> Content -> Fonts & Colours -> Colours... ->
Text and Background -> Background:.

Attaching testcase shortly.
Attached file Testcase.
Testcase. No red, and no '1's should be seen, regardless of the
browser.display.use_document_colors preference. Background-color should equal
browser.display.background_color and not be transparent.
cc: bzbarsky

A possible solution is adding a rule to use user selected bgcolor instead of document's bgcolor if 
document's bgcolor is not transparent.

It could be done in nsRuleNode.cpp. But I don't think it's a good idea, and I don't know how to seperate 
HTML and XUL there.

From W3C Web Accessibility Initative Browser User Interface Guidelines (http://www.w3.org/WAI/UA/
wai-browser-gl)
"The user needs to be able to turn off HTML author defined colors and fonts and have the ability to 
specify their own foreground and background colors, and font characteristics."
> and I don't know how to seperate HTML and XUL there.

You can't.  But why do you need to, exactly?

Note that we have bug 247805, bug 255411, bug 160099, and bug 205892 all
covering this issue already.  Pick the one with the most information and dup the
rest (including this one) to it, please?

*** This bug has been marked as a duplicate of 255411 ***
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.