ability to limit bandwidth/speed to the download manager

VERIFIED WONTFIX

Status

()

Toolkit
Downloads API
--
enhancement
VERIFIED WONTFIX
13 years ago
3 years ago

People

(Reporter: Roland Käser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

I would like to request for the feature that the bandwith usage for a download
or all downloads can be limited while the download is running.

Reproducible: Always
this is something for an extension and definitly not what everyone would use
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
*** Bug 312974 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
*** Bug 334949 has been marked as a duplicate of this bug. ***

Comment 4

12 years ago
(In reply to comment #1)
> this is something for an extension and definitly not what everyone would use
> 
Imagine you are the admin of a company. You have to download a servicepack or a linux distribution NOW and not during the night. When you start your download it uses nearly all the bandwidth of the internet acces and the rest of the company is calling all the time, why the internet is so slow. If you could set up in Firefox-Downloadmanager, that only a limited bandwidth for that download will be used, you are out of troubles!.
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> (In reply to comment #1)
> > this is something for an extension and definitly not what everyone would use
> > 
> Imagine you are the admin of a company. You have to download a servicepack or a
> linux distribution NOW and not during the night. When you start your download
> it uses nearly all the bandwidth of the internet acces and the rest of the
> company is calling all the time, why the internet is so slow. If you could set
> up in Firefox-Downloadmanager, that only a limited bandwidth for that download
> will be used, you are out of troubles!.
> 
Thats exactly what I meant as I wrote this feature enhancement. Thanks Thomas for this good explanation, I couldn't describe it better.

When will it be done in the firefox release? 
(For the developpers, take a look at the wget sources, there is a routine to limit the bandwith wile downloading files. It may can be used for firefox to.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
*** Bug 336135 has been marked as a duplicate of this bug. ***
OS: Other → All
Hardware: PC → All
Summary: Limit Bandwidth per right mouse click on the download manager → ability to limit bandwidth to the download manager
Duplicate of this bug: 371623
Summary: ability to limit bandwidth to the download manager → ability to limit bandwidth/speed to the download manager
Depends on: 101711
Confirming as feature request based on the dupes and votes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I'm sorry, but I don't see us wanting this.  A more useful thing might be to limit the application itself.
Status: NEW → RESOLVED
Last Resolved: 13 years ago10 years ago
Resolution: --- → WONTFIX

Comment 10

10 years ago
(In reply to comment #9)
Is this more useful thing present in your bugtracker?
not that I am aware of

Updated

10 years ago
Duplicate of this bug: 437572
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit

Comment 13

9 years ago
I wish this feature was available. I download multiple large downloads most of the time from various websites. I would like to limit the download speed of individual downloads in the download manager. 

This will be a great add-on for firefox. I realize that this will not be used by every user, but how about providing an extension or a plugin that can do this?

Updated

8 years ago
Duplicate of this bug: 101711

Comment 15

8 years ago
v. Wontfix from a component peer
Status: RESOLVED → VERIFIED
Could someone explain the WONTFIX a bit better. Thanks.

Comment 17

8 years ago
Shawn said in comment 9 that a fix that was scoped to only the download manager is wontfix. Generalized core:networking code is wontfix'ed in bug 193532.
Duplicate of this bug: 550653

Comment 19

7 years ago
Bug 101711 had 17 votes... so this is actually a relatively highly requested feature. Not that votes mean anything.

Comment 20

3 years ago
More than this feature, I would much more prefer to have ability to limit bandwidth to specific websites.  Such as Netflix, Crackle, Hulu, and other bandwidth intense services.  The reason is that I have determined that some computers get overwhelmed when very high speed bandwidth is available to them, thus high rate of traffic flow and memory and CPU usage caused by the browser, and when the same computer accesses the media service on a slower bandwidth connection, no failure or crash or problems with the browser.  Reason is that the rate of data flow gets limited.  The slower speed still provide great viewing and media experience.  The faster speed causes too high resource usage, and creates problems.  I've submitted this as a request to Mozilla's Firefox Feedback/Suggestions.  Titled it as "Want Firefox feature of Bandwidth Throttle/Limit Per Site or IPA or URL" and that is different from limiting/throttling bandwidth on all of Firefox or for just downloads/uploads.
You need to log in before you can comment on or make changes to this bug.