Closed Bug 301945 Opened 14 years ago Closed 13 years ago

Account Wizard won't offer to create new RSS or Movemail accounts

Categories

(Thunderbird :: Build Config, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird2.0

People

(Reporter: wsheets, Assigned: ispiked)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file, 4 obsolete files)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050724 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b4) Gecko/20050724 Firefox/1.0+

Thunderbird(HEAD/20050724): this bug shows only when I run the program from
it's *installed* location (/usr/local/bin/thunderbird).  When I run it as
obj/dist/bin/thunderbird, then the Account Wizard offers all four types of
new accounts -- weird!

Reproducible: Always

Steps to Reproduce:
1.Compile and install with 'make -f client.mk install'
2.Run TB from /usr/local/bin/thunderbird
3.Try adding an RSS account from the Account Wizard -- you can't.
4.Run TB from obj/dist/bin/thunderbird -- and it works normally.
Actual Results:  
Account Wizard offers only 'Newsgroups' and 'Email' accounts.  RSS and
Movemail accounts are not mentioned.

Expected Results:  
Account Wizard should offer all types of accounts.

My gut feeling is that the 'make install' target is broken for the Account
Wizard -- but I don't know which Makefiles are involved.
I noticed the same issue. The issue seems to be that defaults/isp is not
properly installed.
I believe there should be an 'install' target added to
mail/extensions/newsblog/Makefile.in
Attached patch Fixes the RSS omission (obsolete) — Splinter Review
This fixes the RSS omission.
I don't understand why the same files are installed in both the 'isp'
directory and in the 'isp/US' directory.

If this is really necessary then a second line needs to be added to the
'install' targets to add the isp/US subdirectory.
Comment on attachment 191070 [details] [diff] [review]
And this fixes the movemail omission.

Why would you $(addprefix $(srcdir)/, movemail.rdf)? 

Just use $(srcdir)/movemail.rdf.

And please attach patches with more context (8 or 12 is generall what I
prefer).
Attachment #191070 - Flags: review-
Comment on attachment 191068 [details] [diff] [review]
Fixes the RSS omission

again, only use $(addprefix) when you have a list of items instead of a single
item.
Attachment #191068 - Flags: review-
Assignee: mscott → wsheets
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking1.8b5+
(In reply to comment #6)
> again, only use $(addprefix) when you have a list of items instead of a single
> item.

I copied it from a similar Makefile with two items -- in fact I'm still wondering
if a second copy should be placed in the l10n subdirectory.  I don't understand
why it is necessary.  (Is it?)
this bug is in danger of being cut from the blocker list.
Minusing for now. Will consider a safe patch but not a blocker.

In the linux builds we make, folks have seen the option for creating rss
accounts and what not, so it's working in our release builds. 
Flags: blocking1.8b5+ → blocking1.8b5-
Attachment #197674 - Flags: review?
Attached patch and the movemail submission. (obsolete) — Splinter Review
Attachment #197675 - Flags: review?
The release builds have the appropiate files, so they should work allright, this
should only be a problem for those who build from source.
*** Bug 328512 has been marked as a duplicate of this bug. ***
Attached patch patchSplinter Review
This is a first stab at getting this fixed. This is heavily borrowed from mailnews/base/ispdata/Makefile.in.
Attachment #191068 - Attachment is obsolete: true
Attachment #191070 - Attachment is obsolete: true
Attachment #197674 - Attachment is obsolete: true
Attachment #197675 - Attachment is obsolete: true
Attachment #230828 - Flags: review?(benjamin)
Attachment #197674 - Flags: review?
Attachment #197675 - Flags: review?
Note that the movemail issue was covered in bug 281084.
Assignee: wsheets → mscott
Severity: major → normal
Component: Account Manager → Build Config
QA Contact: build
Version: unspecified → Trunk
Attachment #230828 - Flags: superreview?(mscott)
Attachment #230828 - Flags: review?(benjamin)
Attachment #230828 - Flags: review+
Comment on attachment 230828 [details] [diff] [review]
patch

nice work adam!
Attachment #230828 - Flags: superreview?(mscott) → superreview+
Whiteboard: [checkin needed]
Assignee: mscott → ispiked
mozilla/mail/extensions/newsblog/Makefile.in 	1.8
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Thunderbird 3
Attachment #230828 - Flags: approval-thunderbird2?
Attachment #230828 - Flags: approval-thunderbird2? → approval-thunderbird2+
Whiteboard: [checkin needed (1.8 branch)]
Target Milestone: Thunderbird 3 → Thunderbird2.0
Depends on: 352168
Checked in, with the bustage fix from bug 352168.
mozilla/mail/extensions/newsblog/Makefile.in 	1.7.4.1
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
You need to log in before you can comment on or make changes to this bug.