Bfcache does not work anymore

VERIFIED FIXED in mozilla1.8beta4

Status

()

Core
Document Navigation
P1
major
VERIFIED FIXED
13 years ago
9 years ago

People

(Reporter: Ria Klaassen (not reading all bugmail), Assigned: Biesinger)

Tracking

({regression})

Trunk
mozilla1.8beta4
regression
Points:
---
Bug Flags:
blocking1.8b5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050809 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050809 Firefox/1.0+

When I click Back Firefox does no go to the previous page.
In order to go back I need to click Go after Back. Then it loads the page twice.
Also setting browser.sessionhistory.max_viewers to 0 works.

Reproducible: Always

Steps to Reproduce:
1. Click a link on a page.
2. Click Back


Actual Results:  
Firefox shows a white page, although the right URL appears in the location bar.

Expected Results:  
Grab the page from the cache and show it.
(Reporter)

Comment 1

13 years ago
Regression between 2005080808 and 2005080822.

Updated

13 years ago
Keywords: regression

Comment 2

13 years ago
*** Bug 304011 has been marked as a duplicate of this bug. ***
Assignee: nobody → bryner
Blocks: 274784
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → mozilla1.8beta4
Flags: blocking1.8b4?
bonsai query for that regression range:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2005-08-08+07%3A00&maxdate=2005-08-08+23%3A00&cvsroot=%2Fcvsroot

Comment 4

13 years ago
In the latest hourly builds, when press the back button, the page don't load,
and press the stop button and firefox crash, everytime

This behaviour since 2005080822 'till now (2005080903) is very anonying.

Somebody happens?
Would the "smoketest" keyword be applicable here? If bfcache is enabled by
default (?), this would appear to hinder smoketest item #B.14.
http://www.mozilla.org/quality/smoketests/
restoring presentation from session history: http://www.mozilla.org/start/
++DOMWINDOW == 9
WARNING: NS_ENSURE_TRUE(holder) failed, file
../../../../../mozilla/dom/src/base/nsGlobalWindow.cpp, line 6638
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file
../../../../mozilla/docshell/base/nsDocShell.cpp, line 5287
###!!! ASSERTION: RestoreFromHistory failed: 'NS_SUCCEEDED(rv)', file
../../../../mozilla/docshell/base/nsDocShell.cpp, line 4935
Break: at file ../../../../mozilla/docshell/base/nsDocShell.cpp, line 4935
###!!! ASSERTION: RestoreFromHistory failed: 'NS_SUCCEEDED(rv)', file
../../../../mozilla/docshell/base/nsDocShell.cpp, line 4935
Break: at file ../../../../mozilla/docshell/base/nsDocShell.cpp, line 4935
nsGlobalWindow.cpp, in nsGlobalWindow::RestoreWindowState
   6637   nsCOMPtr<WindowStateHolder> holder = do_QueryInterface(aState);
   6638   NS_ENSURE_TRUE(holder, NS_ERROR_FAILURE);


nsDocShell.cpp
   5286     rv = privWin->RestoreWindowState(windowState);
   5287     NS_ENSURE_SUCCESS(rv, rv);
caused by bug 298459?
there's also this warning while saving the state:
WARNING: NS_ENSURE_TRUE(rv) failed, file
../../../../../mozilla/dom/src/base/nsGlobalWindow.cpp, line 6610

at:
   6606 #ifdef DEBUG_PAGE_CACHE
   6607   printf("saving window state, stateObj = %p\n", (void*)stateObj);
   6608 #endif
   6609   nsresult rv = CopyJSProperties(cx, mJSObject, stateObj);
   6610   NS_ENSURE_TRUE(rv, rv);
   6610   NS_ENSURE_TRUE(rv, rv);

should be SUCCESS, not TRUE
Assignee: bryner → cbiesinger
Priority: -- → P1
Created attachment 192098 [details] [diff] [review]
patch
Attachment #192098 - Flags: superreview?(bryner)
Attachment #192098 - Flags: review?(bryner)
Status: NEW → ASSIGNED
*** Bug 304057 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
Comment on attachment 192098 [details] [diff] [review]
patch

Can we get this reviewed an in?
Attachment #192098 - Flags: superreview?(bryner) → superreview+
Attachment #192098 - Flags: review?(bryner) → review+

Updated

13 years ago
Flags: blocking1.8b4? → blocking1.8b4+

Updated

13 years ago
Attachment #192098 - Flags: approval1.8b4?

Comment 14

13 years ago
Comment on attachment 192098 [details] [diff] [review]
patch

a=chase@mozilla.org
Attachment #192098 - Flags: approval1.8b4? → approval1.8b4+

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
for reference:
2005-08-09 14:29	timeless%mozdev.org 	mozilla/ dom/ src/ base/
nsGlobalWindow.cpp 	1.759 	2/2  	Bug 304003 Bfcache does not work anymore patch
by biesi r=bryner sr=smfr a=chase

Comment 16

13 years ago
*** Bug 304090 has been marked as a duplicate of this bug. ***

Comment 17

13 years ago
*** Bug 304086 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
*** Bug 304108 has been marked as a duplicate of this bug. ***
*** Bug 304116 has been marked as a duplicate of this bug. ***
*** Bug 304134 has been marked as a duplicate of this bug. ***
Verified with Linux and Windows builds from 2005-08-10
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.