Allow Dynamic dictionary switching from the compose window

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({fixed1.8})

Trunk
Thunderbird1.1
x86
Windows XP
fixed1.8
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Add a drop down to the spell check button which will allow you to change
dictionaries on the fly.

Switching the dictionary will cause us to load the new dictionary and if inline
spell check is turned on, re-check text using the new dictionary.

Spun out from Bug #280825
(Assignee)

Comment 1

12 years ago
Created attachment 192993 [details] [diff] [review]
the fix

Dynamically populates a drop down for the spell check button which lists the
current dictionaries. 

I'm tempted to ditch the UI in the preferences window that lets you switch the
language as well.
Attachment #192993 - Flags: superreview?(bienvenu)
(Assignee)

Comment 2

12 years ago
this change really needs the memory leak fix from Bug #305017
Status: NEW → ASSIGNED
Depends on: 305017
Target Milestone: --- → Thunderbird1.1

Updated

12 years ago
Attachment #192993 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 3

12 years ago
fixed on the trunk. I'm going to leave it open for a day to see how it shakes
out before putting on the branch.

Comment 4

12 years ago
*** Bug 300077 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
*** Bug 300896 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
(In reply to comment #3)
> fixed on the trunk. I'm going to leave it open for a day to see how it shakes
> out before putting on the branch.

Actually, I think you checked this in the branch ...
(Assignee)

Comment 7

12 years ago
so I did. It's now on the trunk too.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8
Resolution: --- → FIXED

Comment 8

12 years ago
(In reply to comment #1)
> I'm tempted to ditch the UI in the preferences window that lets you switch the
> language as well. 

That is a good idea (cleans up the pref dialogs). However, users might remove
the "Spell" toolbar button (to save space). Therefore, there should be the
ability to switch the language for the menus:

| Options |
   Spelling Language > English / United States
                       German / Germany
                       --------------------------
                       Download More Dictionaries
Depends on: 306379
(In reply to comment #8)
> That is a good idea (cleans up the pref dialogs). However, users might remove
> the "Spell" toolbar button (to save space). Therefore, there should be the

Speaking of which, did this break message compose when Spell is not on the
toolbar (bug 306379)?
No longer depends on: 306379
Depends on: 306379

Comment 10

11 years ago
*** Bug 352975 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Blocks: 360488

Updated

10 years ago
No longer blocks: 360488
You need to log in before you can comment on or make changes to this bug.