Closed Bug 306453 Opened 17 years ago Closed 17 years ago

Remove "Read Mail" and "New Message..." from Tools menu

Categories

(Firefox :: Menus, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox 2 alpha1

People

(Reporter: beltzner, Assigned: Gavin)

References

Details

(Keywords: fixed1.8.1, useless-UI, Whiteboard: [read COMMENT 39 before commenting])

Attachments

(1 file)

The "Read Mail" and "New Message..." items in the Tools menu add function which
isn't really directly related to web browsing at the cost of additional menu
clutter. I suspect that they won't be missed if removed, and will in fact
simplify the appearance/structure of the Tools menu by doing so.

We should look at getting some feedback on this during beta.
Whiteboard: [beta feedback needed]
Also of note: the unread mail count tends to be incorrect for many Win32 users
due to using the MS provided regkey for unread mail count and the fact that it
isn't managed afaict or if it is it isn't managed well. It is difficult for a
user to understand that the unread mail count is provided by mail apps writing
to this key and they usually blame Firefox for the incorrect count. Two thumbs
up for this change!
If we remove these, we should probably remove "Send Link" as well so that if
someone wants to add email integration as a FFx extension, they've got a nice
clear slate on which to innovate.

If any of those people are reading this bug: think webmail integration! Right
now these functions all have a rather notable lack of support for Yahoo!, Gmail
and Hotmail users ...
My "Read Mail" is screwed up. There is "(1 new)" constantly written next to it
(aswell as having "1 unread mail message" written next to my name on the Windows
XP login page [which is really annoying]) and there is absolutely no messages
whatsoever in my Outlook.
Removing "Send Link..." sounds like an awful idea: the other two have little to
do with a browser and only sort-of work, while it has a great deal to do with
the browser, and works perfectly on any system where mailto: links work
(something that anything doing webmail integration has to handle anyway).
> do with a browser and only sort-of work, while it has a great deal to do with
> the browser, and works perfectly on any system where mailto: links work

So, I'd considered that (which is why "Send Link" doesn't appear in the original
reports) and would gladly entertain debate, but where I ended up was that there
was no reason to have an email only copy-n'-paste accelerator unless there was
significant evidence that the feature was heavily used. I get the impression
that it's the type of thing that looks very handy, but isn't all that often
used, and could easily be restored by an extension for those who really want it.
The advantage to yanking it is, of course, simplification of the context menu.

I'd also note that right now it's a little strange how if you right-click on
whitespace, "Send Link" sends the contents of the location bar; if you
right-click on a link itself, "Send Link" sends the URL of the click target.
"Send This Link..." then, to parallel "Bookmark This Link..."?

No skin off my nose, I'll write my own extension (I use the File menu option all
the time, to send myself links as a substitute for sharing bookmarks between
work and home), but I'm not your target market: they are the people using Send
Link and asking for (and, mostly, not knowing how to ask for) IE's "Send.. Page
by E-mail" because that's how Real People [TM] share a page of funny jokes with
their friends, not just by emailing a link but by emailing the whole bloody
page. I don't really see them tracking down an extension to add back a feature
like Send Link, but I might be wrong.
(In reply to comment #0)
> The "Read Mail" and "New Message..." items in the Tools menu add function which
> isn't really directly related to web browsing at the cost of additional menu
> clutter. I suspect that they won't be missed if removed, and will in fact
> simplify the appearance/structure of the Tools menu by doing so.
> 
> We should look at getting some feedback on this during beta.

I agree. The "read mail" and "new message" options should be left out. If
someone really wants this option, maybe it could be provided as an extension.
The "lightness" of firefox and extension capabilities are the heart and soul of
this browser. IMHO these features should also obey firefox's philosophy.
Also note that there is a "Mail" toolbar button (not added by default) for accessing the same functionality that would need to be removed.
In my experience quite a few users use 'email this page' and 'send this link' features of whichever browser they have (based on the number that I receive).  Few if any of these would be savvy enough to download an extension to replicate this behaviour.  I think 'email this page' is more useful than 'email this link', but both would be worth having.  The 'read mail' and 'new message' links, I agree, should be removed.  I've always wondered why they were there - it seemed pretty arbitrary, like having a 'play music' or 'defrag hard disk' option.

Plus the new mail count is always wrong.
k, for now plz ignore comment 2 and let's keep this bug about removing "Read Mail" and "New Message ..." from the tools menu.
Adding bug 246143 as depends on even though it really doesn't. Just added that as the reference to the comments about the mail count being wrong.  Based on mike beltzner's comment 10 I assume it was agreed upon that this should be removed. I might take this bug on and remove this code in the coming weeks.
Depends on: 246143
Keywords: useless-UI
Target Milestone: --- → Firefox 2
Attached patch patchSplinter Review
Removes "Read Mail" and "New Message..."
Flags: blocking-firefox2+
Attachment #208488 - Flags: ui-review?(beltzner)
Attachment #208488 - Flags: review?(mconnor)
Assignee: beltzner → gavin.sharp
Comment on attachment 208488 [details] [diff] [review]
patch

fwiw, I don't think this is the sort of thing that needs a ui-review, since there's really only one way to remove menu items :)
Attachment #208488 - Flags: ui-review?(beltzner) → ui-review+
Attachment #208488 - Flags: review?(mconnor) → review+
mozilla/browser/locales/en-US/chrome/browser/browser.dtd;        1.32;
mozilla/browser/locales/en-US/chrome/browser/browser.properties; 1.22;
mozilla/browser/themes/pinstripe/browser/browser.css;            1.15;
mozilla/browser/themes/winstripe/browser/browser.css;            1.24;
mozilla/browser/base/content/browser-menubar.inc;                1.69;
mozilla/browser/base/content/browser-sets.inc;                   1.64;
mozilla/browser/base/content/browser.js;                         1.554;
mozilla/browser/base/content/browser.xul;                        1.277;
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Whiteboard: [beta feedback needed]
Target Milestone: Firefox 2 → Firefox 3
Version: 1.5 Branch → Trunk
Attachment #208488 - Flags: approval1.8.1?
Depends on: 323686
The Toolbar.png image files need to be cropped (the mail icon is the last image in the set), but I didn't do that because I wasn't able to find an editor that did it without horribly munging the file. I filed bug 323686 for that, if anybody wants to take that feel free :)
No longer depends on: 246143
Can we get this on the branch as well since it is such low/no risk and helps avoid the problem?
Attachment #208488 - Flags: approval1.8.1? → approval1.8.1+
Mike, in the future when you make changes to UI, would you please file a followup bug to fix the help documentation or CC help.documentation@firefox.bugs on the original bug?  Help docs people can take it from there, but if we don't know about the change (perhaps, say, because none of us happened to skim the relevant checkin logs) we can't easily update docs to reflect it.  Thanks!  :-)
Sorry, Jeff, it was my fault, I should have remembered to file the help bug.
Yeah, but to be fair, I wouldn't have known enough to do it myself, so I'll consider this a lesson learned. Thanks, Jeff!
*** Bug 324304 has been marked as a duplicate of this bug. ***
Why not also remove the shell service functions that support this then to trim back on needless back end code? Can you file a bug on that please?
Depends on: 324361
(In reply to comment #21)
> Why not also remove the shell service functions that support this then to trim
> back on needless back end code? Can you file a bug on that please?

Filed bug 324361 for removing it - on the trunk only.
Landed on the 1.8 branch for Firefox 2 (with bug 323686).

mozilla/browser/locales/en-US/chrome/browser/browser.dtd;        1.25.2.3;
mozilla/browser/locales/en-US/chrome/browser/browser.properties; 1.20.2.2;
mozilla/browser/themes/pinstripe/browser/Toolbar-small.png;      1.4.4.1;
mozilla/browser/themes/pinstripe/browser/Toolbar.png;            1.4.4.1;
mozilla/browser/themes/pinstripe/browser/browser.css;            1.11.4.5;
mozilla/browser/themes/winstripe/browser/Toolbar-small.png;      1.4.18.1;
mozilla/browser/themes/winstripe/browser/Toolbar.png;            1.4.18.1;
mozilla/browser/themes/winstripe/browser/browser.css;            1.17.2.8;
mozilla/browser/base/content/browser-menubar.inc;                1.57.2.10;
mozilla/browser/base/content/browser-sets.inc;                   1.51.2.10;
mozilla/browser/base/content/browser.js;                         1.479.2.48;
mozilla/browser/base/content/browser.xul;                        1.268.2.9;
Keywords: fixed1.8
Target Milestone: Firefox 3 → Firefox 2
Target Milestone: Firefox 2 → Firefox 2 alpha1
I prefer having it there, except the "read mail" option is ALWAYS INCORRECT - says I have 2 unread messages when I do not.
Please reconsider your removal of the "Read Mail" items. I use a theme that copies MS Internet Explorer and without that icon and menu entry it won't look the same.

Also: I like to send a email directly from my browser rather than go to the start menu and open Outlook Express from there.

As for the problem about showing the correct number of emails, why not just remove that small feature and leave the rest?
(In reply to comment #25)
> Please reconsider your removal of the "Read Mail" items. I use a theme that
> copies MS Internet Explorer and without that icon and menu entry it won't look
> the same.
> 
> Also: I like to send a email directly from my browser rather than go to the
> start menu and open Outlook Express from there.
> 
> As for the problem about showing the correct number of emails, why not just
> remove that small feature and leave the rest?
> 


Concur with the above poster.  I use the mail toolbar icon frequently for sending emails ("new message").  It is much easier and more productive to send a quick email while in Firefox versus minimizing, opening email program, etc., etc.  And the suggestion to remove the right click "Send Link" is perhaps even worse as this functionality is utilized by many FF users frequently.

Now, IMO, the "Read Mail" function/capability is unnecessary from within FF.
Those that need send mail, can create bookmark with mailto: as address.
Horrible idea.  INTEGRATION is what will speed adoption of both Firefox and Thunderbird.  Just as inconvenient in Linux as in Windows.
Please reconsider the removal of the "Read Mail" and "New Message" and Mail Menu items.

Practically everyone I know including myself use the "Send Link" feature.

It seems Fx developers do not read through any forums or they would see that the removal of this feature will cause users to leave Fx for Opera or IE. If anything the feature should be left in place with the addition of "Send Page" like in IE.

If MoFo decides not to revers course then they should have an extension available upon the release of 2.0 to allow users to add this feature back into Fx. 

The suggestion by Ivan Icin to add a bookmarklet is short sighted and does not take into consideration that the bulk of Fx users have no clue as to what a bookmarklet is let alone create one. If Fx is to remain useful browser and grow the average mom & pop user needs to have feature ease priority.
(In reply to comment #29)
> Please reconsider the removal of the "Read Mail" and "New Message" and Mail
> Menu items.
> 
> Practically everyone I know including myself use the "Send Link" feature.

Umm if you would have read the bug and you even quoted the title; you'd understand that all that was removed was whats in the title. Who said anything about the Send Link and Send Page being removed from the right click context menus and File menu? The bug ONLY removed the Read Mail and New Message... from the tools menu. Period.
(In reply to comment #1)
> Also of note: the unread mail count tends to be incorrect for many Win32 users
> due to using the MS provided regkey for unread mail count and the fact that it
> isn't managed afaict or if it is it isn't managed well. It is difficult for a
> user to understand that the unread mail count is provided by mail apps writing
> to this key and they usually blame Firefox for the incorrect count. Two thumbs
> up for this change!
I totally think that Fiefox should have email capabilities equal to and even better than IE 7. I am ready to jump ship back to IE if I can't "send page in email"...

Sorry guyz. BUt idea to remoe Read Email/New Email was an awful idea! This will not help you to speed up FF twice! Personally I use Mail button  to fast access by ThunderBird, but after new release of Bon Echo without Mail button, it is hard for me to always minimize all windows to run mail client! Please, leave it alone! Or people will move to other browsers! If will continue to do the same, you will remove half of menus just because someone things this is useless UI element! Just look on computers where FF used as primary browser! A lot of extentions installed just because you guyz removed a lot of things!
I'm used Mozilla Suite a log time ago and it was a terrible process for me to switch to FireFox because I will not be able to find half of function in FF!
And now you want to do same things? In this case drop graphics interface and FF as text browser! No needs in graphics at all :) (just a joke :) )
And while we're at it, why not add a calculator and a virus scanner, and actually I always hate having to minimise Firefox to load up my sequencer whenever I want to write some music so why not add an 'Open Cubase' link?

In fact, sod it.  Can you please make Firefox into a shell replacement.  I promise I won't switch to another browser if you do! 
I am against the removal too! PLEASE PLEASE PLEASE bring them back.

To the lamer that posted above me: trying to be funny????

E-mail IS related to browsing. I often need to mail something to an address that appears in a webpage, it's very easy and efficient to just press ctrl-M and write the message, instead of monimizing FF and running my mail client (TB).
(In reply to comment #34)
> I am against the removal too! PLEASE PLEASE PLEASE bring them back.
> 
> To the lamer that posted above me: trying to be funny????
> 

Hooray!  I'm a lamer.  Is it because I was begging in capitals?
(In reply to comment #34)
> I am against the removal too! PLEASE PLEASE PLEASE bring them back.
> 
> To the lamer that posted above me: trying to be funny????
> 
> E-mail IS related to browsing. I often need to mail something to an address
> that appears in a webpage, it's very easy and efficient to just press ctrl-M
> and write the message, instead of monimizing FF and running my mail client
> (TB).
> 

This bug is fixed, and commenting here can only be considered as spam. If you have something against it, open the new bug to bring back mail functions (or it is possibly already opened ?) and comment there.
Why is "menu clutter" a reason to remove a menu item?
Now I have to "clutter" my system menu with my own Thunderbird button.
Functionality is not necessarily "clutter".   

I suggest allowing the user to decide this.   Couldn't
a Thunderbird open button be configurable?

I used the ff Email feature daily.  When I upgraded to ff 2.0,
I greatly missed it.

This fix actually increases user menu clutter in Linux by forcing
the user to add a launcher button for Thunderbird (or other client).
It also increases work and worry:  I've spent two hours trying to get
my Email button to appear!

Let the user decide when a menu is "cluttered".
(In reply to comment #37)
> Why is "menu clutter" a reason to remove a menu item?
> Now I have to "clutter" my system menu with my own Thunderbird button.
> Functionality is not necessarily "clutter".   
> 
> I suggest allowing the user to decide this.   Couldn't
> a Thunderbird open button be configurable?
> 
> I used the ff Email feature daily.  When I upgraded to ff 2.0,
> I greatly missed it.
> 
> This fix actually increases user menu clutter in Linux by forcing
> the user to add a launcher button for Thunderbird (or other client).
> It also increases work and worry:  I've spent two hours trying to get
> my Email button to appear!
> 
> Let the user decide when a menu is "cluttered".
> 

There are extensions out there that add this back in. Please do not comment further in this bug. It's closed and has been for months.


-----

Btw is there anyways bugs can be locked from further comment unless they have at least canedit privs?

Just a FYI for people who are coming to this bug to complain, there are extensions available to restore this; e.g., https://addons.mozilla.org/firefox/3591/
Whiteboard: [read COMMENT 39 before commenting]
https://addons.mozilla.org/firefox/3591/ does NOT work for me. I used webmailcompose to intercept the standard mail icon so that it would go to Yahoo mail and hence I would not need and extra (Yahoo) toolbar.  The suggested replacement does NOT work. It invokes the dll that I used for IE, and I get an IE web page with Yahoo mail in it.  Is it possible for the wiseacres who removed this icon to provide some kind of plug in that lets me use an icon to invoke Yahoo Mail?

Thanks,
Brian Williams
I can understand the simplification of the Tools menu, but what's the benefit of removing the Mail button as an option from the Customize Toolbars window? I've received a number of complaints about that, and indeed it doesn't seem like much of a win.
Status: RESOLVED → VERIFIED
(In reply to comment #41)
> I can understand the simplification of the Tools menu, but what's the benefit
> of removing the Mail button as an option from the Customize Toolbars window?

The toolbar item has most of the same problems as the menu item - it isn't really related to web browsing, the unread mail count was often wrong, and removing all the front-end mail handling code at once reduced code clutter in the already too-cluttered browser.js. The backend support was not removed, however, so writing an extension to re-add the toolbar button and/or menuitem is pretty simple.
(In reply to comment #42)
>  The backend support was not removed,
> however, 

Is there any intention to remove the backend code? If so, is there a bug for it?
(In reply to comment #43)
> Is there any intention to remove the backend code? If so, is there a bug for
> it?

See comment 22.
****. I LOVED the new mail item. I also liked both SEND LINK and SEND PAGE. Bring 'em back! They were not bugs - so far as I know they worked fine.
You need to log in before you can comment on or make changes to this bug.