Closed Bug 307387 Opened 15 years ago Closed 14 years ago

{inc} TD cells are moving on click in DeerPark

Categories

(Core :: Layout: Tables, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Unassigned)

References

Details

(Keywords: regression, testcase, Whiteboard: [reflow-refactor])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050906 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050906 Firefox/1.6a1

When you click on the TD cells (or TR? or A? or IMG?) on the left of this test
page I uploaded (from a site I'm editing) you can see that the items move.  This
is of course not by design and this moving only happends in DeerPark.

We are talking about the latest 09/06/2005 nightly.

http://davidbetz.net/DeerParkTest/MovingBug/

Reproducible: Always

Steps to Reproduce:
1. Go to http://davidbetz.net/DeerParkTest/MovingBug/
2. Click on the left items
3.

Actual Results:  
They move...

Expected Results:  
They shouldn't move...
Invalid. Check your defined table width - It's too small for the images you're
using.
Irrelevant.

This looks fine in Firefox 1.0.x, Internet Explorer 6, Internet Explorer 5.5,
and it even works fine in Opera 8.  Only Firefox 1.5 has this bug.

That's just my point.  That site was created by a person who ...well, should
never be making websites.  He's horrible.  But you are going to break a LOT of
his work if you release that into production.  He created enormous websites and
the will all be a slanderous attack on Firefox 1.5 and an amzing advertisement
for Internet Explorer.

(I'm tasked to fixed his stuff and make it web standards compliant)
Version: unspecified → 1.5 Branch
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b4) Gecko/20050909
Firefox/1.4 ID:2005090906

This behavior persists in the above nightly.  Like comment 1, I'm not sure that
this is a bug though.
Status: UNCONFIRMED → NEW
Component: General → Layout: Tables
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → layout.tables
Version: 1.5 Branch → Trunk
-> Tech Evangelism
Component: Layout: Tables → English US
Product: Core → Tech Evangelism
Target Milestone: --- → Future
Version: Trunk → unspecified
Attached file testcase
This is not Tech Evangelism. As the reporter correctly stated, this didn't 
happen in previous versions. The testcase shows it also happens if the table is 
wide enough for its content. I'm trying Layout: Tables as a start.
Component: English US → Layout: Tables
Keywords: regression, testcase
Product: Tech Evangelism → Core
Target Milestone: Future → ---
Version: unspecified → Trunk
*** Bug 308392 has been marked as a duplicate of this bug. ***
Perhaps this should be -> Event Handling, since the strangeness is with a
mouse/keyboard action?
Reminds me of bug 263776.
Depends on: 263776
Er, I meant, reminds me of bug 263141.
Depends on: 263141
No longer depends on: 263776
Summary: TD cells are moving on click in DeerPark → {inc} TD cells are moving on click in DeerPark
Whiteboard: [reflow-refactor]
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

Seems fixed by reflow branch landing
Well, the img in the testcase doesn't have any width or height with current trunk builds (this was already the case with a 2006-12-06 build)
This regressed on trunk between 2006-06-24 and 2006-06-27, I filed bug 363235 for it.
To be able to test whether this bug is fixed, the testcase needs to avoid the condition in which bug 363235 occurs.
This bug seems to be fixed by the reflow branch landing. I can see the bug with a 2006-12-06 build, but not anymore with a 2006-12-08 build.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.