Spaces in folder names causes thunderbird to think a folder is not a folder

RESOLVED WORKSFORME

Status

Thunderbird
General
--
minor
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: Mathew Monroe, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050909 Fedora/1.0.6-1.2.fc4 Firefox/1.0.6

I have a IMAP based mail tree that looks like this

Inbox\
  Foo\
     Bar
     Baz
  Foo Stuff\

All of these folders contain mail.  On the linux version of thunderbird the
folder Inbox.Foo\ is considered a non-folder and one can not access messages
within it.  One can however access Inbox.Foo.Bar and Inbox.Foo.Baz.  If I rename
Inbox.Foo Stuff to something else, such as Inbox.Bar this problem goes away. 
This problem is not seen on the windows version of Thunderbird.




Reproducible: Always

Steps to Reproduce:

Comment 2

10 years ago
I can confirm this problem with Thunderbird 2.0.0.14.

Other clients can access the "foo" folder. With Thunderbird "foo" with its emails are not accessable.

Comment 3

10 years ago
Created attachment 328117 [details]
Screenshot

The folder "test ordner" below "Teststruktur" is in thunderbird not a normal folder. But it should and there is an email in it.

Comment 4

10 years ago
Created attachment 328118 [details]
Screenshot with evolution

This is the same account with evlution. You see "test ordner" below "Teststruktur" is a normal folder with an email in it.

Updated

10 years ago
Assignee: mscott → nobody

Comment 5

9 years ago
tested with Thunderbird 3.0b1pre (20080922) and there the "test ordner" is a folder as expected. The email inside is accessable again.

So its a problem in version 2 and fixed in version 3.

Comment 6

9 years ago
I found the cyrus Bug https://bugzilla.andrew.cmu.edu/show_bug.cgi?id=2777 and with this patch on a 2.2.13 cyrus imapd the problem is fixed for me.

Comment 7

9 years ago
->WFM as comment 5 says it works fine on trunk.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.