The default bug view has changed. See this FAQ.

unable to print forwarded mail (message/rfc822)

RESOLVED FIXED

Status

MailNews Core
Printing
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: wind li, Assigned: Ian Neal)

Tracking

({fixed-seamonkey1.1.3, regression, verified1.8.1.5})

Trunk
x86
All
fixed-seamonkey1.1.3, regression, verified1.8.1.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

In ThunderBird 1.5b1, select a mail forward to you, double click the forwarded
mail in the attachments to open it. Click print or print preview in the
toolbar,you will get a printing preparing dialog, and it will not finish at all.

Reproducible: Always

Steps to Reproduce:
1.In ThunderBird 1.5b1, select a mail forward to you
2.double click the forwarded mail in the attachments to open it
3.Click print or print preview in the toolbar

Actual Results:  
a printing preparing dialog, and it will not finish at all
(Reporter)

Updated

12 years ago
Summary: unable to print forwarded mail → unable to print forwarded mail
Version: unspecified → 1.5

Comment 1

12 years ago
There's actually very little that can be done with a forwarded message; see 
bug 204350.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 1.5 → Trunk

Updated

12 years ago
Blocks: 204350

Comment 2

12 years ago
With the patch for bug 204350, it is possible to print a forwarded message; however, the results are not as desired; see bug 204350 comment 41.

Actual results:
The printout shows the source of the message, rather than the text; all attachments are shown in their source state, which could be pages and pages of BASE64.

Expected results:
Minimal headers, message text shown as displayed, attachments printed out just as if the message had been opened from a folder rather than an attachment.

Comment 3

12 years ago
I can confirm this with Thunderbird version 1.5 (20051025)

Furthermore, saving the attached email to disk, opening it from there and trying to print causes Thunderbird to crash!

This seems to indicate that currently there is no way to print an attached message.

Comment 4

12 years ago
I can also confirm this works in 1.0.7 (version 1.0.7 (20050923))

I can open an attached message, and open a message attached to that message, and print it no problem.

Comment 5

12 years ago
(In reply to comment #4)
> I can also confirm this works in 1.0.7 (version 1.0.7 (20050923))

Quite right! My fault for not checking this.  1.5rc1 hangs on print, as described with this bug; 1.6a1-1109 prints the message source.
Keywords: regression

Comment 6

11 years ago
I can also confirm this with Thunderbird version 1.5 final release on win32 (20051201)

Comment 7

11 years ago
The workaround is to save the attachment as a .EML file, open that file using File|Open, and print from there.

Comment 8

11 years ago
*** Bug 322961 has been marked as a duplicate of this bug. ***

Comment 9

11 years ago
*** Bug 338814 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Summary: unable to print forwarded mail → unable to print forwarded mail (message/rfc822)

Comment 10

11 years ago
*** Bug 338586 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Component: Mail Window Front End → MailNews: Printing
OS: Windows 2000 → All
Product: Thunderbird → Core
confirmed on tb2a1 build 20060828

the eml attachment opens correctly, but TB prints a white page and so print preview, that shows a white page

Comment 12

11 years ago
*** Bug 360764 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Flags: blocking-thunderbird2?

Updated

10 years ago
Duplicate of this bug: 365958

Updated

10 years ago
Duplicate of this bug: 367363

Comment 15

10 years ago
Moving off bugs that didn't make the deadline for Thunderbird 2. 
Flags: blocking-thunderbird2? → blocking-thunderbird2-

Updated

10 years ago
Flags: blocking-thunderbird2- → blocking-thunderbird2?

Updated

10 years ago
Duplicate of this bug: 377014

Updated

10 years ago
Duplicate of this bug: 379346
(Assignee)

Updated

10 years ago
Duplicate of this bug: 349492
(Assignee)

Updated

10 years ago
Duplicate of this bug: 344564
(Assignee)

Comment 20

10 years ago
if the param.originalMsgURI is imap rather than imap-message then Edit as New fails, setting that variable to an empty string means Edit as New works.
(Assignee)

Comment 21

10 years ago
Created attachment 265463 [details] [diff] [review]
Simple patch v0.1 (Checked into trunk & 1.8 branch)

This patch:
* Changes two lines to take into account attached emails are now type=application/x-message-display instead of type=x-message-display
Assignee: mscott → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #265463 - Flags: superreview?(mscott)
Attachment #265463 - Flags: review?(mscott)

Updated

10 years ago
Attachment #265463 - Flags: superreview?(mscott)
Attachment #265463 - Flags: superreview+
Attachment #265463 - Flags: review?(mscott)
Attachment #265463 - Flags: review+
(Assignee)

Comment 22

10 years ago
Comment on attachment 265463 [details] [diff] [review]
Simple patch v0.1 (Checked into trunk & 1.8 branch)

Checking in (trunk)
nsMsgPrintEngine.cpp;
new revision: 1.84; previous revision: 1.83
done
Attachment #265463 - Attachment description: Simple patch v0.1 → Simple patch v0.1 (Checked into trunk)
(Assignee)

Comment 23

10 years ago
Comment on attachment 265463 [details] [diff] [review]
Simple patch v0.1 (Checked into trunk & 1.8 branch)

Requesting a= for TB and SM for very simple, low-risk regression fix.
Attachment #265463 - Flags: approval-thunderbird2?

Comment 24

10 years ago
Comment on attachment 265463 [details] [diff] [review]
Simple patch v0.1 (Checked into trunk & 1.8 branch)

I think we'd need 1.8.1.5 approval for this...thx a lot for fixing this, Ian.
Attachment #265463 - Flags: approval1.8.1.5?
(Assignee)

Comment 25

10 years ago
Fixed on trunk, just waiting for branch approvals -> Resolved / Fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Duplicate of this bug: 384302
Comment on attachment 265463 [details] [diff] [review]
Simple patch v0.1 (Checked into trunk & 1.8 branch)

approved for 1.8.1.5, a=juanb for release-drivers
Attachment #265463 - Flags: approval1.8.1.5? → approval1.8.1.5+
(Assignee)

Comment 28

10 years ago
Comment on attachment 265463 [details] [diff] [review]
Simple patch v0.1 (Checked into trunk & 1.8 branch)

Checking in (1.8 branch)
nsMsgPrintEngine.cpp;
new revision: 1.78.12.1; previous revision: 1.78
done
Attachment #265463 - Attachment description: Simple patch v0.1 (Checked into trunk) → Simple patch v0.1 (Checked into trunk & 1.8 branch)
Attachment #265463 - Flags: approval-thunderbird2?
(Assignee)

Updated

10 years ago
Flags: blocking-thunderbird2?
Keywords: fixed-seamonkey1.1.3, fixed1.8.1.5
I just finished printing a couple levels of forwarded messages, just fine, in both the 3-pane and the message pane, with:

version 2.0.0.5pre (20070710) running on Windows XP SP2.

Replacing fixed1.8.1.5 keyword with verified1.8.1.5
Keywords: fixed1.8.1.5 → verified1.8.1.5

Comment 30

10 years ago
Works for me on Thunderbird 2.0.0.6 on Win2k AS
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.