Selection drag-scroll->try to scroll up but page keeps scrolling down

VERIFIED FIXED in M16

Status

()

defect
P3
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: b.judd, Assigned: mjudge)

Tracking

Trunk
PowerPC
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

20 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.14 ppc; en-US; m14)
BuildID:    2000030215

Take a page that is at least two screenfulls in size. Select a section of text
and drag downwards so that the page scrolls down. When it reaches the bottom
release the mouse button. While the text is still; selected, you will be unable
to scroll up (if you attempt to useing page-up or the scroll bars it will simply
scroll back down again -- spooky :) )


Reproducible: Sometimes
Steps to Reproduce:
This is tricky to do. At first I couldn't get it to work, but with a bit of
practice it happens every time so just keep at it :)

1. Load the page above
2. Scroll down to a spot one screen above the very bottom.
3. Mouse down and move the mouse to the bottom of the screen causing it to
scroll downwards. Do it so that the screen moves as slowly as possible or else
you may not be able to stop in time.
4. At the instant the very bottom line appears on the screen release the mouse
button causing it to stop scrolling (this is the tricky bit, if you do it too
soon (so the last line doesn't appear on screen) or too late (so that the screen
pauses at the bottom for an instant with the mouse button down) the effect
doesn't appear)
5. Hit the page up key (notice how it scrolls down all by itself)
6. Try to scroll up with the scroll bars (notice the same effect)
7. Unselect the text. You can now scroll up


Actual Results:  When attempting to scroll up, the page would scroll down all by
itself

Expected Results:  The page should not scroll around all by itself

This is a spooky thing to have happen to you when you aren't expecting it :)

NOTE: the above effect is really tricky to get to work. After trying 20 times I
could get it to work three times, so it is really dependant on the exact timing
of when you release the mouse button. The scroll bar has to travel all the way
to the bottom and the last line has to be displayed completely, but you have to
release the mouse button as soon as you can. I found the easiest way to get it
to work was on a reasonably large page which would scroll reasonably slowly. You
have to keep your eye on the scroll bar, not the pointer and watch to see when
it hits the bottom.

Comment 1

20 years ago
                                                                    
b.judd@xtra.co.nz, thanks for the great bug report. Do you think you could be 
seeing bug #29300 ("Release mouse button on scroll bar -> page won't stop 
scrolling")?
Reporter

Comment 2

20 years ago
I'm not sure now because I cannot get the behaviour specified in 29300 (by the
way, how do you put in a link to another bug?), (I'm also having difficulty
repeating *my* bug but hey), but I think my bug is different. He specified that
it seemed not to recognise the button release which caused the selection to
continue changing. What I get is completely different ie. it seems to recognise
the button release but you can't scroll up. Hope this helps.

Comment 3

20 years ago
Hey, B Judd ---

Thanks for your quick follow-up! Bugzilla automatically inserts the links when 
you provide a bug #. 

If you can find a highly reproducible case for your bug, that would be great. 
Otherwise, it'll probably sit around until someone can reproduce it, or Mike 
figures out what's triggering it.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Reporter

Comment 4

20 years ago
Heh, that's what I figured. It's driving me nuts, now *I* can't even reproduce
it :) Maybe it's a phase of the moon thing. Oh by the way B Judd is my father,
I'm gwyn 

Comment 5

20 years ago
Setting to M16 for now.

Please continue to try to reproduce this.  If you are unsuccessful, we'll resolve 
the bug as worksforme (you could later reopen the bug if you later did find the 
problem).  Thanks!
Target Milestone: M16
Reporter

Comment 6

20 years ago
Ok will do
Assignee

Comment 7

20 years ago
I had done some fixing for pageup/down snapping back to your "cursor" aka 
extension part of selection. I think this bug has been fixed. I THINK I have 
tried the bug the way it was explained and I cant reproduce it. Now that I have 
checked in the setcapture code, please try reprodicing this again. thanks alot.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Reporter

Comment 8

20 years ago
I wish I could :). Unfortunately for various reasons including there is no
nightly ppc build, I cant build myself and in any case I could never reproduce
the problem after the first couple of times I will be unable to try to reproduce
it again. I suggest leaving it as FIXED or even VERIFIED if you like cause I
doubt there is ever gonna be enough test data to be sure it was ever fixed.

Comment 9

19 years ago
Rubber-stamping as Verified/Fixed, due to lack of a better resolution.
Status: RESOLVED → VERIFIED
Reporter

Comment 10

19 years ago
I finally got around to installing M15 (nice job guys, heaps faster :) ). Anyway

now drag-scrolling doesn't work at all! I don't know if they are related or not

though so I put it in as a totally new bug #36792

Reporter

Updated

19 years ago
Blocks: 36868
You need to log in before you can comment on or make changes to this bug.