Thunderbird doesn't use display name for people I know within the thread pane

RESOLVED DUPLICATE of bug 243631

Status

Thunderbird
Folder and Message Lists
--
enhancement
RESOLVED DUPLICATE of bug 243631
12 years ago
7 years ago

People

(Reporter: Anthony P., Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Hi Team,

currently using Thunderbird 1.5 Beta 1 (20050908)

I have the option selected to Show only display name for people in my address
book. However in the "Sender field" of the Folder pane Inbox,on my IMAP Folders.
It only shows their email address. It's not untill I open the email I actually
see the senders name.

Reproducible: Always

Steps to Reproduce:
1. Start Thunderbird
2. Navigate to Folder Pane
3. View received emails


Actual Results:  
in the "Sender field" of the folder pane Inbox,on my IMAP Folders shows email
address only. It does not show "Friendly Name"

Expected Results:  
It should have displayed emails in the folder pane on my IMAP folders with 
"Friendly Name" not just the email address.

Comment 1

12 years ago
This is mentioned at bug 243631 but isn't what that bug is about.
Unfortunately, the dupe has been WontFix'd.

*** This bug has been marked as a duplicate of 279290 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

12 years ago
Created attachment 200047 [details]
NOT Showing My display Name in Folder Pane on IMAP Account

How could this be marked a duplicate of 279290. When this Bug# 279290 has
nothing to do with the Folder Pane on IMAP folders. 279290 Is referring to the
envelope pane. Please see attached image I have blocked out the domain of the
email for privacy!
(Reporter)

Comment 3

12 years ago
Created attachment 200048 [details]
Showing My display Name in Folder Pane on POP 3 Account

Please see attached image and the previous image to show what I am trying to
explain and to work out why you have deemed this to be a duplicate of 279290. 

I believe 279290 was making reference to the email address either displaying or
not displaying in the envelope pane. Once the email has been opened.

Please review!
Not a dupe. Reporter does this still happen for you? Otherwise please close this bug as WFM.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
QA Contact: front-end
David, AFAIR this has nothing to do with the display name, right? The name which is shown in the thread pane is the senders name and not the display name out of the address book. Could this be an RFE?

Comment 6

11 years ago
right, we display what's in the e-mail msg, not what's in your address book. It could be an RFE.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Thunderbird Not showing Display name for people in my address book on IMAP Folders → Thunderbird doesn't use display name for people I know within the thread pane
Version: unspecified → Trunk

Updated

9 years ago
Assignee: mscott → nobody

Updated

9 years ago
Duplicate of this bug: 493445

Updated

9 years ago
Component: Mail Window Front End → Folder and Message Lists
QA Contact: front-end → folders-message-lists

Updated

8 years ago
Blocks: 296523
my duped bug #493445 is related to POP3.

Comment 9

8 years ago
Just found an Add-On that provides the display name in the thread pane as requested in this bug report:
https://addons.mozilla.org/de/thunderbird/addon/5296

The interesting thing:
This Add-On made me aware of an additional problem:
The Thunderbird search/searchbox (with or without Gloda) does not recognize the display name !
--> So if someone starts to work on this bug one day, please take this additional problem into consideration and make the Thunderbird search function aware of the display name
.

Comment 10

8 years ago
Marking this dependent on bug 474721, which has a single, (relatively) standard function for formatting display names. Unfortunately, the function is in Javascript, and I have no idea how to call it from C++ (or if it's possible at all). If someone has ideas for how to implement it, I'll write a patch.
Depends on: 474721

Comment 11

7 years ago
After implementing this bug, will there be any place where we are still showing the REAL headers (incl. original display name) as in the message? I am not sure converting to address book's display name is the right thing for everyone. Please ensure maximum customisability if this should ever get implemented!

(In reply to comment #9)
> The Thunderbird search/searchbox (with or without Gloda) does not recognize the
> display name !
Part of that problem is covered by:
Bug 460737 - Quick search ignores friendly contact names / inconsistent UI displaying addresses in message list vs. message reader

Comment 12

7 years ago
The message headers will still show the true values if "Preferences -> Advanced -> Reading & Display -> Show only display name for people in my address book" is unchecked. Theoretically, this could be extended to anywhere else FormatDisplayName is used, but I don't know if that's really important as long as the information is somewhere.

That said, there is considerably more customizability this way since anyone should be able to override FormatDisplayName to work however they like.

Updated

7 years ago
See Also: → bug 460737

Comment 13

7 years ago
Well, since the current way annoys me, but I can't figure out a way to implement this that won't have performance issues, I did it in an addon: https://addons.mozilla.org/en-US/thunderbird/addon/239114/

Hopefully at some point, I'll be able to figure out how to do this properly in Thunderbird, but until then at least I have my pretty threadpanes. :)

Comment 14

7 years ago
(In reply to comment #13)
> Well, since the current way annoys me, but I can't figure out a way to
> implement this that won't have performance issues, I did it in an addon:
> https://addons.mozilla.org/en-US/thunderbird/addon/239114/
> 
> Hopefully at some point, I'll be able to figure out how to do this properly in
> Thunderbird, but until then at least I have my pretty threadpanes. :)

Jim, very nice extension. Thanks.

Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101012 Thunderbird/3.3a1pre

Comment 15

7 years ago
Just tested the extension and I found out, that you cannot search for display names via the Quick Search Bar or Gloda.
Example:
- In your addressbook you have the following contact
  Display Name: "John Doe"
  E-Mail: "test@test.com"
- Then you get an E-Mail from that contact.
  But the sender's details in that mail are (according to the mail's
  source text):
  From (= Sender Name): "MrX"
  E-Mail: "test@test.com"
  (The mail's source text shows for the sender:  "MrX <test@test.com>" )
- Your Inbox shows:
  From (= Display Name): "John Doe"
- When you now search for "Doe" or "John", you will not not get any
  result/match.
  You will only get a result/match if you search for e. g. "MrX" or "test".

I guess my findings will also be relevant when implementing this new feature directly in TB, not only for the extension.
Thanks.

Comment 16

7 years ago
(In reply to comment #15)
> Just tested the extension and I found out, that you cannot search for display
> names via the Quick Search Bar or Gloda.

The quickfilter problem is related bug 460737: Quickfilter ignores searches for friendly display names from address book contacts
Which is quite a considerable UI flaw that would well deserve more attention, like having the wanted-thunderbird+ flag set.

Comment 17

7 years ago
I just saw that TB 3.3a3pre (in my case build 2011-02-16) shows the display names from the addressbook in the thread pane of each folder.
It seems that Bug 243631 fixed this ?

Comment 18

7 years ago
sounds like this is a dup.
Status: NEW → RESOLVED
Last Resolved: 12 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 243631
You need to log in before you can comment on or make changes to this bug.