Last Comment Bug 315979 - MathML <mover> and <mo> interaction test fails. OverBar doesn't extend over expression.
: MathML <mover> and <mo> interaction test fails. OverBar doesn't extend over ...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: MathML (show other bugs)
: Trunk
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: rbs
: Hixie (not reading bugmail)
Mentors:
http://www.w3.org/Math/testsuite/test...
Depends on:
Blocks: 289678
  Show dependency treegraph
 
Reported: 2005-11-10 18:55 PST by Austin Lund
Modified: 2006-10-18 19:08 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Austin Lund 2005-11-10 18:55:22 PST
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051110 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051110 Firefox/1.6a1

See URL.  The overbar appears as a small dash on my rendering.  Does not extend over the expression as in the example.

Reproducible: Always

Steps to Reproduce:
1. Go to URL

Actual Results:  
Overbar does not extend over expressions as per the example.

Expected Results:  
See the sample rendering.
Comment 1 zug_treno 2005-11-11 15:04:10 PST
Related to Core bug 120198 comment 85?
Comment 2 distler 2006-06-01 22:21:41 PDT
Same problem in SeaMonkey 1.5a, Gecko/20060531. This is NOT a Firefox-specific bug. It's a MathML rendering bug (MacOSX-specific, AFAIK). I suggest changing Product to "Core" if you want to get some attention to it.

What worked for me was to add the line:

\u00AF = \uFFFD\uFFFD\uFFFD\uF8E5\u00AF # ad-hoc: overbar is stretched with the radical extender

to the file 

Contents/MacOS/res/fonts/mathfontMath4.properties

Comment 3 distler 2006-10-08 10:23:07 PDT
Four months later, and the status of this bug does not seem to have changed. The solution (which has been verified to work in Firefox, SeaMonkey and Camino) is in the previous comment.
Comment 4 rbs 2006-10-08 16:21:53 PDT
That line comes from the mathfontSymbol.properties file.

Any reason why the Symbol font is not working for you guys anymore?

It could be that Symbol is not terminating the font.mathfont-family pref.

font.mathfont-family: ..., Symbol
Comment 5 distler 2006-10-08 19:18:47 PDT
On MacOS, one needs to change the default value for font.mathfont-family to omit the Computer Modern fonts from the list.

There was a time (not that long ago) when Symbol was not working on MacOSX. So I, at least, had eliminated it, as well.

Changing

   user_pref("font.mathfont-family", "Math1,Math2,Math4");

to 

   user_pref("font.mathfont-family", "Math1,Math2,Math4,Symbol");

did, indeed, fix the problem for me.

The instructions at

   http://www.mozilla.org/projects/mathml/fonts/

need to be corrected, then. Either that, or one needs to add the line I suggested about to mathfontMath4.properties, so that those who follow these instructions will not be tripped-up.
Comment 6 rbs 2006-10-18 16:59:44 PDT
Math4 does not contain the overbar or radical extender, so it is not quite clean to put that definition in mathfontMath4.properties (the definition is only working because we further do some extra lookup in the Gfx font code to substitute glyphs not in the primary font).
http://www.mozilla.org/projects/mathml/fonts/encoding/math4.gif

The section "TeX's Computer Modern Fonts" on the font webpage instructs looking at: https://bugzilla.mozilla.org/show_bug.cgi?id=134849#c10

But based on this feedback, it might help users to just put that pref inline in the font webpage to make it more apparent.
Comment 7 rbs 2006-10-18 19:08:07 PDT
The text in the font webpage has been updated. I am marking this one fixed, but we are not done yet with &OverBar; (bug 289678).

Note You need to log in before you can comment on or make changes to this bug.