Firefox 1.5 RC3: xlink:href hyperlinks inside of svg text elements do not work

RESOLVED DUPLICATE of bug 330059

Status

()

Core
SVG
--
major
RESOLVED DUPLICATE of bug 330059
12 years ago
11 years ago

People

(Reporter: Henning Pingel, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6 Mnenhy/0.7.2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.10) Gecko/20050717 Firefox/1.0.6 Mnenhy/0.7.2.0

Inside of a SVG document I create a text element that contains an amount of words. One of these words should be turned into a hyperlink that leads to a different web site. Inside of the text-element I didn't find a way to create a hyperlink using the a-tag (or tspan-tag and a-tag in combination).

According to my knowledge of the SVG specification it should be possible to use an a-tag inside of a text-tag.

For further details please have a look at the provided example (hyperlinks_in_text_tags.svg).

Reproducible: Always

Steps to Reproduce:
Open SVG document in Firefox. Compare displayed text content with source. Try to click links.

Actual Results:  
Text content wrapped with an a-tag is not displayed if inside of a text tag

Expected Results:  
Hyperlinks should be displayed, be clickable and lead to target web page.

Works in MSIE with Adobe SVG Viewer 3.
(Reporter)

Comment 1

12 years ago
Useragent used for SVG testing was : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Error Message for test 5 (see testcase hyperlinks_in_text_tags.svg) was: 

Error: uncaught exception: [Exception... "Component returned failure code: 0x804b000a [nsIIOService.newURI]"  nsresult: "0x804b000a (<unknown>)"  location: "JS frame :: chrome://browser/content/browser.js :: makeURLAbsolute :: line 4797"  data: no]
(Reporter)

Updated

12 years ago
Summary: xlink:href hyperlinks inside of svg text elements do not work → Firefox 1.5 RC2: xlink:href hyperlinks inside of svg text elements do not work
(Reporter)

Updated

12 years ago
Summary: Firefox 1.5 RC2: xlink:href hyperlinks inside of svg text elements do not work → Firefox 1.5 RC3: xlink:href hyperlinks inside of svg text elements do not work
(Reporter)

Updated

12 years ago
(Reporter)

Comment 2

12 years ago
Testcase can be found at: 
http://www.henningpingel.de/fileadmin/henning/bugzilla/hyperlinks_in_text_tags.svg

Comment 3

12 years ago
So there are two issues here, that need two separate bugs:

1)  The links don't work.  This should be filed on Core:SVG.  I have no idea
    what's up there.

2)  This exception is thrown.  It's thrown because someone passed |undefined| as
    the base to makeURLAbsolute, and that happens because as far as JS is
    concerned an <svg:tspan> is not an nsIDOM3Node.  The reason is a missing
    DOM_CLASSINFO_SVG_ELEMENT_MAP_ENTRIES (or possibly even
    DOM_CLASSINFO_SVG_GRAPHIC_ELEMENT_MAP_ENTRIES?  No idea) in the following
    code in nsDOMClassInfo.cpp:

2691   DOM_CLASSINFO_MAP_BEGIN(SVGTSpanElement, nsIDOMSVGTSpanElement)
2692     DOM_CLASSINFO_MAP_ENTRY(nsIDOMSVGTextPositioningElement)
2693     DOM_CLASSINFO_MAP_ENTRY(nsIDOMSVGTextContentElement)
2694   DOM_CLASSINFO_MAP_END

Over to core SVG, but this bug covers issue 1; we should have a separate bug on issue 2.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → SVG
Ever confirmed: true
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → ian
Hardware: PC → All
Version: unspecified → Trunk

Comment 4

12 years ago
I'm pretty sure the links not working issue is bug 314568.

Comment 5

12 years ago
It's not.  That's a trunk-only regression for cases when xlink:href is used for non-link purposes.  This bug is present in 1.8 branch builds (as you can see from the summary).

I filed bug 317027 for the classinfo issue.
Depends on: 317027

Comment 6

12 years ago
I think the link not working in test #5 (the final case) is a duplicate of bug 287252. Tests #2, #3 and #4 exhibit a different issue however.

Updated

12 years ago
Depends on: 287252
The problem with text inside an <a> not showing was fixed by Robert in bug 330059. As for text #5, for now we don't support XLink on arbitrary SVG elements, only on <a>.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 330059
You need to log in before you can comment on or make changes to this bug.