Hangs when opening a PDF, sometimes (Both of Adobe Acrobat Reader 6.00 & Professional 6.0.4 are installed)

RESOLVED DUPLICATE of bug 212067

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 212067
13 years ago
12 years ago

People

(Reporter: Julian D. A. Wiseman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Opening a PDF has caused Firefox 1.5 to hang, such that it can only be closed with the task manager. I have not yet worked out how to this consistently, but it has happened several times with 1.5RC3 and with 1.5. 

This might or might not be related to Bug 266698, Bug 252048, Bug 173061, and Bug 274077, but this is a much newer report and the problem is with 1.5. 

Installed is, inter alia, the (reliable in 1.07) addon PDF Download 0.5.1.2. 

Reproducible: Sometimes

Steps to Reproduce:
(Q1) What is the version of Adobe Reader (or Adobe Acrobat Reader)?
     Please note that plugin's version number is 7.0.0
     even for newest Adobe Reader 7.0.5.
(Q2) Is killing of windowless AcroRd32.exe process from "Task Mangaer" 
     (Not started from start menu or shortcut. Stared by PDF open in browser.) 
     a effective recovery procedure from freeze of Firefox?

See also Bug 318733 and Bug 318611.
(Reporter)

Comment 2

13 years ago
Adobe Acrobat Professional 6.0.4 7/25/2005. 

When it next happens I will test the killing of AcroRd32.exe and report back. 
(In reply to comment #2)
> Adobe Acrobat Professional 6.0.4 7/25/2005. 

Hang of Acrobat 6.0.0 should have been resolved by Acrobat 6.0.1
(See Bug 214137)
Regression after Acrobat 6.0.1?
If it was, similar bugs to this bug even after Acrobat 6.0.1 is understandable...
But...

Do you install both Acrobat Professional 6.0.4 and Acrobat Reader 6.0.x(or 5.x)?
What is plugin's version? Where plugin is read from?
(Set plugin.expose_full_path=true thru about:config, then see about:plugins)
(Please don't forget to reset plugin.expose_full_path to false for safety. )
(Reporter)

Comment 4

13 years ago
Adobe Acrobat
File name: C:\Program Files\Adobe\Acrobat 6.0\Reader\browser\nppdf32.dll
Adobe Acrobat Plug-In Version 6.00 for Netscape

MIME Type Description Suffixes Enabled
application/pdf Acrobat Portable Document Format pdf Yes
application/vnd.fdf Acrobat Forms Data Format fdf Yes
application/vnd.adobe.xfdf XML Version of Acrobat Forms Data Format xfdf Yes
application/vnd.adobe.xdp+xml Acrobat XML Data Package xdp Yes
application/vnd.adobe.xfd+xml Adobe FormFlow99 Data File xfd Yes

[Apologies for losing the table formatting: if important I'll do an attachment.]
(In reply to comment #4)
> Adobe Acrobat
> File name: C:\Program Files\Adobe\Acrobat 6.0\Reader\browser\nppdf32.dll
> Adobe Acrobat Plug-In Version 6.00 for Netscape

Looks for me to be that plugin module of "Adobe Acrobat Reader 6.0.0" is used
even though AcroRd32.exe is module of "Adobe Acrobat Professional 6.0.4".
Summary: Hangs when opening a PDF, sometimes → Hangs when opening a PDF, sometimes (Adobe Acrobat 6.0)
Summary: Hangs when opening a PDF, sometimes (Adobe Acrobat 6.0) → Hangs when opening a PDF, sometimes (Both of Adobe Acrobat Reader 6.00 & Professional 6.0.4 are installed)

Comment 6

12 years ago

*** This bug has been marked as a duplicate of 212067 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
No longer blocks: 336184
You need to log in before you can comment on or make changes to this bug.