If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[meta-ish] Cmd-. (period) / Escape / Cancel button parity

RESOLVED WORKSFORME

Status

Camino Graveyard
Accessibility
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Herbert Schulz, Assigned: froodian (Ian Leue))

Tracking

(Depends on: 1 bug, {access, helpwanted, polish})

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051216 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051216 Camino/1.0+

If you mistakenly press Cmd-D you can't dismiss the drop down sheet using Cmd-. from the keyboard.

Reproducible: Always

Steps to Reproduce:
1.With a page open, press Cmd-D (to get the Add Page to Bookmarks sheet to drop down).
2Cancelling via Cmd-. doesn't work, only ESC or clicking works.
3.

Actual Results:  
See above.

Expected Results:  
Cmd-. is a standard Mac command to Cancel and should, along with ESC, be bound to the Cancel button on that sheet.

I haven't checked other sheets.
(Assignee)

Comment 1

12 years ago
Yeah, Cmd-period should consistently mapped to cancel for any sheet.  I think we should tweak the summary to include all sheets we don't do this for, since a seperate bug for each one would be messy.  Just mention if you want me to file them seperately and I'll fix.  Here's the list of menu items we should add this to:

Open File...
Save As...
Import Bookmarks...
Export Bookmarks...
Page Setup...
Clear History...
Add Page to Bookmarks...
Add Bookmark Folder...
(Reporter)

Comment 2

12 years ago
Howdy,

I agree. Put them all under this bug.

Good Luck,
Herb Schulz
(Assignee)

Comment 3

12 years ago
Found another:

Open Location... (with toolbar hidden)

Comment 4

12 years ago
Why isn't this working by default? I thought cmd-. was automatically hooked up to cancel by the OS, like Esc is.

cl
Wevah and I already have a few bugs on Cmd-period not working.

Comment 6

12 years ago
Found another one tonight. Cmd-. with a download selected in the Download Manager doesn't work. Esc does. Oops.

cl
(In reply to comment #6)
> Found another one tonight. Cmd-. with a download selected in the Download
> Manager doesn't work. Esc does. Oops.

Bug 298446

(In reply to comment #1)
> Open File...

Bug 168644

Somewhat-related bugs: bug 285531, bug 289432, bug 314306

There may be others already filed, but these are the ones I came up with after a very quick search.
Status: UNCONFIRMED → NEW
Depends on: 168644, 298446
Ever confirmed: true
Summary: Cancel Button on Add Page to Bookmark sheet not tied to Cmd-. → Cmd-. (period) / Escape / Cancel button parity
Target Milestone: --- → Camino1.1
Putting this in the right place; sorry.
Component: Bookmarks → Accessibility
Keywords: polish
(Assignee)

Comment 9

12 years ago
Found another - the sheet that comes up for Search the Web when the toolbar is minimized or text only (probably should have thought of it back in Comment 3)
Keywords: access
QA Contact: accessibility
Summary: Cmd-. (period) / Escape / Cancel button parity → [meta-ish] Cmd-. (period) / Escape / Cancel button parity
We need to figure out how you assign two shortcuts to the same button to fix a lot of these, both for sheets/dialogues generated in code and those done as nibs.
Assignee: mikepinkerton → nobody
Keywords: helpwanted
Target Milestone: Camino1.1 → Camino1.2
(Assignee)

Comment 11

11 years ago
The reason we don't get the cmd-./escape parody for free is because we have cmd-. as the keyboard shortcut for "Stop Loading Page" in the main menu.  Every place I could think of that uses escape also works for cmd-. if we change the menu item's shortcut.

I'm not sure what we should do about this.  Obviously cmd-. should stop a loading page, but maybe we should set that keyboard shortcut programmatically instead of in the nib?  I'm also not sure how Safari works around this...
(Assignee)

Comment 12

11 years ago
Created attachment 259875 [details] [diff] [review]
Patch v1

This is moderately evil, for a couple reasons:

1) It completely rewrites an OS method that gets called at every keystroke
2) There's gotta be a better way to do the bitwise arithmetic here, but I sure don't know what it is.  The tricky thing is that you can't just compare between event and menu item, since there's some device-specific information in the event's modifierFlags.  Additionally, non-function-key items with shift don't have the shift mask in the menu item - they're just stored as the capital version of the letter.  What I do works, I'm just not sure it's best.
3) It feels kinda sketchy to essentially ask MainController if we need to beep

On the other hand, it seems to fix all incarnations of this bug.
Assignee: nobody → froodian
Status: NEW → ASSIGNED
Attachment #259875 - Flags: review?(stuart.morgan)

Comment 13

11 years ago
Comment on attachment 259875 [details] [diff] [review]
Patch v1

So many flavors of no.
Attachment #259875 - Flags: review?(stuart.morgan) → review-
Depends on: 289432
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
Target Milestone: Camino1.6 → ---

Comment 15

10 years ago
Command-. works for me in all of these cases.  I'm on Leopard.  Was this an OS bug that got fixed?  Does the OS only steal command-. when View:Stop Loading Page is enabled?
Just as with bug 168644, this appears to work correctly in all listed cases (10.5 and 10.6)
Ditto bug 168644 comment 17 here: if it doesn't work on 10.4, we should just "[10.4]" the summary and leave it open until we drop 10.4 support.

Yay for the progress of time :)
It's unclear what this is tracking itself (as opposed to the meta part, where it's tracking all of just bug 168644 now).  Given that, and comment 15 and 17, I'm just going to WFM this now.  This has served its purpose.

> Yay for the progress of time :)

P.S. Hi, Ian!
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.