Closed Bug 32360 Opened 24 years ago Closed 24 years ago

View Frame Source is broken

Categories

(SeaMonkey :: UI Design, defect, P1)

x86
All
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: rzach, Assigned: law)

References

()

Details

(Keywords: regression, Whiteboard: [nsbeta2+][6/15])

Right click on frame and choosing "View frame source" from context menu doesn't
work.

To reproduce:
1. Go to frameset page, e.g., http://socrates.berkeley.edu/~frege
2. Right-click
3. Choose "View frame source"

Actual result: Nothing happens.  Console sez:

JavaScript Error: TypeError: contextMenu.viewFrameSource is not a function

Expected result: source view of frame

Linux build 2000.03.17.09
Confirmed as reported on WinNT with 2000-03-20-11-M15. The "View Page Source"
item on the context menu for either frame displays the source for the frameset
page, as expected, but the "View Frame Source" item does nothing.
Changing OS to "All".
not a problem using beta1 branch bits (linux, winNT, mac, 2000.03.20.06-nb1b,
opt comm) --so, just to clarify, was this seen in tip builds? thx!
Yes, the build I used was not an nb1b build.

From comments in bug 29795, "cannot view frame source right", WORKSFORME,
it looks like this was working at the beginning of the month; marking as
regression.
Keywords: regression
I saw it on a trunk build, not on beta.
Note related bug 32437. Upping severity (the whole subsystem seems to have 
problems) and changing to XPApps, as suggested by asadotzler@netscape.net.

Gerv
Severity: normal → critical
Component: XP Toolkit/Widgets: Menus → XPApps
Status: NEW → ASSIGNED
Target Milestone: --- → M15
I've fixed this and will be checking it in soon.  Some code got deleted from 
nsContextMenu.js.  I've put it back and have tweaked it to match the new view 
source strategy.
View Frame Source does precisely nothing on 20000328 W95 or NT. (It does work in 
the commercial beta, though ;-)

Gerv
I'll check it in "soon," just not *that* soon :-).  I'll mark this 
resolved-fixed as soon as I do.  Priority is on some beta2 feature work at the 
moment.
Move to M16 ... when Bill can get to it ... I hope ...
Target Milestone: M15 → M16
insert following code in nsContextMenu.js at line 272

    // Open new "view source" window with the frame's URL.
    viewFrameSource : function () {
    window.openDialog(	"chrome://navigator/content/viewSource.xul",
			"_blank",
			"chrome,dialog=no",
			this.target.ownerDocument.location.href);
    },

ripped an a little bit modified from
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/xpfe/browser/resources/content&command=DIFF_FRAMESET&file=nsContextMenu.js&rev1=1.13&rev2=1.14&root=/cvsroot

Tested with Build ID: 2000041008 on WinNT - works perfectly ;-)
law@netscape.com or anyone else - there's an easy kill for you here...

Gerv
*** Bug 36340 has been marked as a duplicate of this bug. ***
*** Bug 37325 has been marked as a duplicate of this bug. ***
Nominating as beta 2 blocker.

Keywords: nsbeta2
Priority: P3 → P1
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [nsbeta2+][6/01]
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][6/15]
Move to M19.
Target Milestone: M16 → M19
*** Bug 40852 has been marked as a duplicate of this bug. ***
Fixed checked in (finally).
Status: ASSIGNED → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
*** Bug 42126 has been marked as a duplicate of this bug. ***
vrfy 2000.06.14.08-m17 all/all.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.