emails: Unread 1 Total 0 - (phantom unread e-mail messages in Inbox)

VERIFIED FIXED in mozilla0.9

Status

SeaMonkey
MailNews: Message Display
P1
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Bruce, Assigned: Bienvenu)

Tracking

Trunk
mozilla0.9
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta1+])

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
There aren't any emails in Folder, but in the "Mail Folders"-Part it says, there
is a unread one.

Example:
Inbox(1)

If it is activated, the bottom Information Line says:
Unread:1 Total:0

Comment 1

19 years ago
This is a dup of one of putterman's bugs.

pimenbru: need more information - what build are you using?  Do you have
reproducible steps to get into this state?

Assignee: dcone → putterman
Component: Printing → Front End
QA Contact: lchiang → fenella

Comment 2

18 years ago
From pimenbru@zhwin.ch via email:

The build ID I'm using: 2000022916
Mozilla M14: (navigator.userAgent=)
Mozilla/5.0 (X11; N; Linux 2.2.14 i586; en-US) Mozilla/m13

Now to the problem:

I've activated my email-account
("Heimadresse") and pressed the 'get message' button. The mails were not
downloaded completly, because I stopped the download (Stop-Button). Since
then the Unread-Indicator shows +1 to much. If I get new mails, the
Unread and the Total - indicator gets increased. It seems like there is a
non-existing unreaded mail in the "INBOX"-Folder (which can't be deleted,
because it isn't there)

PS: I'm using two POP-accounts, and the problem is on both Inbox-folders!

Comment 3

18 years ago
We have another bug where if you stop a POP download and choose get messages 
again, the messages will downloaded twice.  I'm wondering if this is what you 
are seeing. http://bugzilla.mozilla.org/show_bug.cgi?id=26770

Can you try a more recent nightly build?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

18 years ago
from pimenbru via email:

-> good thought!
It is possibly the same bug: I just realized I have stopped the download once
and tried to resume it. Later I saw the result of the bug. 

Would still like for you to try a later build.  I think we can mark a dup of the 
bug I mentioned earlier?

Comment 5

18 years ago
reassigning to bienvenu.
Assignee: putterman → bienvenu
(Assignee)

Comment 6

18 years ago
accepting to shut bugsplat up - not going to be able to work on them until I'm 
better.
Status: NEW → ASSIGNED

Comment 7

18 years ago
Is this actually a dup of 26770?

Comment 8

18 years ago
*** Bug 36194 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
moving to M18.  If this is something that's easily reproduceable then perhaps we
should nominate for beta2.  If it's something that we can't reproduce then we
should move this to M20.
Target Milestone: --- → M18

Comment 10

18 years ago
Bruce - are you still seeing this problem?  

Comment 11

18 years ago
Per Bruce via email: "Since I am using M16, I haven't seen it yet"

mark worksforme for now
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 12

18 years ago
.
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
A search for all bugs, all resolutions, with the word "unread" in summary is
quite an interesting tour in bugzilla.

I've been seeing this bug "forever" on linux, currently on 2000-081509.
The only thing i can do to get all marked read is - to mark "All read". The
unread-counter will then reset when i delete a message.
But after only a few more mails and startups of mailnews - the bug is back. 1
mail unread according to counter - and all mails are really read.

This bug is repeatedly being reported - over and over - and being set WFM when
it temporarily goes away for that user. The unread-counter keeps bouncing back
to one more unread messages than there really is, showing "1" when it should
show "0".

Currently it's also reported in unconfirmed bug 48844 on Windows98.
Taking the liberty of reopening this one - something *IS* wrong.

I'm using 2 POP accounts, it's the second account i normally see the bug on but
that's the account i mainly use too.
Status: VERIFIED → REOPENED
Resolution: WORKSFORME → ---

Comment 14

18 years ago
*** Bug 49852 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
49852 reported on Mac system9 2000080712 (M17)

Comment 16

18 years ago
a reliable way to reproduce the bug is to provoke a crash after you have read a
new mail.
At this point, all the mails are read, and the counter also indicates they are
read. But when restarting after the crash, the counter will have gone astray;
indicating one unread message, but  none of the actual messages are indicated as
unread (i.e. none are in bold text)

Following above description, I can provoke this bug to happen 100% reproducable.
Just find your favourite crash-bug and test it.
Another, perhaps unrelated observation: When using "Mark all read" feature, the
counter doesn't actually reset untill you delete a message. Something isn't
quite in synch.

Comment 17

18 years ago
*** Bug 48647 has been marked as a duplicate of this bug. ***

Comment 18

18 years ago
setting OS: All - windows, NT and Mac see this as well.
I saw it latest in yesterdays linux build.
OS: Linux → All

Comment 19

18 years ago
*** Bug 48844 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
*** Bug 51969 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
so what is this now? i don't see any progress... here is what happens on my
win98 but not on my redhat system: messages are NEVER counted as read in the
folder line even though they are marked as read in the message index.
furthermore when i delete a message, the count doesn't change, not even if i
restart my pc =) BUT as soon as i receive new mail, the count first goes up too
high, and then chages to the real value, but still it shows the whole count and
not only the unread messages. also, when i set in unread, the count even grows,
so i can make a "inbox (3)" string with only one message in the folder (or even
a higher value depending on when i received mail the last time). this is all for
pop3 i didn't try yet for imap.
(Assignee)

Comment 22

18 years ago
No one can reproduce this here.

Comment 23

18 years ago
I'm experiencing this bug now on NT 4.0.  I've got 3 unread , total of 215.
There are no unread messages.

I can do a debug build on the machine that is experiencing the problem if that
would help you David.

Comment 24

18 years ago
This happens to me all the time. I can't reproduce it on demand, but it happens
at least once or twice a week for me on NT 4.0sp6a... Marking all messages read
cleans up the unread count. I most often experience the problem after opening a
mail window and clicking on the "get messages" button. After the download
completes, the unread count is higher than it should be.

Comment 25

18 years ago
*** Bug 55521 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
*** Bug 55677 has been marked as a duplicate of this bug. ***

Comment 27

18 years ago
adding mostfreq keyword in an attempt to avoid more dups.
This keeps happening all the time. The unread counter is in reality a
crash-counter. After a crash the counter gets wrong. Indicating the counter
isn't perm saved when mail is read, but only stored in memory for the duration
of a session, and saved to disk first when mozilla is properly quit.
Keywords: mostfreq

Comment 28

18 years ago
modifying that theory: It actually works like a "mail arrived in the previous
session" counter. If inbox displayed 0 read before the crash, it doesn't matter
HOW many mails arrived: Next time mailnews is started the count will be 1

If many new mails now arrive, and are all read, and a new crash occures, the
next time moz is started, unread count on that inbox will be 2.

etc. etc. etc.

Comment 29

18 years ago
appending to summary. I filed a dupe of this bug (still seeing it on 100608)
because when I queried I couldn't find this one, probably because the summary
was a little vague and cryptic (emails: Unread 1 Total 0). I just wouldn't have
searched for that, or recognized it when scanning summaries. Hopefully the
addition will result in less dupes.
Summary: emails: Unread 1 Total 0 → emails: Unread 1 Total 0 - (phantom unread e-mail messages in Inbox)

Comment 30

18 years ago
Happens to me also, frequently, on Win ME and Linux. It did happen in all builds
since Netscape PR3, and still does in 20001028. It's not only EMails, but also
Newsgroups, and it is not always +1, but can be much more (I have 17 phantom
messages in one of my News accounts). I too think this is caused by crashes, but
not always. Something is out of sync.

BTW, after installing 20001028, the bug seems to have changed behaviour a bit.
The counters sometimes reset, it seems the list is being repainted frequently,
but selecting one of the newsgroups or mail folders brings back the old value again.
Also, marking all as read only works after deleting (as said above). Otherwise,
the old value returns again...

Hope this helps.

Comment 31

18 years ago
I'm seeing this bug right now (11/8/00) on M18 Windows2000, user agent:

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001102 Netscape6/6.0

My IMAP Inbox insists that there is (1) unread message, when none is displayed
in the message list for that folder. Use of other mailers indicates that there
are no unreads in this folder.

Incidently, there is a message in the message list for this same folder which is
displayed with an incorrect subject header. Perhaps a message was incorrectly
stored locally, and this discrepancy results in an incorrect unread count?

This condition has been persistent for 2 days now.

Comment 32

18 years ago
nominating for rtm
Whiteboard: rtm

Comment 33

18 years ago
I've noticed that each time mozilla crashes, and i have received new mail (AND
read it) within the same session, mailnews will insist i have an unread message
after i restart.
The message that is "unread" is not marked unread in the inbox, however.
I've also noticed that each time mozilla crashes, and i have recieved mail (AND
read it) within the same session, there are mail-related files scattered around
in the /tmp directory, and they are never cleaned up.

Is it possible that it is these messages the "unread" counter misinterpret after
mailnews is restarted? (Or rather - the most recent of them)

Comment 34

18 years ago
*** Bug 59738 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 35

18 years ago
yes, that's pretty much what's happening - the db/summary file and the local
mailbox are out of sync. It shouldn't happen, but apparently it does. I haven't
seen it myself, but then, I don't crash very often.

Comment 36

18 years ago
*** Bug 58288 has been marked as a duplicate of this bug. ***

Comment 37

18 years ago
*** Bug 60559 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 38

18 years ago
changing priorities
Priority: P3 → P2

Comment 39

18 years ago
I don't know if this is relevant, but there is an easy workaround.
Delete Inbox.msf (in Mail directory). That forces it to be rebuilt when you
restart. Since I did that, I never saw the bug again. Of course this doesn't
address the question of why it happened in the first place. This is on Linux.

Comment 40

18 years ago
When folder contain corrupted message even deleting and recreating of .msf file
don't help.

Detailed description:
I have manually appended to mail folder corrupted message (it contained two
Date: fields and no X-UIDL:, X-Mozilla-Status:, X-Mozilla-Status2: fields).
After deleting .msf file, restaring mozilla and opening folder the message
appears as new.
Reading it makes it read but did not insert missing fields.

And as told in previous comments, crashing renews problem with unread count,
additionally Go/Next/Unread Message is broken, and a lot other things is broken
too...

Comment 41

18 years ago
Created attachment 20092 [details]
The broken message file I used to append to mail folder file and get everything broken
(Assignee)

Comment 42

18 years ago
Myroslav, have you ever seen Mozilla itself attach a corrupted message (i.e.,
one without an x-mozilla-status header)? We do require that header to mark a
message read, and it would be a problem if Mozilla managed to put such a message
in a folder. In 4.x, the folder compaction code would add an x-mozilla-status
header if one was missing, when you compacted a folder. I don't know if that
code was maintained in 6.0 (but I would guess not).

Comment 43

18 years ago
I am not sure that it was mozilla and most likel it was me who did the thing,
but my comment here is because it is likely that corrupted message involves this
"phantom unread message" bug to appear more intensively. After I corrected all
such messages in mail folder files the bug had not appeared for 1 week already.
Maybe this will help.

Comment 44

18 years ago
*** Bug 62241 has been marked as a duplicate of this bug. ***

Comment 45

18 years ago
*** Bug 62854 has been marked as a duplicate of this bug. ***

Comment 46

18 years ago
*** Bug 63041 has been marked as a duplicate of this bug. ***

Comment 47

18 years ago
I tried the workaround to trash Inbox.msf file.  Every time I trash and the .msf
is rebuilt, the number of phantom Unread message decreases by one, and the
exactly the same number of actual messages in the list appear as Unread.
Clicking the message reduces the nnumber of Unread as expected.  However, after
trashing Inbox.msf and restart, the number of Unread returns as "previous-1".
Mtrunk 2000121908 for MacOS.
(This bug seemed to have gone at some point in recent builds, but returned this
week.)

Comment 48

18 years ago
*** Bug 52313 has been marked as a duplicate of this bug. ***

Comment 49

18 years ago
*** Bug 64657 has been marked as a duplicate of this bug. ***

Comment 50

18 years ago
I get the bug consistently.  It happens every time I read a mail as Mozilla is
downloading it.  I get more than 70 messages overnight, so I start reading them
before Mozilla has finished retrieving all the messages.  If I happen to select
a mail that Mozilla is currently retrieving, I get a phantom unread email message.

I am running Mozilla 0.7 on Windows 2000 (Athlon 750, 256 MB RAM).

It seems to pause long enough to finish loading the message, which is fine,
but there is a discontinuity in how unread messages are counted and read
messages are counted.  You know if unread messages + read messages !=
total messages then something is wrong.

If we are counting the mails as they come in with integers, then we have
a design issue to boot--but it could be that the unread message int is
incremented twice and then decremented once.  If we are dealing with two
lists, then we have a reference of the same email in the unread list and
the read list (thus it is being counted twice).  If this information is
being saved to file instead of being read in fresh every time, then we
also have a design issue.

If the mail messages are serialized and marked as read/unread, when we
restart Mozilla and read the messages back in, the problem would correct
itself and not be AS annoying.
(Assignee)

Comment 51

18 years ago
Berin, that's an interesting theory. I'll try to reproduce it.

Comment 52

18 years ago
Looks like it has been fixed in Mac builds sometime after Dec26(which is the
build for Moz0.7).
Now I do not see any phantom number even after crash, and if I produce such
phantom by using Dec 22 build, current build can eliminate it after Compact this
folder. WFM in 2001011104 and a few builds back.

Comment 53

18 years ago
Let me clarify--I get this error on any folders I have separated my mail in.
As I mentioned earlier I get 70+ mails overnight--to maintain sanity I
_have_ to apply filters to the mail and split them into the different projects
I work on.  I get the phantom reads on the folders I created--not on the main
Inbox.

Comment 54

18 years ago
Like Berin, I use a lot of filters. However, I must differ and say the phantom
messages have occasionally shown up in my Inbox as well.

Comment 55

18 years ago
*** Bug 65565 has been marked as a duplicate of this bug. ***

Comment 56

18 years ago
How about changing target milestone to something else than "M18"?

cc:ing self.
(Assignee)

Comment 57

18 years ago
ah, I had this confused with 42361 (i.e., that one showed up on my mozilla .8/.9
query list). They're probably the sme bug, but I'll put this one at 0.9 as well.
Target Milestone: M18 → mozilla0.9

Comment 58

18 years ago
*** Bug 42361 has been marked as a duplicate of this bug. ***

Comment 59

18 years ago
marking nsbeta1+ and moving to mozilla0.9
Keywords: nsbeta1
Priority: P2 → P1
Whiteboard: rtm → [nsbeta1+]
(Assignee)

Comment 60

18 years ago
Well, part of the problem is that the code that reads local messages and marks
them read in the db *does not* commit the db. That's part of the fix. However,
this should leave the db in an invalid state relative to the mail folder and
cause the mail folder to be reparsed next time it's loaded. So the second part
of the fix is to figure out why that's not happening.
(Assignee)

Comment 61

18 years ago
Created attachment 22713 [details] [diff] [review]
proposed fix
(Assignee)

Comment 62

18 years ago
so, I was wrong before - ignore all that. The problem was that we were
committing the db, and then changing the unread counts. This latter change might
or might not get committed, so it could get out of sync. The fix is to change
the unread counts before we commit, so they get committed as well. This fixes
the problem I was able to recreate, which was crashing after reading an unread
message. CC'ing Scott and Seth for code reviews.
Status: REOPENED → ASSIGNED

Comment 64

18 years ago
This is an issue with multiplke mail accounts. I have 4. 1 IMAP and then 3 POP.
The first (IMAP) account is OK. The second account has 1 unread message, the
third has 2, and the fourth has 3! On 2001012008 and win2k. This has been here
forever.
Anyone going to sr this so this could get checked in ?
by the power of greyskull, I have the power

sr=sspitzer
(Assignee)

Comment 67

18 years ago
I checked in my change but I thought there could be other causes of this bug so
I left the bug open. Are you still seeing it?
Verify this fixed on 2001013120 Windows....
(Assignee)

Comment 69

18 years ago
OK, I'll resolve fixed. Please reopen if it happens again (along with info about
what happened).
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 70

18 years ago
David, I use a filter to automatically redirect certain messages to a folder.
When I got new messages, that folder's right column (the amount of messages)
isn't updated.

Is that another bug or in someway related?   Thanks!
(Assignee)

Comment 71

18 years ago
that's a different bug - I assume you're using POP, because I see that on my pop
account too. I don't know if there's a bug open on it, however. I can't seem to
find one in Gayatri's list - I'll open a new one. When you open the filter
destination folder, the counts are updated, right? 
I've opened bug 67556 for this.

Comment 72

18 years ago
Linux (2001-02-06-06 mtrunk)
Win32 (2001-02-06-06 mtrunk)
Mac (2001-02-05-12 mtrunk)
This problem has been fixed.
Status: RESOLVED → VERIFIED

Comment 73

18 years ago
*** Bug 68250 has been marked as a duplicate of this bug. ***

Comment 74

18 years ago
i'm still getting this bug in imap (imap.cs.com) with build 2001-03-05

Comment 75

17 years ago
*** Bug 89369 has been marked as a duplicate of this bug. ***

Comment 76

14 years ago
Note: It is fixed as of Mozilla 1.7 on linux i386

Thanks
Amit
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.