bulky mails disappear after move by drag and drop (corrupted .msf file)

RESOLVED DUPLICATE of bug 355591

Status

Thunderbird
Mail Window Front End
--
major
RESOLVED DUPLICATE of bug 355591
12 years ago
11 years ago

People

(Reporter: mdp, Assigned: Scott MacGregor)

Tracking

x86
Windows XP
Bug Flags:
blocking-thunderbird2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 1.1.4322)
Build Identifier: version 1.6a1 (20060117)

I created a subfolder (say 'sf') in 'sent' folder
I moved 8 mails from 'sent' to 'sf'
'sf' showed 3 present mails (o.c. wrong) but 13 Mb size (correct)
(fyn the three mails are 4kb, 375 kb, 378 kb big)

Before posting I tested:
I moved a 10 Mb mail from 'sent' to 'sf'
- 'total' value and num of displayed mails did not change
- 'size' value correctly increased
I moved a 1 Kb mail from 'sent' to 'sf'
- this was correctly added to the 'total' value and it is displayed

Reproducible: Sometimes

Steps to Reproduce:
1. made subfolder in 'inbox'
2. moved small file, it worked
3. moved big (6 Mb) file, it's there (mbox size increases) but doesn't show

Actual Results:  
(best described above)
Small mails are shown, big mails are not shown

Expected Results:  
(best described above)
(Ceteris paribus) every mail in the mbox file should be shown in the list

I also checked if this bug shows with incoming mails - I correctly received and displayed a 6.3 Mb mail.
I tried to move it in 'sf' and it worked - it is displayed (!) 
I so tried with an old mail again and it is now correctly displayed (!!)
The previous 'hidden' ones are still hidden

Comment 1

11 years ago
Don't know if it is the same bug ...
But ... it could be ...

Thunderbird 2.0b1pre 2006101803

--> mails in Local Folder --> XXX --> YYY (subfolders)
I was, by using drag and drop, moving +/- 30 emails to subfolder
Local Folder --> XXX --> ZZZ --> WWW

These 30 emails contains attachment like jar files, or doc and pdf

But the emails disappears ... only a very few of them was there ...
--> close TB
--> open TB
--> always there

--> compress folder WWW --> no effect
(and no effect on WWW.msf and physical WWW mbox folder)

--> close TB
--> delete WWW.msf
--> open TB
--> and the emails was there ... 


It was the first time i saw that ... and i'm using Branch 1.8.1 for more than 6 months ...

Cannot find an other bug in bugzilla matching a drag and drop disappears of mail a part this one ...

Comment 2

11 years ago
cannot succeed to reproduce it with the same group of mail :-(
Summary: some moved bulky mails disappear → some moved bulky mails disappear (corrupted .msf file)

Comment 3

11 years ago
Confirmed as reported by dipane@unicri.it

So:
1) sending to you a mail with a big attachment (for me: 6.3Mo) ... if your smtp accept it ...
2) receive the mail
3) drag and drop to an other folder 
In my case the mail goes by filter to Local Folder --> XXX --> YYY (subfolders)
and i try to drag and drop to Local Folder --> XXX --> ZZZ

--> the mail doesn't appear ...
--> the mbox file was increased by 8Mo
--> compacting the folder has no effect
--> only way to solve the problem: Close TB and delete the ZZZ.msf file

Some interesting comments:
1) Using right-click--> Move To : no problem
--> the problem comes only with drag and drop
2) Drag and drop to trash --> no problem ...
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

11 years ago
Cannot test on 1.5.0.7 ... so setting version to 2.0
Is somebody can test on 1.5.0.7?
Component: General → Mail Window Front End
Flags: blocking-thunderbird2?
Version: unspecified → 2.0

Updated

11 years ago
Summary: some moved bulky mails disappear (corrupted .msf file) → bulky mails disappear after move by drag and drop (corrupted .msf file)
(Assignee)

Comment 5

11 years ago
we didn't get any traction on this in time for thunderbird 2.
Flags: blocking-thunderbird2? → blocking-thunderbird2-
dup of 355591 ? or connected to it?

Comment 7

11 years ago
yes ... dupe
and new similar bug entered recently: bug 378838
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 355591

Comment 8

11 years ago
bug 355591 is a dup of bug 368112 which is landed on trunk and branch 1.8.1.4
--> verified with test case of comment #3
You need to log in before you can comment on or make changes to this bug.