The default bug view has changed. See this FAQ.

[UI] Create a pref item for Default Display charset for Messenger

VERIFIED FIXED in M17

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: scottputterman)

Tracking

Trunk
x86
Windows 98
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Because of rhp's backend work, Bug 28863, we now have a way to
deal with the default mail viewing charset in the backend.
This bug is filed to create a pref UI item for this. 

mailnews.view_default_charset

applies to any message which lacks the MIME charset info.
This setting will be used unless there is auto-detection
module engaged or a manual menu override has been effected.

A simple UI proposal would be somehting like the following:

Edit | Prefs | Mail & News | Internaitonal | Message View default charset

There should be a combobox list of available charsets to choose from.
Once set, it will apply to all mail/news folders unless a per-folder 
charset is set differently.

Currently, the per folder charset is proposed as a separate
item available from within the folder properties dialog, see 
Bug 32714. 

It may be possible to combine these 2 and place them under the folder
properties dialog. But for now, I propose to keep these 2
separate until implementation begins under way.
(Reporter)

Comment 1

17 years ago
Assignng myself as QA contact.
QA Contact: lchiang → momoi
Target Milestone: ---

Updated

17 years ago
Status: NEW → ASSIGNED

Updated

17 years ago
Keywords: beta2
(Reporter)

Updated

17 years ago
Blocks: 33977

Comment 2

17 years ago
If there are only 2 additional I18N mail specific UI prefs:

 bug 32720 [UI] Create a pref item for Default Display charset for Messenger 
 bug 32802 [UI] create a pref item for Send message default charset 

then I don't think this warrants a new International pref panel.  Instead we
should just add these to the Edit | Prefs | Mail & News | Messages
panel: (1) under "For incoming messages" section and (2) under "For outgoing
messages" section.  Each would look something like:

   Default Character Coding       [dropdown list]

Comment 3

17 years ago
German and mail folks,
  Are you OK with adding this to the Edit | Prefs | Mail & News | Messages
prefs panel?

Comment 4

17 years ago
Assuming UE and mail team will approve, reassigning to nhotta for now.
Assignee: bobj → nhotta
Status: ASSIGNED → NEW
Target Milestone: --- → M16

Comment 5

17 years ago
Accepting, to be added inside "For incoming messages" in Messages pref, I am not 
sure any room is left for new items (if not, the item maynot be seen unless 
resizing the pref dialog).
Status: NEW → ASSIGNED

Comment 6

17 years ago
Created attachment 7317 [details]
screen shot of new pref items

Comment 7

17 years ago
Attached a screen shot of this pref. I am going to check this in if I don't hear 
any objections.
Because of the additional items, I needed to change the default pref window 
size to 550. Any problem of that? With 640 * 480 screen, I cannot see the bottom 
edge of the dialog but I can see both "OK" and "Cancel" buttons at the bottom.

Updated

17 years ago
Blocks: 35851

Comment 8

17 years ago
Checked in the UI with a fixed number of charset list.
Need to change the list of chasets to be dynamic.

Updated

17 years ago
Keywords: nsbeta2

Comment 9

17 years ago
My last check in was removed after the UI re-work.
I move this to M17 and remove nsbeta2 keyword since 32714 enables per folder 
based charset setting UI.
Keywords: beta2, nsbeta2
Target Milestone: M16 → M17

Comment 10

17 years ago
Are you cutting this or expecting to do this features after 5/16 and still 
getting this into PR2?
Whiteboard: [NEED INFO]

Comment 11

17 years ago
To clarify, mark as WONTFIX. At least not needed for beta2. If later we decide 
this is needed then we can reopen this.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 12

17 years ago
I'm going to re-open this for now. 
jglick@netscape.com has a UI proposal for this in
Bug 32802. I believe the backend work is ready also.
This provides a way to set/reset mail viewing default for 
all folders (existing and ones to be cerated in future). It will be
useful when a useer creates a new profile and would like to 
set a default different than the one set for the locale of the
client. It will aslo allow oyu to reset all folder charset settings.

nhotta, do you want to pass on the UI work to Mail News team?
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

Comment 13

17 years ago
>nhotta, do you want to pass on the UI work to Mail News team?
yes, the JS code to enumerate available charsets has been checked in,
mozilla/mailnews/compose/prefs/resources/content/pref-messages.js

Reassign to selmer, please assign mail/news engineer, contact me for questions, 
thanks.

Momoi san, if this is nsbeta2, please put that.
Assignee: nhotta → selmer
Status: REOPENED → NEW
Whiteboard: [NEED INFO]
(Reporter)

Comment 14

17 years ago
This is needed to complete the UI work proposed in Bug 32802. 

This pref allows the user to set Mail Viewing default properly on a new profile,
or reset the existing folders' charset to the default. 
We anticipate the use of English Mozilla for many different languages
as English becomes more and more the default international language
for business and commerce. This pref allows an easy way for such global
oriented users to easily switch the mail viewing default charset. 

Per folder charset default discussed above should be positioned as an advanced
feature to deal with cases of different charsets in languages
such as Chinese, Russsian , etc. (Useful because these languages use more than
one charsets for mail and news.)

Nominating for nsbeta2 because it is an easy UI implementation for which the proposal
already exists (Bug 32802) and would be a good convenience feature for international users. 
Keywords: nsbeta2

Comment 15

17 years ago
Scott, seems like one of yours.
Assignee: selmer → putterman

Comment 16

17 years ago
*** Bug 39097 has been marked as a duplicate of this bug. ***

Comment 17

17 years ago
Scott, Did you forget to mark this FIXED?
(Assignee)

Comment 18

17 years ago
I've never done anything with this bug yet! :)  Is it fixed?  It looks like
nhotta did all of the work.

Comment 19

17 years ago
No, I did not do that. It was checked in by suresh, r=putterman.
But the menu item needs to change. Currently, it uses the same list as send 
default but the view default menu item should be different. I think the code I 
am writing for folder property dialog can be also used for this.

Comment 20

17 years ago
I think the featue is implemented, so we should close this bug.
File another bug about the getting the correct list.

Comment 21

17 years ago
Putting on [nsbeta2-] radar.  
Whiteboard: [nsbeta2-]
(Reporter)

Comment 22

17 years ago
** Checked with 7/10/2000 Win32, Linux and Mac builds **

The UI for default viewing charset is now in and working
The list is the same as for the send default charset and
that is not optimal. I'll file another bug for it.

Marking it resolved as fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED
(Reporter)

Comment 23

17 years ago
Now it is verified as fixed.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 24

17 years ago
Bug 45218 has been filed to address the exapansion of 
the list.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.