disable Bigger/Smaller Text in about:bookmarks/about:history

RESOLVED FIXED in Camino1.5

Status

Camino Graveyard
Bookmarks
--
minor
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: the Falcon, Assigned: froodian (Ian Leue))

Tracking

({fixed1.8.1})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1

Details

(URL)

Attachments

(1 attachment)

3.15 KB, patch
froodian (Ian Leue)
: review+
Mike Pinkerton (not reading bugmail)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.1) Gecko/20060214 Camino/1.0

After invoking Show All Bookmarks, the menu items Bigger Text, Smaller Text, and Text Encoding remain enabled. Invoking them doesn't seem to do anything. That is, however, until you invoke Hide All Bookmarks. The commands you've invoked turn out to have affected the page you visited just before about:bookmarks.

Reproducible: Always

Steps to Reproduce:
1. Browse to www.caminobrowser.org and note the text size.
2. Bookmarks > Show All Bookmarks
3. View > Bigger Text | Smaller Text (or pick a different text encoding from View > Text Encoding).
4. Bookmarks > Hide All Bookmarks
Actual Results:  
The size of the text in the bookmarks manager did not change, but the text on www.caminobrowser.org did.

Expected Results:  
The text size in about:bookmarks should have changed when using Bigger/Smaller Text. View > Text Encoding should probably be disabled altogether in bookmarks view.

Comment 1

11 years ago
I agree with the reporter on all but one thing: we should probably be disabling the text-size adjustments too, since we're trying to make the bookmarks manager as akin to a Finder list view as possible.

I swear we've talked about some other stuff we need to disable (menu items) when in the manager before, but I can't seem to find it at the moment.

cl
Chris, you're prolly thinking of bug 288814, or bug 309132 and bug 316835.  It's not any of those, but like the latter two, it prolly deserves its own bug.

For all three of these, we need to disable the toolbar buttons and the menu items.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish
Summary: Bigger/Smaller Text in about:bookmarks has unexpected results. → disable Bigger/Smaller Text in about:bookmarks/about:history
Target Milestone: --- → Camino1.1
Blocks: 316835
Blocks: 341853
No longer blocks: 316835
(Assignee)

Comment 3

11 years ago
Created attachment 225975 [details] [diff] [review]
Patch

Disables toolbar buttons and menu items.
Assignee: mikepinkerton → stridey
Status: NEW → ASSIGNED
Attachment #225975 - Flags: review?(hwaara)

Comment 4

11 years ago
Comment on attachment 225975 [details] [diff] [review]
Patch

Does this control the toolbar buttons as well?
(Assignee)

Comment 5

11 years ago
(In reply to comment #4)
> (From update of attachment 225975 [details] [diff] [review] [edit])
> Does this control the toolbar buttons as well?
> 

Yup.  The BWC section is in - (BOOL)validateToolbarItem:(NSToolbarItem *)theItem
(Assignee)

Comment 6

11 years ago
Comment on attachment 225975 [details] [diff] [review]
Patch

r=hwaara per IRC
Attachment #225975 - Flags: superreview?(sfraser_bugs)
Attachment #225975 - Flags: review?(hwaara)
Attachment #225975 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #225975 - Flags: superreview?(sfraser_bugs) → superreview?(mikepinkerton)
Comment on attachment 225975 [details] [diff] [review]
Patch

sr=pink
Attachment #225975 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Updated

11 years ago
Whiteboard: [needs checkin]

Comment 8

11 years ago
Fixed trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: polish → fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [needs checkin]
You need to log in before you can comment on or make changes to this bug.