Closed Bug 332972 Opened 14 years ago Closed 10 years ago

Sharing profile between trunk and branch causes C++ runtime error R6034

Categories

(Firefox :: General, defect, critical)

x86
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: marinebio72, Unassigned)

References

Details

(Keywords: crash)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

run time error R6034 "An application has made an attempt to load the C runtime library incorrectly."  After installing Deer Park Alpha 2 latest build, opening deer park, closing it, and opening firefox will throw a runtime error every time.  Not sure if it matters, firefox is set to default browser, click no when opening deer park alpha.  a screen shot of the thrown error is included.

Reproducible: Always

Steps to Reproduce:
1.Run Deer Park Alpha 2
2.Do not set to default, close program.
3.Open firefox.exe.

Actual Results:  
Throws runtime error R6034 every time

Expected Results:  
opened normally

using theme nautipolis for firefox 1.5.0.3. havent had a chance to test yet with default theme.
Summary: Firefox throws a runtime error R6034 → Firefox throws a runtime error R6034 after installing deer park alpha 2 and loading firefox
checked theme dependence.  throws same runtime error on default theme.
that is definitely not the same bug, from the description.
(In reply to comment #0)
> After installing Deer Park Alpha 2 latest build, opening
> deer park, closing it, and opening firefox will throw a runtime error every
> time.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060406 Firefox/1.6a1
WFM
*** Bug 333370 has been marked as a duplicate of this bug. ***
I bet this is because if you share a profile, some of the registered components are from the trunk build, which means they need the VC8 runtime library.  I don't know that this is really valid.  You shouldn't be sharing a profile between trunk and branch.  Given the Places changes, you won't be able to share a profile this way anyway.
Summary: Firefox throws a runtime error R6034 after installing deer park alpha 2 and loading firefox → Sharing profile between trunk and branch causes C runtime error R6034
Once you launch trunk, even Fx 1.5 (or whatever versions of Fx on your system) may use nssckbi.dll in trunk directory. This will cause R6034 because Fx 1.5 has no manifest to use msvcr8.
Workaround: rename nssckbi.dll in your trunk installation.
Depends on: 176501
*** Bug 334342 has been marked as a duplicate of this bug. ***
Got this error on Bon Echo Beta1 when I had Minefield installed also. The workaround fixed it
*** Bug 358491 has been marked as a duplicate of this bug. ***
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
Summary: Sharing profile between trunk and branch causes C runtime error R6034 → Sharing profile between trunk and branch causes C++ runtime error R6034
Version: unspecified → Trunk
*** Bug 335400 has been marked as a duplicate of this bug. ***
*** Bug 361291 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 366719
Shortly after midnight on 2009-01-08 I upgraded Sandboxie from version 3.32 to 3.34.  Whether that has had any bearing on the Firefox 3.0.5 runtime error which was generated subsequently, I would not know, but perhaps you need to know.  I have been running Firefox 3.0.5 in a "sandbox" created by Sandboxie for about the past ten days, without any software errors arising from doing that.  After installing the upgrade, I eventually went online with Firefox. I was in the process of downloading a podcast transcript (text file) from the Security Now!  page on the Gibson Research Corporation website (http://www.grc.com/securitynow.htm) when the Microsoft Visual C++ Runtime Library output Runtime Error R6034.  The message text is on the screenshot.
Given the cluster of dups, and the fact that I haven't hit this going between 3.7a1 and 3.5 (skipping a branch!), I'm guessing this is WFM.

Comment 15 sounds like a different bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.