"Manage Search Engines..." in Search dropdown still has stale/incorrectly positioned tooltip

RESOLVED FIXED in Firefox 3 beta3

Status

()

defect
--
trivial
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: aja+bugzilla, Assigned: wladow)

Tracking

({fixed1.8.1, polish})

Trunk
Firefox 3 beta3
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060501 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060501 Minefield/3.0a1

After bug 311653, the "Manage Search Engines..." action in the Search dropdown still has a stale tooltip.

Reproducible: Always

Steps to Reproduce:
1. Activate Search dropdown
2. Select "Manage Search Engines..."
3. Notice the tooltip

Actual Results:  
stale tooltip (e.g. "Search Google") located top/left

Expected Results:  
Tooltip with text "Manage Search Engines..." near the selected action
Flags: blocking-firefox2?
Keywords: polish
Depends on: 313673, 317107
Severity: normal → trivial
No longer depends on: 317107
Flags: blocking-firefox2?
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060502 Minefield/3.0a1 ID:2006050207 [cairo]

confirmed
Status: UNCONFIRMED → NEW
Ever confirmed: true
I see this in the new search box drop down.

You can put your mouse over any of the search dropdown menu engine options and it does this.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060505 BonEcho/2.0a1 ID:2006050602
Was this fixed with Bug 311653?
no(In reply to comment #3)
> Was this fixed with Bug 311653?

no
Blocks: 335435
Depends on: 337169
No longer depends on: 313673
Flags: blocking-firefox2?
(In reply to comment #4)
> no(In reply to comment #3)
> > Was this fixed with Bug 311653?
> no

But it was "fixed" on the branch with that bug's 1.8 branch patch (which removed all tooltips), so this shouldn't be an issue on the branch.
Flags: blocking-firefox2?
Version: unspecified → Trunk
*** Bug 361258 has been marked as a duplicate of this bug. ***
Summary: "Manage Search Engines..." in Search dropdown still has stale tooltip → "Manage Search Engines..." in Search dropdown still has stale/incorrectly positioned tooltip
Works for me with latest trunk linux build.
Is this fixed?

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a8pre) Gecko/2007091519 Minefield/3.0a8pre
I can still reproduce in the latest Windows nightly.
Does not work for me on Linux. Tooltip says "Search using Google" for "Manage Search Engines...".

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2)
Gecko/2007121016 Firefox/3.0b2
Jason, could you file a new bug, with steps to reproduce? Might be worth trying a newer build first.
(In reply to comment #10)
> Jason, could you file a new bug, with steps to reproduce? Might be worth trying
> a newer build first.
> 
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3pre) Gecko/2008011008 Minefield/3.0b3pre ID:2008011008

repro:
open FF
Click on the [G] in the searchbar
hover over [Manage Search Engines]

result:
tooltip: Search using Google



Oh, right, that's this bug. Sorry for saying "file a new bug", I thought this bug was resolved for some reason.
Depends on: 374288
No longer depends on: 337169
Posted patch simple hack (obsolete) — Splinter Review
Very simple hack - sets empty tooltiptext for this menuitem
Attachment #299439 - Flags: review?(gavin.sharp)
Comment on attachment 299439 [details] [diff] [review]
simple hack

Hmm, good idea! :)

Can you put a comment explaining why we're using a blank tooltip here? Just a "<!-- XXX See bug 336231 -->" should do.
Attachment #299439 - Flags: review?(gavin.sharp) → review+
Posted patch patch for checkin (obsolete) — Splinter Review
Assignee: nobody → valastiak
Status: NEW → ASSIGNED
Attachment #299439 - Flags: approval1.9?
Target Milestone: --- → Firefox 3 M11
Attachment #299536 - Flags: approval1.9+
Attachment #299439 - Flags: approval1.9?
Attachment #299439 - Attachment is obsolete: true
Checking in browser/components/search/content/search.xml;
/cvsroot/mozilla/browser/components/search/content/search.xml,v  <--  search.xml
new revision: 1.117; previous revision: 1.116
done
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
I backed this out due to the following test failure in the browser mochitests:

FAIL - Exception thrown - TypeError: items[i].getAttribute is not a function -
chrome://mochikit/content/browser/browser/components/search/test/browser_405664.js

Looks like adding the comment isn't such a great idea, since it introduces a comment node!  I'd think maybe you want a node type check in that loop?  Or a comment using the XUL preprocessor?  Or some other type of check in the loop?  I'm sure a browser peer would know which is the best style to fix.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Ugh, that sucks. I'll just change it to use a preprocessor comment, having the comment in the processed source isn't all that important, and not worth adding runtime checks for this kind of thing.
Posted patch fixed patchSplinter Review
Attachment #299536 - Attachment is obsolete: true
Attachment #300062 - Flags: review+
mozilla/browser/components/search/content/search.xml 	1.119

Filed bug 414642 on removing this workaround once bug 374288 is fixed.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
No longer depends on: 374288
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.