[sidebar] bookmarks should have the look and feel of links

VERIFIED DUPLICATE of bug 76420

Status

--
enhancement
VERIFIED DUPLICATE of bug 76420
18 years ago
14 years ago

People

(Reporter: tim.taylor, Assigned: bugs)

Tracking

({meta})

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This is a meta-enhancement to provide context to several individual enhancements
related to  making bookmarks look and behave like regular links.  I've tried to
locate and reference existing bugs that are related.  Where I didn't find an
existing bug, I created one.  The closest dupe I could find is this comment by
Matthew Thomas in bug 47315:

"IMO, bookmarks should have the same behavior as normal links --  dragging them
should do the same as for links, right-clicking on them should give the same
context menu as is shown for a link in a Web page ... and hovering over them
should show their URL in the status bar"

But I never found corresponding bugs by Matthew for these suggestions.  So here
they are...

To have a look and feel like links, bookmarks should:

* be decorated like links (bug 85367)
* open with a single click (works in sidebar, doesn't in manager (bug 85369))
* open in new window when middle-clicked (bug 33761)
* include link context menu items when right-clicked (bug 85374, bug 54678)
* drag and drop like links (done. Listed here for completeness)
* mouseover should display URL in statusbar (bug 64892)

Currently this enhancement applies to the bookmark editor and the bookmark tab
in the Sidebar. Ideally, it would apply to all link-like things including the
history tab/viewer and search results in the search tab.  The one exception
would be when a bookmark is displayed as a menu item (Bookmarks menu, Personal
Toolbar), in which case it should have the look and feel of a menu item. 
Consistency with the menu UI outweighs consistency with link UI. 
 
Lastly, apologies if I did a Bad Thing(TM) by creating this and the related
bugs.  Seemed like the only way to obey the "one request per bug" rule while
providing context to justify all the individual enhancements.
(Reporter)

Updated

18 years ago
Depends on: 33761, 64892, 85367, 85369, 85374
ccing mpt.  Status -> new.  Seems like a decent idea to me, except for one thing
-- when managing bookmarks it's nice to be able to select multiple bookmarks and
move/delete them all at once.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: bookmarks should have the look and feel of links → [meta] bookmarks should have the look and feel of links
(Reporter)

Comment 2

18 years ago
Seems that treating bookmarks like links uniformly across the entire application
doesn't have support (bug 85369).  I'd settle for all bookmarks,  bookmark-like,
or link-like things in the sidebar having the look and feel of links consistently.
(Reporter)

Updated

18 years ago
Depends on: 76420

Comment 3

18 years ago
> I'd settle for all bookmarks, bookmark-like,
And i'd settle for NOT doing this.
> or link-like things in the sidebar having the look and feel of links 
consistently. 

Iff single click activates an object just like a link is activated then it 
should look like a link. If single click merely selects then it should not look 
like a link.

I'm adding these comments because other items including history might be 
clickable and manageable or someone might make a bookmarks manager sidebar.
Keywords: meta
Summary: [meta] bookmarks should have the look and feel of links → [sidebar] bookmarks should have the look and feel of links

Comment 4

18 years ago

*** This bug has been marked as a duplicate of 76420 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED

Updated

17 years ago
No longer depends on: 33761
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.