Closed Bug 338074 Opened 15 years ago Closed 8 years ago

SpellCheck dictionaries should have their own place in the Add-ons manager

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 591780

People

(Reporter: Peter6, Assigned: jboriss)

References

Details

If spellchecking is to be a big deal for 2.0 ... and/or later, there should be some UI where to add / remove the dictionaries. (rightclick contextmenu is not that great)

(similar to Bug 335781)
Summary: SpellCheck dictionaries should have their own place in the addons manager → SpellCheck dictionaries should have their own place in the Add-ons manager
*** Bug 340836 has been marked as a duplicate of this bug. ***
Flags: blocking1.9a2?
If they are packaged as extensions they will just be listed with extensions. If ui is needed to support dictionaries that aren't packaged as an extension this will probably entail doing something similar to the pref panels and allowing app's define additional panes along with the code to manage the pane, etc.
*** Bug 347139 has been marked as a duplicate of this bug. ***
In FF2.0 RC2 the dictionaries are listed in the add-ons manager as extensions. This is workable, but it would be better if the dictionaries have a separate "tab" in the add-ons manager.
Flags: blocking1.9a2?
They do now in current trunk build and will in the Firefox 3.0 release. Resolving WFM
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
reopening - dictionaries that are not managed by the EM are not displayed.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Flags: blocking-firefox3.6?
--> toolkit::add ons manager

Not blocking, but Mossop might have some ideas in the general EM API reworking. He might also have some guidance here in case someone else wants to pick this up.
Component: General → Add-ons Manager
Flags: blocking-firefox3.6?
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Duplicate of this bug: 574680
Spelling dictionaries are (at the moment) regarded as just plain extensions, aren't they? Setting severity to "enhancement".

I don't expect this, if fixed someday, to be ported to the 1.9.2-and-earlier addons manager: setting Version to Trunk.

Not sure whether this is wanted, Future, or WONTFIX.
Severity: normal → enhancement
Version: unspecified → Trunk
Status: REOPENED → NEW
IMO dictionaries should not be in the add-ons manager at all, but rather together with downloadable UI languages in Prefs > Content > Languages
Eh no. A language is not the same as a dictionary. You can have multiple dictionaries for a single language. And it's perfectly ok to use let's say a French dictionary in an English text, if you want to spell check an single paragraph or even a word. Plus, the whole point of the add-ons manager is to manage downloadable items. Dictionaries are downloadable, languages are not.
(In reply to comment #11)
> Eh no. A language is not the same as a dictionary. You can have multiple
> dictionaries for a single language. And it's perfectly ok to use let's say a
> French dictionary in an English text, if you want to spell check an single
> paragraph or even a word. Plus, the whole point of the add-ons manager is to
> manage downloadable items. Dictionaries are downloadable, languages are not.

Languages are downloadable as *.langpack.xpi addons all over the place at ftp.mozilla.org, and they appear in the "Language" tab of the addons manager. Like (heavyweight) themes, any number can be installed but only one can be enabled at a time. A language pack modifies the texts of the chrome and of the messages originating in the application, a theme modifies the buttons, colours, etc., even the fonts, let's say anything in the chrome that is not the text of the labels. Dictionaries modify the behaviour of the application when you type something in it (in the *content* of a page, mostly), and any number can be enabled at a time. Like you say, they are just one particular kind of extension.

To remove a dictionary, select it in the addons manager, click "Remove" and restart.

To add a dictionary, go to addons.mozilla.org, select "Dictionaries and La
...nguage Packs" in the sidebar, and click the one you want to install it just like any other extension.
Duplicate of this bug: 564681
Assignee: nobody → jboriss
Keywords: uiwanted
Depends on: 591780
Duplicate of this bug: 795840
Status: NEW → RESOLVED
Closed: 13 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591780
You need to log in before you can comment on or make changes to this bug.