All users were logged out of Bugzilla on October 13th, 2018

Searches in search fields can't be cancelled with Escape

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: camino, Assigned: stuart.morgan+bugzilla)

Tracking

({access, fixed1.8.1.8})

Details

(Reporter)

Description

13 years ago
When you do a web search you should be able to escape from the search
just like you do when clicking on the cancel icon in the search field.
Do other search fields in the OS do this?
Component: General → Accessibility
Keywords: access
QA Contact: general → accessibility
*** Bug 338731 has been marked as a duplicate of this bug. ***
Toolbar search field, Bookmarks Manager search field, Cookies and Cookies Exceptions List search fields all need to be the same here.
Summary: Web search can't be cancelled with Espace or Commad + period. → Searches in search fields can't be cancelled with Escape or Commad + period
(Reporter)

Comment 4

13 years ago
Thank you smokey for cleaning up that mess.

Comment 5

13 years ago
This is going to be closely related to bug 320528. In fact, it's *almost* a dupe of that bug.

cl
Well, that bug is a meta-ish bug on places where one of the two works and not the other.  This bug is about the fact that none of our search fields (or the "Search the Web" sheet that comes up when the toolbar is hidden) have a keyboard-accessible way to cancel a search.

(The OS widget does not appear to, either, at least not in the Metal Finder in 10.3)

So that's 5 different search fields now; see also bug 330666, on which this should perhaps depend?
Depends on: 330666
Summary: Searches in search fields can't be cancelled with Escape or Commad + period → Searches in search fields can't be cancelled with Escape or Command + period

Comment 7

13 years ago
Finder's quick search doesn't cancel on escape. Isn't Cmd-A + backspace good enough?
(Reporter)

Comment 8

13 years ago
In Mail/iTunes/Spotlight/Sys Prefs it does work.  just think we should do it because I expect to be able to cancel with Escape in search fields because I can excape with my mouse.
Yeah, those other apps do it and I can see the usefulness. But, besides Spotlight, is there an app that cancels it's search field on cmd-. ? I can't seem to find one. Escape makes sense, but not cmd-.
(Reporter)

Comment 10

13 years ago
Fair enough, command + . is a bit of a stretch.
Summary: Searches in search fields can't be cancelled with Escape or Command + period → Searches in search fields can't be cancelled with Escape
Target Milestone: Camino1.1 → Camino1.2

Comment 11

12 years ago
FWIW, if we decide we don't want this, we can use escape for bug 339322.
Mass un-setting milestone per 1.6 roadmap.

Filter on RemoveRedonkulousBuglist to remove bugspam.

Developers: if you have a patch in hand for one of these bugs, you may pull the bug back to 1.6 *at that point*.
Target Milestone: Camino1.6 → ---
In the Cookies sheets, we want to have Esc close the sheets (bug 364320) like it used to.  

In the search sheet, Esc closes the sheet, not clears the search terms.

I'm not really sure what we want to do with the toolbar search field and Bookmarks Manager search field.  As Ian notes above, if we don't do this, we can use Esc for bug 339322 in those two fields.
(Assignee)

Comment 14

11 years ago
Isn't this fixed with my recent landings? Escape now clears searches everywhere we don't have it doing something different on purpose (like the search sheet)
I'm going to close this FIXED by bug 330666 and bug 357560; it works on for me on 10.5, and presumably Stuart was still on 10.4 in comment 14.

On 10.3, NSSearchField apparently doesn't do anything on Esc; I was unable to get any search field in the OS (Finder, iPhoto, Console) to cancel (or do anything) on Esc.  "Yay", but at this point it's not something major enough for us to do any custom engineering to fix for 10.3.
Assignee: nobody → stuart.morgan
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1.8
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.