Closed Bug 339087 Opened 15 years ago Closed 14 years ago

Sync trunk code with 1.8.0 and 1.8 branches

Categories

(Core Graveyard :: XForms, defect)

1.8 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: allan, Assigned: allan)

References

()

Details

(Keywords: fixed1.8.1)

Attachments

(3 files, 4 obsolete files)

Same trick as for 0.5, bascially just removing SOAP support.

(hmm, I've just done this bug once. Iid I type this into a wrong window the first time, or did bugzilla just swallow my bug....)
Status: NEW → ASSIGNED
Apply this to extensions/xforms (HEAD), and compile it on 1_8_0.
Running through my test suite, crashes ff. Not on the same test case. Just suddenly.

nsProfileLock::FatalSignalHandler(int)+0x0000013B [dist/bin/firefox-bin +0x00024FFF]
__kernel_sigreturn+0x00000000 [ +0x00000420]
nsCOMPtr<nsIContent>::assign_from_qi(nsQueryInterface, nsID const&)+0x00000021 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x002CB129]
nsCOMPtr<nsIContent>::nsCOMPtr(nsQueryInterface)+0x00000031 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x002CB187]
nsCOMPtr<nsIContent>::Assert_NoQueryNeeded()+0x00000046 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x002CB1D6]
nsCOMPtr<nsIContent>::operator=(nsIContent*)+0x00000030 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x002F33D0]
nsDOMEventRTTearoff::LastRelease()+0x00000050 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x005D8218]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x005D835D]
nsCOMPtr<nsIDOMEventTarget>::~nsCOMPtr()+0x00000050 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x003C1456]
nsXMLEventsListener::Unregister()+0x000000D0 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x006470CE]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x0064711B]
nsBaseHashtable<nsISupportsHashKey, nsCOMPtr<nsXMLEventsListener>, nsXMLEventsListener*>::s_EnumStub(PLDHashTable*, PLDHashEntryHdr*, unsigned int, void*)+0x0000004D [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x0064900F]
PL_DHashTableEnumerate+0x00000086 [dist/bin/libxpcom_core.so +0x00076726]
nsBaseHashtable<nsISupportsHashKey, nsCOMPtr<nsXMLEventsListener>, nsXMLEventsListener*>::Enumerate(PLDHashOperator (*)(nsISupports*, nsCOMPtr<nsXMLEventsListener>&, void*), void*)+0x00000070 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x00648C52]
nsXMLEventsManager::DocumentWillBeDestroyed(nsIDocument*)+0x0000003E [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x00646FC8]
nsDocument::~nsDocument()+0x00000228 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x005AD5E8]
nsHTMLDocument::~nsHTMLDocument()+0x000002D0 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x006D7994]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x005A7D54]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x006D4E10]
nsCOMPtr<nsIDOMEventTarget>::~nsCOMPtr()+0x00000050 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x003C1456]
nsDOMEvent::~nsDOMEvent()+0x00000132 [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x0063AC0E]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x00639500]
XPCJSRuntime::GCCallback(JSContext*, JSGCStatus)+0x0000094B [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libxpconnect.so +0x00068821]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x007806F0]
js_GC+0x000013FA [dist/bin/libmozjs.so +0x00052C52]
js_ForceGC+0x0000005D [dist/bin/libmozjs.so +0x0005184B]
JS_GC+0x00000064 [dist/bin/libmozjs.so +0x00017E82]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libgklayout.so +0x00780684]
nsTimerImpl::Fire()+0x00000291 [dist/bin/libxpcom_core.so +0x000FE1FD]
handleTimerEvent(TimerEventType*)+0x0000012E [dist/bin/libxpcom_core.so +0x000FE46A]
PL_HandleEvent+0x00000055 [dist/bin/libxpcom_core.so +0x000F5892]
PL_ProcessPendingEvents+0x000000D3 [dist/bin/libxpcom_core.so +0x000F571E]
UNKNOWN [dist/bin/libxpcom_core.so +0x000F89E1]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libwidget_gtk2.so +0x0003503C]
UNKNOWN [/opt/gnome/lib/libglib-2.0.so.0 +0x000521DF]
g_main_context_dispatch+0x000001FC [/opt/gnome/lib/libglib-2.0.so.0 +0x0002834C]
UNKNOWN [/opt/gnome/lib/libglib-2.0.so.0 +0x0002B7BB]
g_main_loop_run+0x000001B7 [/opt/gnome/lib/libglib-2.0.so.0 +0x0002BAD7]
gtk_main+0x000000C1 [/opt/gnome/lib/libgtk-x11-2.0.so.0 +0x0012E861]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libwidget_gtk2.so +0x00035AD8]
UNKNOWN [/store/mozilla/source/firefox15/mozilla/dist/bin/components/libtoolkitcomps.so +0x0004105D]
UNKNOWN [dist/bin/firefox-bin +0x0000FC77]
UNKNOWN [dist/bin/firefox-bin +0x000084A6]
__libc_start_main+0x000000D0 [/lib/tls/libc.so.6 +0x00014EA0]
Version: Trunk → 1.8 Branch
*** Bug 339084 has been marked as a duplicate of this bug. ***
Attached file Testcase (crasher) (obsolete) —
(In reply to comment #2)
> Running through my test suite, crashes ff. Not on the same test case. Just
> suddenly.

I think I found the testcase. The problem was that it happens on document destruction so there were some delay... load this, exit the page, and wait.
Attached file Testcase (crasher) (obsolete) —
Another crasher, same stack.

Repeat is involved again.
There is some weirdness involved in this. I cannot get the testcases to crash when I load then from bugzilla, but the same testcases loaded through my testsuite (localhost) crashes.
Attached file Testcase (crasher) (obsolete) —
Same stack. And repeat again.
On the bright side: Except for these crashers (which all seems to be related with repeats somehow), we seem to run just fine on 1.8.0
Any event listener on an element (ev:event="...") inside repeat content possibly combined with some JS addEventListener() calls seems to trigger this.
Depends on: 339104
don't forget that we need schema-validation changes, too.  I think there are at least one or two that aren't on the branches.  And didn't you have an xpath change?  I guess that probably can't go in without approval, though, since it isn't our component.
(In reply to comment #10)
> don't forget that we need schema-validation changes, too.  I think there are at
> least one or two that aren't on the branches.

I trust that Doron are on top of that.

> And didn't you have an xpath change?  I guess that probably can't go in without 
> approval, though, since it isn't our component.

Yes, the fix to instance(), but we need approval for that one (bug 338263)
Bug 339104 fixed the crashers, and we seem to be running smooth on 1_8_0 now. Only  problem is bug 332803, which seems to still exist on 1_8_0.
(In reply to comment #10)
> don't forget that we need schema-validation changes, too.  I think there are at
> least one or two that aren't on the branches.  And didn't you have an xpath
> change?  I guess that probably can't go in without approval, though, since it
> isn't our component.
> 

which schema changes?
(In reply to comment #13)
> (In reply to comment #10)
> > don't forget that we need schema-validation changes, too.  I think there are at
> > least one or two that aren't on the branches.  And didn't you have an xpath
> > change?  I guess that probably can't go in without approval, though, since it
> > isn't our component.
> > 
> 
> which schema changes?
> 

bug 338005, bug 326530, and bug 331897 aren't in the branches yet, it doesn't look like.
Attached patch Patch for 1_8_0 (obsolete) — Splinter Review
Here's a complete patch for 1_8_0 extensions/xforms. It includes the patch in bug 338451. So applying this makes xforms fly in 1_8_0 land :)

So basically we just need to land bug 338451, and fix the permission dialog (bug 339284).

Well, and the tree needs to open...
Attached patch Patch for 1_8Splinter Review
Blocks: 339568
(In reply to comment #16)
> Created an attachment (id=223682) [edit]
> Patch for 1_8

Check in on MOZILLA_1_8_BRANCH.
No longer blocks: 339568
Keywords: fixed1.8.1
Attached patch Patch for 1.8.0Splinter Review
Here's the branch that I've just synced 1.8.0 with.
Attachment #223170 - Attachment is obsolete: true
Attachment #223174 - Attachment is obsolete: true
Attachment #223177 - Attachment is obsolete: true
Attachment #223424 - Attachment is obsolete: true
Summary: Sync trunk code with 1.8.0 branch → Sync trunk code with 1.8.0 and 1.8 branches
Both 1_8_0 and 1_8 are up-to-date with trunk now.
can we close this now, or is it waiting on bug 338451 to go to 1.8.1 and 1.8.0 branches?
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.