Closed Bug 340559 Opened 14 years ago Closed 14 years ago

Migrate Sunbird build options from /m/c/sunbird/config/mozconfig to /m/configure.in

Categories

(Calendar :: Internal Components, defect, minor)

defect
Not set
minor

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mattwillis, Assigned: mattwillis)

Details

Attachments

(1 file, 2 obsolete files)

The trend appears to be for apps to put all their build idiosyncracies in configure.in, rather than in a mozconfig file.

bsmedberg verified that this was The Right Thing To Do when we talked about where to disable xpcom/obsolete
Attachment #224588 - Flags: first-review?(benjamin)
Attachment #224588 - Flags: approval-branch-1.8.1?(benjamin)
Comment on attachment 224588 [details] [diff] [review]
rev0 - moves items from mozconfig to their equivalents in configure.in

You shouldn't need MOZ_STORAGE=1, that's the default.

You shouldn't be disabling accessibility.

I don't think you should be NS_DISABLE_LOGGING either.
Attachment #224588 - Flags: first-review?(benjamin)
Attachment #224588 - Flags: first-review-
Attachment #224588 - Flags: approval-branch-1.8.1?(benjamin)
Attachment #224588 - Attachment is obsolete: true
Attachment #224886 - Flags: first-review?(benjamin)
Attachment #224886 - Flags: approval-branch-1.8.1?(benjamin)
Attachment #224886 - Flags: first-review?(benjamin)
Attachment #224886 - Flags: first-review+
Attachment #224886 - Flags: approval-branch-1.8.1?(benjamin)
Attachment #224886 - Flags: approval-branch-1.8.1+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
After check in of this patch it seems to me that the Sunbird build is now done with enabled installer by default. On trunk and branch I run into Bug 341403 when building on Windows (--enable-installer is not set). I have to add --disable-installer to my mozconfig to make the build finish. (This is also done on solaria tinderbox mozconfig).

I think the reason is that MOZ_INSTALLER will be always set to 1:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/configure.in&rev=1.1689&mark=5675#5670
(In reply to comment #5)
> I think the reason is that MOZ_INSTALLER will be always set to 1:

Crap. That's a regression from the Universal Binaries bug.

Once the tree opens again I'll fix it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #225592 - Flags: first-review?(jminta)
FYI, --disable-accessibility  is needed for MinGW/cygwin builds.
(In reply to comment #8)
> FYI, --disable-accessibility is needed for MinGW/cygwin builds.

Is this true across all apps?

If so, the Right Fix would be to add mingw to the list at
http://lxr.mozilla.org/mozilla/source/configure.in#4073

Is there a bug already filed about this?
Comment on attachment 225592 [details] [diff] [review]
workaround to fix regression while tree is closed

tree is open, and I don't think this is the correct way to fix this anyway
Attachment #225592 - Attachment is obsolete: true
Attachment #225592 - Flags: first-review?(jminta)
(In reply to comment #6)
> (In reply to comment #5)
> > I think the reason is that MOZ_INSTALLER will be always set to 1:
> 
> Crap. That's a regression from the Universal Binaries bug.

Upon further review, I retract that statement. I thought I had left MOZ_INSTALLER=1 in the patch, but I had indeed not.

If you look at the "minimal" case at
http://lxr.mozilla.org/mozilla/source/configure.in#4183
you'll see "MOZ_INSTALLER="

I really think defining it as empty should work. I'll get a Linux build rolling before bed to test this. If nothing else, I'll ask bsmedberg what's going on here.

Sorry.
(In reply to comment #9)
> (In reply to comment #8)
> > FYI, --disable-accessibility is needed for MinGW/cygwin builds.
> 
> Is this true across all apps?
> 
> If so, the Right Fix would be to add mingw to the list at
> http://lxr.mozilla.org/mozilla/source/configure.in#4073
> 
> Is there a bug already filed about this?
> 

It's been a long time (prior to Firefox) since I've looked into this. May be best to check with cls. However, I do have disable-accessibility on all my MinGW builds.
(In reply to comment #12)
> > If so, the Right Fix would be to add mingw to the list at
> > http://lxr.mozilla.org/mozilla/source/configure.in#4073
> > 
> > Is there a bug already filed about this?

There is now: bug 341965
Closing this bug as Windows builds should finish successfully since we have the NSIS installer. The fact that MOZ_INSTALLER is always 1 is a separate issue.

-> FIXED (still)
Status: REOPENED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.