Closed Bug 345322 Opened 14 years ago Closed 4 years ago

enhancement: hot keys to run filters, junk mail controls

Categories

(Thunderbird :: Mail Window Front End, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: btomhave1, Unassigned)

References

(Blocks 2 open bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Under the Tools menu, please add hot keys to run message filters and junk mail controls on a folder.  Local Folders do not automatically run message filters or junk mail controls.  Point-n-click to run these is too cumbersome.

Reproducible: Always

Steps to Reproduce:
1. Use message filters to move all new mail into Local Folders.
2. Local Folders message filters, junk mail controls are not executed.
3. Manually run message filters, junk mail controls.




This is an enhancement request, though it could be taken as a bug report if message filters and junk mail controls are supposed to run automatically when mail enters Local Folders.
Assignee: mscott → nobody
Blocks: junktracker
Can somebody test comment 0?

When messages are moved into Local Folders by filters, should Local Folders' message & junk filters run automatically? (suppose yes) Do they?

With that checked, I'd be happy to close this wontfix or duplicate of that core bug which allows users to set their own keyboard shortcuts...
Flags: needinfo?
Keywords: qawanted
Whiteboard: [testme, otherwise wontfix or dupe]
Flags: needinfo?
Keywords: qawanted
Whiteboard: [testme, otherwise wontfix or dupe] → [testme, otherwise wontfix or dupeme]
(In reply to Thomas D. (currently busy elsewhere; needinfo?me) from comment #1)
> Can somebody test comment 0?
> 
> When messages are moved into Local Folders by filters, should Local Folders'
> message & junk filters run automatically? (suppose yes)

I'm not sure whether "should" is relevant. But I think the answer is no.
 
> Do they?

non-inbox - no
 
> With that checked, I'd be happy to close this wontfix or duplicate of that
> core bug which allows users to set their own keyboard shortcuts...

I breifly looked at bug 57805 and I'm not sure we, Thunderbird, should be held hostage to whether core does not fix this - which they have NOT for over a decade.

Does this answer your question?
Flags: needinfo?(bugzilla2007)
Whiteboard: [testme, otherwise wontfix or dupeme]
(In reply to Wayne Mery (:wsmwk, use Needinfo for questions) from comment #2)
> (In reply to Thomas D. (currently busy elsewhere; needinfo?me) from comment
> #1)
> > Can somebody test comment 0?
> > 
> > When messages are moved into Local Folders by filters, should Local Folders'
> > message & junk filters run automatically? (suppose yes)
> 
> I'm not sure whether "should" is relevant.

? should they run = would we / the user expect filters to run when mail enters a local folder (more so when such mail enters there automatically, moved by other filters.

> But I think the answer is no.

Why? What's the point of having filters on local folders if they would never run automatically?
just asking, I don't have strong opinion nor time or interest in this.

> > Do they?
> 
> non-inbox - no

thanks for checking

> > With that checked, I'd be happy to close this wontfix or duplicate of that
> > core bug which allows users to set their own keyboard shortcuts...
> 
> I breifly looked at bug 57805 and I'm not sure we, Thunderbird, should be
> held hostage to whether core does not fix this - which they have NOT for
> over a decade.

+1.

> Does this answer your question?

I'm not sure about this bug either way, but thanks for reply.
Flags: needinfo?(bugzilla2007)
So the reporter has two requests here 
1. to cascade filter operations (I think there's a bug for that)
2. add hot keys (which is the summary of this bug)

I sympathize with the statement of "Point-n-click to run these is too cumbersome."  But the solution is the access key sequence Alt+T+<something> which makes these dead easy to access without a mouse. And much harder for a user to footgun.  And I wouldn't ever want to see these as hotkeys for myself or the majority of users - no doubt the result would be support requests and complaints about lost messages.

Plus no one has asked for this in 10 years except the reporter. The bar has in the past been very high for adding short cuts, and this doesn't meet the criteria we've used in the past. So I'm going to say we wouldn't accept a patch for this even if it were offered.
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.