Status

()

Core
Layout: Tables
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: Bernd, Assigned: Bernd)

Tracking

(Blocks: 1 bug, {fixed1.8.0.7, fixed1.8.1})

1.8 Branch
x86
Windows XP
fixed1.8.0.7, fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8.0.7 +
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sg:critical?][need testcase])

Attachments

(1 attachment)

(Assignee)

Description

11 years ago
I fixed a couple of bugs blocking bug 339128 on trunk. IMHO the patches should be ported to 1.8.1. I don't see any point in cherry picking the patches all of them lead to crashes. I will do the patch today or tomorrow so that it can be pushed towards branches.
(Assignee)

Updated

11 years ago
Blocks: 339128
(Assignee)

Updated

11 years ago
Depends on: 339130, 342559
(Assignee)

Updated

11 years ago
Depends on: 339246
(Assignee)

Updated

11 years ago
Depends on: 343588
(Assignee)

Updated

11 years ago
Depends on: 344000
(Assignee)

Updated

11 years ago
Depends on: 343087
(Assignee)

Updated

11 years ago
Depends on: 343778
(Assignee)

Comment 1

11 years ago
Created attachment 232193 [details] [diff] [review]
patch against MOZILLA_1_8_BRANCH

this is the promised patch which I think should go on 1.8.1 and probably also on 1.8.0.7
Attachment #232193 - Flags: approval1.8.1?
(Assignee)

Comment 2

11 years ago
Boris could you have an eye on this while I am away (till 2006-08-21)

Comment 3

11 years ago
Bernd/Bz how long has this been on trunk?  Any risk for the branch?

Comment 4

11 years ago
Variable amounts, from "as of this morning" for bug 343087 to "at least a month" for some of the other bugs.  There is probably some risk, but I'm not quite sure how much; the exact regression tracking and whatnot has been happening in the bugs this one depends on...

I do think we should let things bake on trunk for a few days before doing anything with branch, but the most recent change also looked reasonably safe to me, at least as this code goes.  
(Assignee)

Comment 5

11 years ago
One has to weight the risk. This will/should fix also the  other branch blocking bugs that block bug 339128 and do not have a patch till now. With the patches I can't reproduce them.

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=nsTableFrame.cpp&branch=&root=/cvsroot&subdir=mozilla/layout/tables&command=DIFF_FRAMESET&rev1=3.650&rev2=3.651

is not included in the patch but should be applied otherwise VC6 will complain.

A good way to estimate the risk would be to ask Jesse to run the tests from bug 339128 and see whether he sees regressions.

Comment 6

11 years ago
Comment on attachment 232193 [details] [diff] [review]
patch against MOZILLA_1_8_BRANCH

a=schrep for drivers.
Attachment #232193 - Flags: approval1.8.1? → approval1.8.1+

Updated

11 years ago
Blocks: 347796

Updated

11 years ago
No longer blocks: 347796
Depends on: 347796

Updated

11 years ago
Depends on: 347725

Comment 7

11 years ago
I had to edit the diff to remove the fixes for bug 339315 and bug 302911, which had already landed on the branch.  With those removed, this applied cleanly and all.  Checked in on 1.8 branch.
Assignee: nobody → bernd_mozilla
Keywords: fixed1.8.1

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Version: Trunk → 1.8 Branch
sayrer just landed a bustage fix for these changes -- for for loop scoping on Windows.
(Assignee)

Comment 9

11 years ago
Comment on attachment 232193 [details] [diff] [review]
patch against MOZILLA_1_8_BRANCH

I guess this should go on the 1.8.0 branch but I did not get enough baking on trunk, I fixed only today one of the regressions
Attachment #232193 - Flags: approval1.8.0.8?
Flags: blocking1.8.0.8?
Group: security
Whiteboard: [sg:critical?]
(Assignee)

Comment 10

11 years ago
Comment on attachment 232193 [details] [diff] [review]
patch against MOZILLA_1_8_BRANCH

I had some discussion with dveditz, where I was more conservative with taking this onto 1.8.0.7. My main concern was that I did not do enough testing and together with still visible asserts. From a stability point of view this patch highly desirable especially when combined with the patch in bug 350081 and the regression fix ofr bug 347796. Just in case that the 1.8.0.7 release will slip asking for inclusion into 1.8.0.7. If I missed the boat this is definetly 1.8.0.8 material.
Attachment #232193 - Flags: approval1.8.0.7?
Flags: blocking1.8.0.8? → blocking1.8.0.7+
Comment on attachment 232193 [details] [diff] [review]
patch against MOZILLA_1_8_BRANCH

approved for 1.8.0 branch, a=dveditz for drivers

We're slipping to tomorrow, please land today.
Attachment #232193 - Flags: approval1.8.0.8?
Attachment #232193 - Flags: approval1.8.0.7?
Attachment #232193 - Flags: approval1.8.0.7+
(Assignee)

Updated

11 years ago
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.0.7
(Assignee)

Updated

11 years ago
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

11 years ago
Status: REOPENED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Whiteboard: [sg:critical?] → [sg:critical?][need testcase]
(Assignee)

Comment 12

11 years ago
re [need testcase] 
Jay, you will not get a testcase, this bug accumulated the patches from the dependent bugs into one single patch as they partially superseded each other. The testcases are in the dependent bugs, this bug is verified once all dependent bugs are verified.
Group: security
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.