Wrong placement of tab drop indicator in RTL locales

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: zwnj, Unassigned)

Tracking

({rtl})

2.0 Branch
Firefox 2
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

12 years ago
Place of marker is wrong for the first place.
(Reporter)

Comment 1

12 years ago
Created attachment 232311 [details]
Screenshot
benham, which build are you using?
Summary: Wrong placement marker in RTL locales → Wrong placement of tab drop indicator in RTL locales
(Reporter)

Comment 3

12 years ago
I use a GTK build from CVS (about 4 days ago) with pango enabled.

Configure arguments
--enable-application=browser --prefix=/home/behnam/opt/mozilla/firefox-2.0-fa --enable-pango 

Comment 4

12 years ago
I see this as well in 1.5.0.5, plus when you close a tab Firefox automatically opens the next tab instead of the previous tab, as it does in LTR locales (in other words, it opens the tab to the left, as it does in LTR, although it should open the tab to the right)

Comment 5

12 years ago
I'm sorry, I was wrong. I have not problems with the tab drop indicator. I do have another problem that is visible in your screenshots - the tab isn't flipped horizontally as it should be - i.e. the straight edge is on the left while the curved one in on the right.
(Reporter)

Comment 6

12 years ago
The problem do exist yet.
Blocks: 347504

Comment 7

12 years ago
If the marker is placed wrong, it makes tab drag and drop much harder to use in RTL locales.  Nominating for driver consideration.
Flags: blocking-firefox2?
Target Milestone: --- → Firefox 2
unable to reproduce, Mano says this looks fine.

unsure if pango might affect it, but unless someone can reproduce in a stock build, there's no way we're blocking on this.
Flags: blocking-firefox2? → blocking-firefox2-
(Reporter)

Comment 9

12 years ago
Created attachment 238176 [details]
Wrong Marker (Updated Screenshot)
Attachment #232311 - Attachment is obsolete: true
(Reporter)

Comment 10

12 years ago
Created attachment 238178 [details]
Right position on the left end

As you can see, the marker for the left end is all right.
(Reporter)

Comment 11

12 years ago
These are screenshot of today's nightly build of tbox.
(Reporter)

Updated

12 years ago
No longer blocks: 347504
(Reporter)

Updated

12 years ago
Blocks: 349207

Updated

11 years ago
Blocks: 412273

Updated

10 years ago
Blocks: 415597

Updated

10 years ago
No longer blocks: 412273

Comment 12

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
(Reporter)

Updated

10 years ago
Blocks: 412273

Comment 13

9 years ago
This has been fixed on trunk.  Resolving as WFM because the 2.0 branch isn't getting any more updates...
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
No longer blocks: 415597
You need to log in before you can comment on or make changes to this bug.