Closed Bug 347994 Opened 15 years ago Closed 13 years ago

New mail alert is not displayed (folderSummaryInfoEl.parseFolder is not a function)

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0a3

People

(Reporter: digitrob, Assigned: rkent)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru-RU; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060724 Thunderbird/2.0a1

When new messages arrive the new mail alert popup does not show.

Reproducible: Always

Steps to Reproduce:
1.Simply click get new messages (make sure you have new mail)
2.
3.

Actual Results:  
the mail is delivered, new mail icon appears in the system tray but the pop up alert does not.

Expected Results:  
Pop up alert should have appeared

That is what I get in console after this happens : 

Error: folderSummaryInfoEl.parseFolder is not a function
Source file: chrome://messenger/content/newmailalert.js
Line: 80
Version: unspecified → 2.0
Component: General → Mail Window Front End
Keywords: qawanted
This works for me in a current branch nightly on Windows XP. Are you using any extensions?
Keywords: qawanted
I tried to disable all extensions and still have the same problem
Severity: normal → major
I'm having the same problem (currently using 20060811 build). When I installed TB (did a clean install), the alert was shown a couple of times - since than it has not appeared. Also tried with all extansions disabled.
Matjaz, are you seeing the same error in the JS Console?
Very weird - parseFolder is defined here:

http://lxr.mozilla.org/seamonkey/source/mailnews/base/resources/content/mailWidgets.xml#2041

could it be a xul fastload cache corruption?
I can reproduce this too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Masayuki Nakano, which build are you seeing this in?

When the icon appears but the alert does not, does the alert sound play, or not?  After the icon appears without a popup, does double-clicking the icon show an alert, or not?

Probably not related, but:  I have noticed occasional weirdness where I'll hear the sound (perhaps due to mail, perhaps due to an RSS item arriving) with no icon or alert; sometimes a few seconds later, the icon and alert appear but with no sound.

I've also noticed, once in the past month or so, an icon without an alert but with no new message I could find anywhere in the folder tree; and another time this occurred when a message was moved by a filter (not by junk controls) to the junk folder but left unread (which is expected behavior, I think).
Oh, sorry: I meant to note, that I've mostly been running with a 2.0 nightly build in that period of time.
I'm using latest trunk build.

But I don't see this bug in real time. Because my PC is running 24 hours for other works. Therefore, the error was logged after I left from my desk. However, there is this bug. The error console tells it.
This issue was introduced by mscott with attachment 204075 [details] [diff] [review] on bug 312940. The list of parameters has changed from one to three for this function. 
Henrik, I don't see any callers that aren't passing the right number of arguments to parseFolder on the branch or the trunk. Do you? 
No. Further I cannot reproduce this issue anymore with a trunk or 1.8 branch build. I can always see the notification window and no error is visible inside the Error Console. Anyone who can still see it?
Using a current trunk still shows me the new mail alert. The error described above  will only happen when the first alert message is shown. For further new mail alerts no new error is added to the Error Console.

Is the function definition not loaded when calling it the first time?
Summary: New mail alert is not displayed → New mail alert is not displayed (folderSummaryInfoEl.parseFolder is not a function)
QA Contact: general → front-end
I have the same problem with Thunderbird 2.0.0.4 (20070604)

When new mail arrive, the new mail alert popup doesn't show.
In previous version (with old style popup) this works ok.

The mail is delivered, new mail icon appears in the system tray, alert sound plays. Double-clicking the icon restores Thunderbird window.

Error console:
Error: folderSummaryInfoEl.parseFolder is not a function
Source File: chrome://messenger/content/newmailalert.js
Line: 88

folderSummaryInfoEl.parseFolder(folder, new urlListener(folder), asyncFetch);
(In reply to comment #15)
> I have the same problem with Thunderbird 2.0.0.4 (20070604)
> 
> When new mail arrive, the new mail alert popup doesn't show.
> In previous version (with old style popup) this works ok.
> 
> The mail is delivered, new mail icon appears in the system tray, alert sound
> plays. Double-clicking the icon restores Thunderbird window.
> 
> Error console:
> Error: folderSummaryInfoEl.parseFolder is not a function
> Source File: chrome://messenger/content/newmailalert.js
> Line: 88
> 
> folderSummaryInfoEl.parseFolder(folder, new urlListener(folder), asyncFetch);
> 

Could this be a theme problem?

Please see this (slightly confused) thread on Mozine Forums.

http://forums.mozillazine.org/viewtopic.php?t=560430
Yes! It seems that this is caused by a theme.

I was using a theme called Azerty 'mail 2.2.0.1 and now it works with Thunderbird default theme...

I've found some article on this:
http://forums.mozillazine.org/viewtopic.php?p=2869202&sid=aa3ffc682ee54cc10e6f2afd92a85e3e

Thanks
(In reply to comment #17)
> Yes! It seems that this is caused by a theme.
> 
> I was using a theme called Azerty 'mail 2.2.0.1 and now it works with
> Thunderbird default theme...
> 
> I've found some article on this:
> http://forums.mozillazine.org/viewtopic.php?p=2869202&sid=aa3ffc682ee54cc10e6f2afd92a85e3e
> 
> Thanks
> 

OK: However, I''m sorry that I gave you a totally rubbish link :( You shouldn't have had to hunt!

This time I think it's the one I meant.

http://forums.mozillazine.org/viewtopic.php?t=560297

Was everyone else here using the default theme? Did they mean 'Disabled all extensions' or 'in safe mode'? What happens in default theme/safe mode?

I see from your Mozine link that that originator was already using the default theme, which perhaps confuses the issue but perhaps only in his/her case.
I've been seeing this fairly reliably on a custom TB trunk debug build from CVS 2008-06-28 with some work-in-process changes. I believe it is caused by a race condition, where the xbl for the folderSummary item has not sufficiently loaded by the time the parseFolder function is called. Moving that function to onLoad, as done in the attached patch, solved the problem for me, with no ill effects in spite of the warning in the .xul file. I want to test it just a little more before I ask for review though.
Assignee: mscott → kent
Status: NEW → ASSIGNED
I'm changing the version to trunk based on my experiences. The test environment that is showing the problem is running Windows 2000 in a VMWare server virtual machine.
Version: 2.0 → Trunk
All/All since I see it in Linux, FWIW. I assumed this was a recent deRDFification regression, but apparently not...
OS: Windows XP → All
Hardware: PC → All
Attachment #327468 - Flags: review?(philringnalda)
Comment on attachment 327468 [details] [diff] [review]
Move prefillAlertInfo to onLoad

Bah, I suck. After taking far too long to get around to reviewing this, I realized that the only real way to review it is to try running with it while firing lots of alerts, but since it doesn't actually affect the platform I use, that'll be a problem. David, don't suppose you remember any of the bug 312940 stuff that prompted the current approach?
Attachment #327468 - Flags: review?(philringnalda) → review?(bienvenu)
Hmm, and I failed to notice that most of that's coming from copying what Ben did when he rewrote the download manager's alert service for something like Fx 0.9, so it may actually be working around Gecko bugs from 1.7 that may or may not exist anymore. Fun!
I don't remember anything beyond what's already commented in the code. I'll try running with the patch on Windows, since I have seen this bug from time to time.
Attachment #327468 - Flags: review?(bienvenu) → review+
Comment on attachment 327468 [details] [diff] [review]
Move prefillAlertInfo to onLoad

thx, rkent, this seems to be working better for me too. Fix checked in changeset:   261:4a1534519151
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.0b1
You need to log in before you can comment on or make changes to this bug.