Clicking Back / Forward button label opens dropdown instead of going back in "Icons and Text" mode

RESOLVED FIXED in Firefox 2

Status

()

Firefox
Toolbars and Customization
P1
normal
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Rob Marshall [tH], Assigned: mano)

Tracking

({fixed1.8.1})

2.0 Branch
Firefox 2
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fx2 theme change])

Attachments

(1 attachment, 4 obsolete attachments)

(Reporter)

Description

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060817 BonEcho/2.0b1

In 1.5, the main non-dropmarker part of the back and forward buttons is a nice big target. In the latest nightly, clicking slightly too low pops up the menu instead, with no prior visual indication what will happen when I click.
nominate this for blocking the final release. This could become a problem for many people.
(In reply to comment #1)
> nominate this for blocking the final release. This could become a problem for
> many people.

If you want to nominate the bug to block, you need to set the blocking flag to "?"...
Assignee: nobody → bugs.mano
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox 2
Status: NEW → ASSIGNED
Priority: -- → P1
Please add the Forward button to the summary too, it does the same for the forward label as it does the back label. Thank you.
Summary: Clicking Back button label opens dropdown instead of going back in "Icons and Text" mode → Clicking Back / Forward button label opens dropdown instead of going back in "Icons and Text" mode
Flags: blocking-firefox2?
Created attachment 234903 [details] [diff] [review]
Winstripe bits
Attachment #234899 - Attachment is obsolete: true
Attachment #234903 - Flags: review?(mconnor)
Attachment #234899 - Flags: review?(mconnor)
Created attachment 234905 [details] [diff] [review]
Pinstripe bits
Attachment #234903 - Attachment is obsolete: true
Attachment #234905 - Flags: review?(mconnor)
Attachment #234903 - Flags: review?(mconnor)
Attachment #234903 - Attachment is obsolete: false
Attachment #234903 - Flags: review?(mconnor)
Created attachment 234907 [details] [diff] [review]
Pinstripe bits

argh
Attachment #234905 - Attachment is obsolete: true
Attachment #234907 - Flags: review?(mconnor)
Attachment #234905 - Flags: review?(mconnor)
Attachment #234903 - Attachment is obsolete: true
Attachment #234903 - Flags: review?(mconnor)
Attachment #234907 - Attachment is obsolete: true
Attachment #234907 - Flags: review?(mconnor)
Flags: blocking-firefox2? → blocking-firefox2+
Blocks: 349744
Created attachment 234978 [details] [diff] [review]
patch

This works pretty well on win32 and OS X.

Thanks to gavin and phil for testing the patches here.
Attachment #234978 - Flags: review?(mconnor)
*** Bug 349744 has been marked as a duplicate of this bug. ***
No longer blocks: 349744
Whiteboard: [needs review mconnor]

Updated

12 years ago
Whiteboard: [needs review mconnor] → [Fx2 theme change][needs review mconnor]
Comment on attachment 234978 [details] [diff] [review]
patch

looks good, r+a=me for this branch theme change
Attachment #234978 - Flags: review?(mconnor)
Attachment #234978 - Flags: review+
Attachment #234978 - Flags: approval1.8.1+
1.8 branch:
mozilla/browser/themes/pinstripe/browser/browser.css 1.11.4.31
mozilla/browser/themes/pinstripe/browser/browser.xml 1.3.12.2
mozilla/browser/themes/winstripe/browser/browser.css 1.17.2.41
mozilla/browser/themes/winstripe/browser/browser.xml 1.4.8.3
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [Fx2 theme change][needs review mconnor] → [Fx2 theme change]

Comment 12

12 years ago
Could this bug have screwed up the positioning of the back and forward buttons?  They're now much higher than all other toolbar buttons in build: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060825 BonEcho/2.0b2 ID:2006082504 when showing icons only (small icons).

~B
(In reply to comment #12)
> Could this bug have screwed up the positioning of the back and forward buttons?
>  They're now much higher than all other toolbar buttons in build: Mozilla/5.0
> (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060825 BonEcho/2.0b2
> ID:2006082504 when showing icons only (small icons).
> 
> ~B
> 
The patch fixed the problem, but left a regression. I would recomment filing a regression bug for this. Paste the bug number in here once you do. Thanks.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060825 BonEcho/2.0b2 ID:2006082504

Updated

12 years ago
Depends on: 350183
Filed bug 350183
No longer depends on: 350183

Updated

12 years ago
Depends on: 350183
You need to log in before you can comment on or make changes to this bug.