Closed Bug 403753 Opened 14 years ago Closed 14 years ago

Groupbox should follow GNOME's interface guidelines

Categories

(Toolkit :: XUL Widgets, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.9beta2

People

(Reporter: ventnor.bugzilla, Assigned: ventnor.bugzilla)

References

(Blocks 4 open bugs)

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
On GNOME, groupboxes don't have rounded borders. Instead, it is just a bold heading with a lot of padding for the content. With our goal to feel more native on every platform, this very trivial patch will make a big difference.
Attachment #288643 - Flags: review?(mano)
Comment on attachment 288643 [details] [diff] [review]
Patch

I'll try gavin.
Attachment #288643 - Flags: review?(gavin.sharp)
Comment on attachment 288643 [details] [diff] [review]
Patch

Ugh, I hate reviewing theme stuff :)

Certainly looks good to me, and matches e.g. gedit (had to fire up the old Ubuntu VM!).

(I wonder why the winstripe theme specifies background colors? Seems like it should just not do that. That would probably also fix bug 236107 without the hack that landed there. Separate issue, I guess!)
Attachment #288643 - Flags: review?(gavin.sharp) → review+
Attachment #288643 - Flags: approval1.9+
Keywords: checkin-needed
Version: unspecified → Trunk
RCS file: /cvsroot/mozilla/toolkit/themes/gnomestripe/global/groupbox.css,v
done
Checking in toolkit/themes/gnomestripe/global/groupbox.css;
/cvsroot/mozilla/toolkit/themes/gnomestripe/global/groupbox.css,v  <--  groupbox.css
initial revision: 1.1
done
Checking in toolkit/themes/gnomestripe/global/jar.mn;
/cvsroot/mozilla/toolkit/themes/gnomestripe/global/jar.mn,v  <--  jar.mn
new revision: 1.16; previous revision: 1.15
done
Status: NEW → RESOLVED
Closed: 14 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9 M10
Gavin, 
The reason a background color is specified is because the border shows through the caption if it is transparent.
Oh, I see. I guess that's kind of a sucky problem.
Duplicate of this bug: 403899
This fix sucks pretty much from what I see and destroys any sensible way groupboxes are styled. groupboxes should be styled through nsITheme but not through such senseless, ugly, hacks. Screen shots like attachment 289804 [details] show that group boxes don't even roughly look like anything what a "group box" might suggest, and this defies any statements I've ever read that UI should help the user, because here the UI completely confuses any normal user.

I'm sure this styling is not true for every GNOME theme, and we really should follow the theme through nsITheme and not some random sucky theme one developer has on his machine.
Blocks: 404752
Having this sucky look now on trunk makes me wonder if bug 349859 needs to be made a blocker, as it would correct the look where it doesn't fit right now.
This has nothing to do with the theme, this is following the GNOME HIG.

"Rather than using bordered frames, use frames without borders, bold labels to make the categories stand out, and indented contents. This, combined with good layout and spacing, is usually a better alternative to bordered frames."

http://library.gnome.org/devel/hig-book/stable/controls-frames.html.en

GTK, and thus nsITheme, doesn't provide anything like this which is why its stated so thoroughly in the HIG. Sorry, but this wins out.
Yes, that chapter in their HIG sucks badly, and now I consider being GNOME-based a real bug.
If one creates such weirdness, it should at least be changeable through theming.

At least now we completely don't fit with more than half of the Linux desktops which are not GNOME.
Blocks: 349859
Blocks: 482972
Blocks: 236107
Depends on: 514883
You need to log in before you can comment on or make changes to this bug.