Ability to print all odd/even pages

REOPENED
Unassigned

Status

()

Core
Printing: Output
P3
enhancement
REOPENED
17 years ago
5 years ago

People

(Reporter: Sebastian Späth, Unassigned)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
Future
x86
All
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
What I really miss in NS is the ability to print out all odd/even pages.
Not everyone has a duplex printer.
Would that have to be different handled in Win/Mac/Uninx?

Comment 1

17 years ago
Do we also need "in reverse order" along with "odd/even" in order to quickly
print a document on both sides of a packet?  Or do all printers take paper in
the same way they spit it out?

Would it also require not using the native print dialog?

Comment 2

17 years ago
We need a UI inorder to do this.  I could get this going.. but the print dialogs 
need to notify printing.  Giving to Don Melton to handle this aspect.  When the 
UI is setup to specify this.. I can put in the support.
Assignee: dcone → don

Updated

17 years ago
Target Milestone: --- → Future

Comment 3

17 years ago
This seems like something that should be done by a separate program between the 
browser and the printer, because this would be useful in most applications use 
the printer.  I'd say the same thing about print preview, though, so maybe I'm 
just crazy.
Since Don has left, Vishy is taking his bugs in bulk, pending reassignment.
thanks,
	Vishy
Assignee: don → vishy

Comment 5

17 years ago
*** Bug 59058 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
*** Bug 24523 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Copying helpwanted keyword from duplicate bug 59058.
Keywords: helpwanted

Comment 8

17 years ago
spam : changing qa to sujay (new qa contact for Printing)
QA Contact: shrir → sujay

Comment 9

16 years ago
Is there any CSS style for this, and should there be?

Comment 10

16 years ago
Shouldn't this functionality be part of the OS or printer software?  It seems 
silly for each app to do it...

Updated

15 years ago
Blocks: 125824

Comment 11

15 years ago
Reassigning to a real person.
Assignee: vishy → rods

Updated

15 years ago
Summary: [RFE] Ability to print all odd/even pages → Ability to print all odd/even pages

Comment 12

14 years ago
*** Bug 221683 has been marked as a duplicate of this bug. ***

Comment 13

13 years ago
Stating the obvious just in case, note that the function ought to work for
specially selected page ranges (ex. pgs 4-9) as well as for a whole document. 
Hope this function goes in :)
*** Bug 265802 has been marked as a duplicate of this bug. ***
*** Bug 310540 has been marked as a duplicate of this bug. ***

Comment 16

11 years ago
Jesse asked (years ago) whether odd/even printing shouldn't be handled by another app. There are lots of ways to print that way in the OS, at least in Linux.

But in firefox, at least, there's no way (through the UI) to modify the print function to pass a duplex or page argument to the printing system, and there's no way I can find (even by editing prefs.js) to add other virtual printers that set the cups arguments page-set=odd or page-set=even.
Assignee: rods → printing
QA Contact: sujay

Comment 17

11 years ago
It *was* working with Firefox 1.0.x.

With Firefox 1.0.x, the printer properties dialog was fairly crude. You
couldn't set many options, but one thing you could do was type any command line
arguments into a box and get pretty much any print-time option you knew the
command flag for.

Under Firefox 1.5 printer properities dialog is a lot cleaner -- and a lot
barer. I can now choose paper size, margins, and between grayscale and color.
That's it. No command line box, no stretch, no tray selection. If I want to use
duplex printing, for example, I'm out of luck. 

It's probably a lot to ask to request that the print dialog box have provision
for every possible option that a printer might have (as a Windows dialog might
have, or OpenOffice, or Acrobat or...)

But that's ok.  If we can just have the command line box back, you can take
your time getting us printer specific options.

Please?

Comment 18

11 years ago
Just a little note, I recently discovered a quite pleasing feature in my HL-1440 Laser Printer. Print > Properties > Advanced > Duplex and voila. The print driver handles the even/odd page printing for itself, even though it doesn't have an actual duplex module. I suspect that other printers have similar features.

Comment 19

10 years ago
My own inkjet printer, an HP Deskjet 1200C which uses the LaserJet 4 command set (customized for color) and PCL5, does NOT have a duplex setting, as nearly as I can determine.  In the early 1990s, this printer was very "high end" --- my recollection is that its list price exceeded $2,000, and that I bought mine on an academic discount for about $1200.

So I'm not sure that most recent printers, given that they are much less expensive, have a Duplex printing setting. 

In any case, my view is that Firefox and SeaMonkey (the latter being what I am using) do need an odd-or-even page setting.  Adobe Reader, WordPerfect, and MS Word all have it.

Without it, I must issue a series of single page print commands for page 1, 3, 5, 7, etc., and then and then issue a series of commands to print page 2, 4, 6, 8, etc.

Especially for long documents (such as some newsletters I receive), it would be a major convenience to be able to print all of the odd pages with one command, and then to print all of the even pages with one command.

Comment 20

9 years ago
This was fixed by the patch for bug 193001, which includes options for duplex and odd/even printing.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
That's swell that this bug is fixed for Linux, but it sure isn't fixed for Windows...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Assignee: printing → nobody
QA Contact: printing

Updated

7 years ago
Duplicate of this bug: 573677

Comment 23

7 years ago
"""I found a way to print even only / odd only pages on any OS """""


Go to the about:config and filter for print. Find the options for the particular printer you want to use (if you have several, like I do) and then look for the name that ends on "evenpages" and for the one that ends on "oddpages". Currently they both are set to "true" but if you, for instance, set the "oddpages" one to false, only the even pages would print; and vice versa

********************************************************************************
You need to log in before you can comment on or make changes to this bug.