Thunderbird keeps crashing while open, but idle in background [@ morkNode::CutStrongRef]

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: mlkisler, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

From Error Console: Error: undefined entity
Source File: chrome://communicator/content/contentAreaContextOverlay.xul
Line: 108, Column: 7
Source Code:
      <menuitem id="context-reloadimage"

This happens at least twice per day, and has been occurring for the past 3-5 days

Reproducible: Sometimes

Steps to Reproduce:
1.Open Thunderbird and leave it running in the background
2.Wait for crash
3.

Actual Results:  
It contines to happen at least twice per day...Sometimes more

Expected Results:  
Not Crashed. Remain open in idle state

It just keeps giving me a message box stationg that "Thunderbird has encountered an error and has to close". I made a screen capture of the actual error message, which I will be happy to email to you on request:  mlkisler@comcast.net
Posted image Detailed Bug Report
Please be gentle...This is my first bug report  :)
T-Bird Version: version 3 alpha 1 (20060911)
Is Talkback (the error reporter) installed and does it startup when you crash? If so, can you get incident id's from it?
More information on Talkback is available here: http://kb.mozillazine.org/Talkback.
Severity: normal → critical
Keywords: crash
Version: unspecified → Trunk
I'm not familiar with talkback - I don't think it's installed. I'll see if I can find an extension for it.
Look in Tools > Extensions. If it's not there, you don't have it installed. The best thing to do if it's not installed is to grab a build that has Talkback and reinstall. Those builds should be in latest-nightly/ on FTP.
alkback now installed. Thanks for the link!
Possibly related to bug 243701.
Depends on: 243701
I've been seeing this intermittently too. Just managed to catch it in the debugger, will add a stack trace.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Posted file Stack trace
Here's the stack trace of my crash. The string contained the host name os it was probably nsImapProtocol::m_hostName.
unfortunately, this looks like a memory trounce, so the stack trace doesn't show where the error was - I don't know if the entity error is related - seems unlikely.
Agreed. I'll keep running in debugger just in case I manage to catch something..
I have the exact same problem here (lately). System info:
- Windows XP-SP2 (32 bit)
- Thunderbird 1.5.0.9 (but previous versions also suffer from this problem).
- Server side: Courier IMAP (without FAM) on Debian 3.1 Linux

I always leave my work computer running at night and lately, when I come back in the morning, Thunderbird has crashed everytime. The odd thing is that I didn't have this problem in the past, although I doubt it has to do with my computer/Windows. Additionally several Windows 2000 users here reported that Thunderbird crashes once in a while, after first consumming all available memory (and bringing the system down to its knees). I think this is related.
Same problem here, since I came back from vacation on Monday.
WinXP SP2, T'Bird 2.0.0.4 with Talkback installed.  I've sent several Talkback reports of it.  Sometimes the crash happens when I restore the T'Bird window from the task bar, sometimes it gets that far but then crashes when I try to create or read a message.  The crashes only happen when T'Bird has been running in the background for a while.
Can anyone please give us the list of talkback ids? That would be really helpful.
Possible clue:  see my last comment on bug 314413.
Oh, never mind.  T'Bird just crashed again, after being in the background for a while...
Stuart, do you see the talkback agent? Please send the crash report and give us the incident id. Have a look at http://kb.mozillazine.org/Talkback if you don't know how to do that.
TB34304393G, TB34300869M, TB34226526G, TB34223880Q, TB34222799Y, TB34220815M, TB34220485W, TB34219609M, TB34219258E, TB34218499G
TB34804984H, TB34804577M, TB34797743G, TB34766703H

A couple of these happened while I was composing a message.  In other words, not immediately after returning to T'Bird from other applications, but some time afterward (5 minutes at least, because drafts are saved and Autosave is set to 5 minutes).

This is a REALLY ANNOYING bug.
Stuart, do you have any extensions enabled?
TB34827082Y, TB34825931Y

Add-ons:  

addressContext 0.8.1
Image Zoom 0.3
Talkback 2.0.0.6
It's pretty likely this is caused by the addressContext extension. Can you try disabling it? It may be doing something wrong, or just exposing some problem in the Thunderbird core...
OK. Disabled, restarted T'Bird.  Drumroll.............
TB34829478W

Nope, that didn't help.

Used other programs, returned to T'Bird, double-clicked a message to open it.  No response.  Closed program window, got crash/Must Close Program dialog.
that's a different stack trace then the ones from comment #23
TB34835363H

during sending of message with attachment.
TB34835727Y

Sent the message again, successfully.  Walked away from the computer for a few minutes, leaving T'Bird in foreground.  Came back and moved the mouse.  Crash.
Stuart, all these incident ids have a different stack trace. Please start Thunderbird in Safe Mode which will disable all extensions. If the crash happens again then we can be sure it isn't produced by an incompatible or malfunction extension.
When the program crashed this morning, TB34906141W, I started it up again in Safe Mode.  (My Program shortcuts include running "without extensions" and also "safe mode".  I picked Safe Mode as you requested.)   The program just crashed again; I had returned to it from another application and double-clicked on a message header to open it.  Got no response, clicked the Window close "X" and got the crash dialog box.  There is no talkback ID, I guess because of safe mode?
David, do we want to mark 'morkNode::CutStrongRef' as top frame of that bug? It seems that this is a stack which happens regulary in different incident ids.

Stuart, can you reproduce it with special messages or does the crash randomly appear?
It's completely random, as far as I can tell.  Sometimes it crashes when I try to open a message, sometimes it crashes as soon as I bring the program window to the front -- before I can click anything -- sometimes while I'm half-way through composing a message.
Stuart, still see this?

adding morkNode::CutStrongRef to summary - but stack from comment 31 is gone.
dropping bug 243701 dependency
Assignee: mscott → nobody
No longer depends on: 243701
Summary: Thunderbird keeps crashing while open, but idle in background → Thunderbird keeps crashing while open, but idle in background [@ morkNode::CutStrongRef]
Now running version 2.0.0.14 (20080421) -- haven't had the problem for a long, long time.  Guess it got fixed in one of the intermediate updates...

thanks,

Stuart
=> WFM  (and fixed prior to 2.0.0.6 or there abouts)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ morkNode::CutStrongRef]
You need to log in before you can comment on or make changes to this bug.