Last Comment Bug 359007 - Event printed multiple times with same time if it is a multiday event
: Event printed multiple times with same time if it is a multiday event
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Printing (show other bugs)
: Trunk
: All All
-- normal (vote)
: 4.4
Assigned To: Decathlon
:
:
Mentors:
: 423863 550859 1177200 (view as bug list)
Depends on: 1201838
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-31 23:40 PST by lambert
Modified: 2015-09-04 03:52 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch - v1 (4.34 KB, patch)
2015-06-26 02:49 PDT, Decathlon
philipp: review+
Details | Diff | Splinter Review

Description User image lambert 2006-10-31 23:40:44 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061031 Calendar/0.4a1

If an event is created over midnight (e.g. from 10 p.m. till 9 a.m.) and this event is printed with the "Monthly Grid" layout, this event is displayed on both days, but with the same entry, like "10 p.m. Eventname". If you see the print out this one event would appear as two events on two successive days.

Reproducible: Always

Steps to Reproduce:
1.Create an event from day1 10 p.m. to day2 6 a.m.
2.File - Print - Layout: Monthly Grid


Actual Results:  
You can already see the problem in the print preview.

Expected Results:  
Generally I would expect a from - to display of events and not only the start time.
Having this from - to display I would expect for one-day events a display like that:
06:00am
Event
09:00am
or something like that

For the situation described above I would suggest:
day1:
10pm
Event

day2:
Event
9am

There is a similar problem in the weekly view, which will go together with this bug. The only difference is, that the weekly view already displays from-to times.
(Maybe the print layout like from time, to time, etc. can be customized in the future, so everyone can adjust his own settings depending on how detailed the information should be -> My purpose is some kind of monthly overview of a working schedule and thus it has to include the times).
Comment 1 User image Martin Schröder [:mschroeder] 2006-11-04 12:43:25 PST
Confirmed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061103 Calendar/0.4a1.

This is a problem in Monthly Grid and Weekly Planer.
Comment 2 User image Stefan Sitter 2008-03-19 10:48:58 PDT
*** Bug 423863 has been marked as a duplicate of this bug. ***
Comment 3 User image Stefan Sitter 2010-03-08 07:04:48 PST
*** Bug 550859 has been marked as a duplicate of this bug. ***
Comment 4 User image Stefan Sitter 2015-06-24 20:08:36 PDT
*** Bug 1177200 has been marked as a duplicate of this bug. ***
Comment 5 User image manuel.knitza 2015-06-24 21:02:02 PDT
wow.... persisting for almost 9 years and no traces for attempts to fix...
Comment 6 User image Decathlon 2015-06-26 02:49:21 PDT
Created attachment 8626487 [details] [diff] [review]
patch - v1

If I don't miss something, this should work.
It displays multiday events in the same way of the month view with the arrows for start, end and "middle" positions.

Is there a simple way to avoid using the code for the unicode arrows characters? If I set the strings by using directly the arrow characters (the same used in the calendar-month-view.xml) they are not displayed correctly in the print preview.
Comment 7 User image Philipp Kewisch [:Fallen] 2015-07-16 05:17:11 PDT
Pushed to comm-central changeset 572e71f97c22
Comment 8 User image Philipp Kewisch [:Fallen] 2015-07-16 05:22:42 PDT
I don't think there is a more simple way for the unicode characters. In theory using the symbols directly should show the right characters, but if that doesn't work then the code is the right way to go.
Comment 9 User image Stefan Sitter 2015-09-04 03:52:34 PDT
This change broke task printing, see Bug 1201838.

Note You need to log in before you can comment on or make changes to this bug.