Closed Bug 360951 Opened 15 years ago Closed 13 years ago

OS X integration: iCal integration

Categories

(Thunderbird :: General, enhancement, P5)

PowerPC
macOS
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 242937

People

(Reporter: mdudziak, Unassigned)

Details

(Whiteboard: [penelope_wants])

We've had several requests for iCal integration, though none of the requests specify exactly what _sort_ of integration. This bug is a placeholder for generic iCal integration. Please add comments to this bug specifying what sort of integration you would like to see between Penelope and iCal.
I'd like Eudora to be able to handle iCal reminders.  I never use the iCal reminders now because only Mac Mail can handle them.
I occasionally get mail messages inviting me to meetings, and containing some sort of attachment describing the event. In Mail, this gets put into iCal. The same functionality in Penelope would be useful.
Lets stick to moving Eudora features into Penelope and leave the calendering features up to the Thunderbird folks for now.  
(In reply to comment #2)
> I occasionally get mail messages inviting me to meetings, and containing some
> sort of attachment describing the event. In Mail, this gets put into iCal. The
> same functionality in Penelope would be useful.

I'm not at all sure, but I THINK I remember reading somewhere that this is a function of iCal's support for the kind of invitations that Outlook issues. And it may be as simple as passing off that kind of attachment to iCal to handle, whenever one is received. I agree this would be quite useful.

Status: NEW → ASSIGNED
iCal integration with Mail.app is done via filetype mapping and AppleScript;

1. Attachments in iCalendar or vCalendar format (ics and vcs extensions, text/x-vCalendar and text/calendar MIME types) are treated by the OS as iCal documents, and opening them from any app that uses the OS's filetype mapping will launch iCal. If, like TBird, you ignore the system  and maintain your own list of such mappings, you can do the right thing yourself. 

2. There is a set of scripts inside the iCal application package that are called when you click the verious iCal buttons to send various sorts of mail to event participants or organizers. These scripts are specific to Mail.app. It is possible to replace those with scripts that drive Classic Eudora, and if TBird/Penelope was scriptable there could be scripts written to make iCal drive it instead. 

On windows it would be nice to support Content-Type text/calendar (and similar:  http://filext.com/file-extension/VCS) as VCS file attachments.  At the moment I get outlook requests from people and get all the text in the body of the message.  If I simply save it as a file with .vcs extension (headers and all) I can double click and the OS opens the right application associated with the VCS extension.

It would eliminate the multiple steps of saving a file, etc if Eudora would give me something to click on in the read window.  I think it would be most intuitive to offer an attachment, perhaps named <email subject>.vcs.
For whatever it may be worth, the MacOS TBird-based Eudora already does behave in the right way as you describe, given the right filetype mapping in the OS: double-click a text/calendar attachment, and  iCal is opened. That implies that what is not working for you is something specific to Windows.  

Maybe that justifies opening a different bug or maybe it isn't a Eudora issue at all but really a Windows issue, but either way, it really isn't in scope for THIS bug, which is about a particular MacOS functionality (mail integration support in the iCal application) that can be hooked into the current Eudora because Eudora is scriptable via Apple's Open Scripting Architecture, but cannot yet be hooked into anything TBird-based because TBird lacks any OSA support. 



(In reply to comment #6)
> On windows it would be nice to support Content-Type text/calendar (and similar:
>  http://filext.com/file-extension/VCS) as VCS file attachments.  At the moment
> I get outlook requests from people and get all the text in the body of the
> message.  If I simply save it as a file with .vcs extension (headers and all) I
> can double click and the OS opens the right application associated with the VCS
> extension.
> 
> It would eliminate the multiple steps of saving a file, etc if Eudora would
> give me something to click on in the read window.  I think it would be most
> intuitive to offer an attachment, perhaps named <email subject>.vcs.
> 

Hmmm ... I might not have understood the original bug description.

In windows you can double click an attachment just as you describe.  However the issue is that there's no attachment.  The vcs file comes through as text in the body.  I thought that's what this bug was describing.  If not, I'll open a new one, which BTW I think is really a feature request.  But if it gets higher priority, then bug is good, too!  :)
Priority: -- → P5
Assigning to Thunderbird as this is not unique to Penelope.
Assignee: mozilla-bugs → nobody
Status: ASSIGNED → NEW
Product: Penelope → Thunderbird
QA Contact: general → general
Whiteboard: [penelope_wants]
Version: unspecified → Trunk
So iCal is calendar... doesn't this make it a Calendar bug, not Thunderbird?
The issue is that Thunderbird (penelope for me) does not recognize an ical as an attachment.  So it displays the attachment contents in the message window.  Many hoops must be jumped through to get it to a useful attachment.

I believe the mimetype is text/calendar.
This is two separate bugs: bug 242937, the poorly-summarized "I want to have text/calendar attachments not display inline even when I've asked to have attachments displayed inline" and the various vaguely-specified bugs in the orbit of bug 243543, bug 125419, bug 352254, bug 287345 and bug 61356 about getting sufficient Applescript support to be able to create an outgoing email with an attachment. Easier to dupe to a single bug than a swarm, so I'm going that way rather than to the Applescript meta bug.
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 242937
You need to log in before you can comment on or make changes to this bug.