Last Comment Bug 361682 - Remove "turbo mode" from suiterunner builds
: Remove "turbo mode" from suiterunner builds
Status: RESOLVED FIXED
: relnote
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: seamonkey2.0a1
Assigned To: Bruno 'Aqualon' Escherl
:
Mentors:
: 383161 (view as bug list)
Depends on:
Blocks: 146340 148194 suiterunner
  Show dependency treegraph
 
Reported: 2006-11-23 10:57 PST by Mark Banner (:standard8)
Modified: 2009-04-17 10:41 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Remove "turbo mode" related code from suite/ (27.30 KB, patch)
2007-09-29 17:29 PDT, Bruno 'Aqualon' Escherl
kairo: review+
neil: superreview+
Details | Diff | Review
Remove Quick Launch from help files (8.82 KB, patch)
2007-09-29 17:33 PDT, Bruno 'Aqualon' Escherl
no flags Details | Diff | Review
Remove "all" Quick Launch from help files (9.74 KB, patch)
2007-09-30 10:28 PDT, Bruno 'Aqualon' Escherl
stefanh: review+
neil: superreview+
Details | Diff | Review
Remove Quick Launch from help including review comments (9.92 KB, patch)
2007-09-30 12:24 PDT, Bruno 'Aqualon' Escherl
bugzilla: review+
bugzilla: superreview+
Details | Diff | Review

Description Mark Banner (:standard8) 2006-11-23 10:57:10 PST
Turbo mode won't work with suiterunner builds on windows or macs (never implemented on linux I believe).

We need to either

a) remove the dialogs/code completely (and hence drop support for it)
b) find a way to hook in before profile selection and restore the turbo mode functionality.
Comment 1 Robert Kaiser (not working on stability any more) 2006-11-23 11:50:48 PST
I think the real turbo mode is something we probably should remove, but with something like that "minimaize to try" stuff and bug 325353 we could probably build a modern replacement for it...
Comment 2 Wayne Mery (:wsmwk, NI for questions) 2007-02-13 12:05:52 PST
(In reply to comment #1)
> I think the real turbo mode is something we probably should remove, but with
> something like that "minimaize to tray" stuff and bug 325353 we could probably
> build a modern replacement for it...

and there is also SM 1.1. breakage - bug 367756, etc. 

Someone (Chris?) mentioned QL/turbo on IRC whether QL should be fixed / obsoleted - probably a timely idea.  Could even 1/4 of the 70** or so open bugs could be addressed? There is a general quality issue - as the "turbo factor" makes triage and repair of SM bugs generally more difficult. Moving to a tray utility from that perspective alone is a good idea. 

BTW, does the thunderbird tray, icon, toolkit bug 325353 obsolete the unfinished tray bug 115348?

** open bugs:
in addition to the core QL bugs, there are 
https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=allwordssubstr&short_desc=&product=Mozilla+Application+Suite&long_desc_type=substring&long_desc=turbo&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&resolution=---&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=trivial&bug_severity=enhancement&op_sys=All&op_sys=Windows+95&op_sys=Windows+98&op_sys=Windows+ME&op_sys=Windows+NT&op_sys=Windows+2000&op_sys=Windows+XP&op_sys=Windows+Server+2003&op_sys=Windows+Vista&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=short_desc&type0-0-0=anywords&value0-0-0=turbo+quicklaunch+QL&field0-0-1=longdesc&type0-0-1=anywordssubstr&value0-0-1=turbo+quicklaunch+QL
and the old meta bug 108795
Comment 3 Robert Kaiser (not working on stability any more) 2007-06-04 11:15:45 PDT
Morphing the bug description into removing "turbo mode".

If we want to follow the path I pointed to in comment #1, we should file a new bug about that. The old turbo stuff needs to go away though.
Comment 4 Worcester12345 2007-06-04 12:29:08 PDT
I just found this bug, and seeing mine at Bug 383161 – keep in memory (turbo mode?) for faster startup not working

we can probably mark 361682 as fixed.
Comment 5 Robert Kaiser (not working on stability any more) 2007-06-04 18:13:07 PDT
*** Bug 383161 has been marked as a duplicate of this bug. ***
Comment 6 Robert Kaiser (not working on stability any more) 2007-09-29 09:08:20 PDT
Hmm, it would be nice if someone could pick this up and remove the turbo stuff for now, it's just unused cruft nowadays.
Comment 7 Bruno 'Aqualon' Escherl 2007-09-29 17:29:46 PDT
Created attachment 282859 [details] [diff] [review]
Remove "turbo mode" related code from suite/

This patch removes code related to "turbo mode" from suite/ (excluding the Help files, those will be changed in an extra patch).

What's also missing from the patch is the removal of /suite/themes/classic/communicator/icons/turbo-systray.gif and /suite/themes/modern/communicator/icons/turbo-systray.gif (haven't figured out, how to remove those with cvsdo remove).
Comment 8 Bruno 'Aqualon' Escherl 2007-09-29 17:33:51 PDT
Created attachment 282860 [details] [diff] [review]
Remove Quick Launch from help files

This patch removes all occurrences of quick launch from the help files.

What should probably go into another bug is the problem, that we only have "Enable Java" in the Advanced pref pane after quick launch is removed. Perhaps that should be moved somewhere else and Advanced should contain an explanatory text like Privacy & Security.
Comment 9 Stefan [:stefanh] (away until May 28) 2007-09-29 18:47:13 PDT
(In reply to comment #7)

> (haven't figured out,
> how to remove those with cvsdo remove).

I might be wrong, but I think you can just do a diff once you've done the cvsdo remove.

I won't be able to look at this until I have my new hardware (should get it next week, though)

Comment 10 neil@parkwaycc.co.uk 2007-09-30 04:12:23 PDT
Comment on attachment 282859 [details] [diff] [review]
Remove "turbo mode" related code from suite/

(In reply to comment #7)
>(haven't figured out, how to remove those with cvsdo remove).
You can't really, they're binary files, the best you can do is generate "Binary files surbo-systray.gif and /dev/null differ".

(In reply to comment #8)
>What should probably go into another bug is the problem, that we only have
>"Enable Java" in the Advanced pref pane after quick launch is removed.
That's not true on Linux, where iirc you have JVM and system preferences.
Comment 11 Bruno 'Aqualon' Escherl 2007-09-30 10:28:46 PDT
Created attachment 282895 [details] [diff] [review]
Remove "all" Quick Launch from help files

Missed one occurence, thx stefanh!

Neil, do you have Windows to have a look at the sight from a windows user? Stefanh won't see the win related changes in the help files and can only check if it looks ok in non-windows systems.
Comment 12 Robert Kaiser (not working on stability any more) 2007-09-30 10:31:30 PDT
Comment on attachment 282859 [details] [diff] [review]
Remove "turbo mode" related code from suite/

Looks good to me, though I can't test this on Windows.
Comment 13 Stefan [:stefanh] (away until May 28) 2007-09-30 10:58:59 PDT
Comment on attachment 282895 [details] [diff] [review]
Remove "all" Quick Launch from help files

-    <p>Once &brandShortName; Mail has been started, the new message alert will
-      continue to work even after you close the Mail window (as long as another
-      &brandShortName; application is running).</p>
+    <p>If any &brandShortName; application is running the new message alert will
+      continue to work even after you close the Mail window.
+    </p>

Keep the old sentence, but remove the "Once..." section: "The new message alert will
-      continue to work even after you close the Mail window (as long as another
-      &brandShortName; application is running)."

r=me by code inspection only
Comment 14 Stefan [:stefanh] (away until May 28) 2007-09-30 11:01:53 PDT
Not sure what happened with the last post, but here's a clarification:

"The new message alert will continue to work even after you close the Mail window (as long as another &brandShortName; application is running)."
Comment 15 Stefan [:stefanh] (away until May 28) 2007-09-30 11:16:30 PDT
Comment on attachment 282895 [details] [diff] [review]
Remove "all" Quick Launch from help files

>Index: suite/locales/en-US/chrome/common/help/cs_nav_prefs_advanced.xhtml
>===================================================================
>RCS file: /cvsroot/mozilla/suite/locales/en-US/chrome/common/help/cs_nav_prefs_advanced.xhtml,v
>retrieving revision 1.49
>diff -u -8 -p -r1.49 cs_nav_prefs_advanced.xhtml
>--- suite/locales/en-US/chrome/common/help/cs_nav_prefs_advanced.xhtml	16 Jun 2007 13:53:36 -0000	1.49
>+++ suite/locales/en-US/chrome/common/help/cs_nav_prefs_advanced.xhtml	30 Sep 2007 17:00:28 -0000
>@@ -47,27 +47,22 @@
> 
> <ol>
>   <li>Open the <span class="mac">&brandShortName;</span>
>     <span class="noMac">Edit</span> menu and choose Preferences.</li>
>   <li>Click the Advanced category.</li>
> </ol>
> 
> <p>The main Advanced preferences panel allows you to enable or disable
>-  Java<span class="win"> and Quick Launch</span>:</p>
>+  Java:</p>
> 
> <ul>
>   <li><strong>Enable Java</strong>: Select this to allow &brandShortName; to
>     interpret pages containing Java. Java is used on some Web page to
>     incorporate interactive and multimedia content.</li>
>-  <li class="win"><strong>Keep &brandShortName; in memory to improve startup
>-    performance</strong>: Select this if you want to shorten the time it takes
>-    to start &brandShortName;. See
>-    <q><a href="nav_help.xhtml#using_quick_launch">Using Quick
>-    Launch</a></q> for more information about using Quick Launch.</li>
>   <li class="unix"><strong>Use Preferences from System</strong>: Select this to
>     use the already set system preferences, overriding &brandShortName;&apos;
>     ones.
> 
>     <p><strong>Note</strong>: This option is available only in XFT/GTK2
>       builds.</p>
>   </li>

Sorry, forgot to say that you should also remove the last paragraph (the XFT/GTK2 one) here.
Comment 16 Bruno 'Aqualon' Escherl 2007-09-30 12:24:55 PDT
Created attachment 282904 [details] [diff] [review]
Remove Quick Launch from help including review comments

Addressed review comments from stefanh, carrying over r/sr.
Comment 17 Bruno 'Aqualon' Escherl 2007-09-30 13:33:40 PDT
Checked in by Standard8. I'll have to check if some other code is still influenced by Quick Launch, but that can be done in other bugs -> RESOLVED FIXED.
Comment 18 Sven Grull 2007-10-01 00:31:32 PDT
I think this should be mentioned in the release notes for the shipment of SeaMonkey 2.0 to avoid new bugs like "turbo mode is missing / does not work".
Comment 19 Worcester12345 2007-10-06 22:49:37 PDT
(In reply to comment #18)
> I think this should be mentioned in the release notes for the shipment of
> SeaMonkey 2.0 to avoid new bugs like "turbo mode is missing / does not work".
> 
Which can be duped to: Bug 383161 – keep in memory (turbo mode?) for faster startup not working
Comment 20 Charles 2008-01-05 03:18:49 PST
I really don't understand why turbo mode was removed. Seamonkey is slow again at startup. It was one of the few features that made me switch from Opera to Seamonkey. Nowadays, computers have plenty of RAM and preloading applications makes sense, as RAM is faster than HDDs. Is there a way to reimplement it and to disable it by default? This way everybody would be happy again.
Comment 21 Mark Banner (:standard8) 2008-01-05 04:12:08 PST
(In reply to comment #20)
> I really don't understand why turbo mode was removed.

SeaMonkey has switched to a new toolkit, the old one supported turbo mode, the new one currently does not. The switch was required for many reasons that have already been posted elsewhere. The code that was left over, was removed by this bug as it was just "dead" code.

> Is there a way to reimplement it and
> to disable it by default? This way everybody would be happy again.

See comment 1 for some suggestions. Currently though, no-one has volunteered to do or offered any patches for this feature.

Note You need to log in before you can comment on or make changes to this bug.